HAM RADIO DELUXE PTT


Mark Gottlieb <kk2l@...>
 

Happy New Year All,

I have used HRD for the last 5 years.  This experience, with the software, has been with my ANAN and FLEX radios  I have set it up, for my ELAD FM DUO, as a TS480 using the dedicated Port from the radio and 38.  I have no problem with audio/decode and I am able to set up the HRD radio to TX when I press that button.  I also have rig control for all settings and am able to change bands etc using HRD.  However, when I attempt to send a signal on DM780, the radio is not keying up.  I do have the PTT, in Program Options, set for HRD connection.  This has usually been enough, in my past experience, to get it going.  Am I missing something?  I am using Win10 and all other features of HRD are operational relating the FM DUO.

73

Mark KK2L


Neil Smith G4DBN
 

Hi Mark, does the software have a proper Elad driver as well as the TS480?  Most things using Hamlib have implemented the latest version which supports the native driver.  Does HRD send a PTT command using CAT, or does it set the RTS line on the CAT port, or something else?  The buggy Hamlib TS480 driver has a race condition which means it hangs or loses track of the state of the radio.  Some of the TS480 emulations are perfectly OK though (Fldigi for instance).  Does the program specify what sort of command is sent?  If it is RTS, you need to set Menu 54 on the DUO to PTT=IN+RTS.

I guess some of the HRD users on the users on the list will come up with better suggestions.

Neil G4DBN
http://g4dbn.uk

On 01/01/2020 21:18, Mark Gottlieb wrote:
Happy New Year All,

I have used HRD for the last 5 years.  This experience, with the software, has been with my ANAN and FLEX radios  I have set it up, for my ELAD FM DUO, as a TS480 using the dedicated Port from the radio and 38.  I have no problem with audio/decode and I am able to set up the HRD radio to TX when I press that button.  I also have rig control for all settings and am able to change bands etc using HRD.  However, when I attempt to send a signal on DM780, the radio is not keying up.  I do have the PTT, in Program Options, set for HRD connection.  This has usually been enough, in my past experience, to get it going.  Am I missing something?  I am using Win10 and all other features of HRD are operational relating the FM DUO.

73

Mark KK2L


Mark Gottlieb <kk2l@...>
 

Hi Neil,

I tried your suggestion of Menu#54 using RTS+IN.  However, when I open HRD, using this setting, the radio immediately goes into TX.   When taken out of TX, the radio will still not transmit when I attempt to send a macro CQ in DM780.   Your idea, however, worked great for FL Rig/FL Digi.  Thanks for the suggestion.

Mark
KK2L


Neil Smith G4DBN
 

OK, sounds like HRD just sets RTS by default.  I guess there isn't an option to use serial port PTT? 

If there is a way to debug or log the CAT stream in HRD, it might be useful to see what is actually being sent to the DUO, but perhaps simpler to wait for an HRD user to chime in with the real answer.

Neil

On 01/01/2020 21:42, Mark Gottlieb wrote:
Hi Neil,

I tried your suggestion of Menu#54 using RTS+IN.  However, when I open HRD, using this setting, the radio immediately goes into TX.   When taken out of TX, the radio will still not transmit when I attempt to send a macro CQ in DM780.   Your idea, however, worked great for FL Rig/FL Digi.  Thanks for the suggestion.

Mark
KK2L
-- 
Neil
<a href="http://g4dbn.uk/"><small>g4dbn.uk</small></a>


Heinz-Juergen Kronemeyer
 

It's a long time ago that i used HRD/DM780 and a TS-480. As far as i know, the TS-480 Command Set has two TX-Commands. One TX-Command awaits Audio from the Mic-Port, the second one awaits Audio from the Digi-Port. In DM780, i did not set TX via HRD, i set its own TX-Command via CAT. As if you use DM780 Standalone. I think you will find two TX-Commands in DM780. One of them should work.

DO1YHJ  Heinz-Juergen


Mark Gottlieb <kk2l@...>
 

Hi,

I did attempt to use DM780 standalone without HRD control window.  I found I could manually click on the TX button and the radio would go into TX.  However, when attempting to send macro message, radio is still not going into TX,
Thanks for your input.

Mark
KK2L


Heinz-Juergen Kronemeyer
 

Hmm, that sounds more like a problem with the Macro Language. Maybe a missing TX-Tag?

DO1YHJ
Heinz-Juergen

Hi,

I did attempt to use DM780 standalone without HRD control window. I found I could manually click on the TX button and the radio would go into TX.  However, when attempting to send macro message, radio is still not going into TX,
Thanks for your input.


Mark Gottlieb <kk2l@...>
 

I was using the default Macros that come with the software.  I have been using FLDIGI for the last 3 years so I am forgetting what the HRD macros should look like but I know there are no TX tags in HRD macros.  There is a <stop> tag to end TX however.  This is a typical sample for HRD:

CQ CQ de <my:callsign> <my:callsign>
CQ CQ de <my:callsign> <my:callsign>
PSE K <stop>

Maybe someone can advise if I am understanding this correctly,

73

Mark
KK2L


PF1JM
 

Hello Mark,

Maybe I can be of some assistance...

First, you need a virtual com port splitter (I use the paid version of Virtual Serial Ports Emulator), so HRD and DM780 can use the same com port.
In Windows hardware settings, I renamed the port connected to the DUO COM12, in VSPE I made a splitter: virtual COM2 directed to data port COM12. Make sure RTS and DTR are unticked! Under settings, set port speed to 38400.

In HRD, select TS480, COM2, CTS, DTR and RTS must be unticked, select Speed 38400.

In DM780 I do not use PTT via HRD, but via com port (COM2). Set RTS (see attachment). That should do the trick.
If not, check the tick box "Send immediately" in the Macro submenu (right click on for example "CQ x 2")

73, Jeroen PF1JM


Alain Reiner <alain@...>
 

hello Mark,

Did you solve the issue ?

If no, I am using the same configuration than you, it's well working. I could list some points to check. Let me know.

73, Alain F4HFS.



Le 02/01/2020 à 11:49, Mark Gottlieb a écrit :
I was using the default Macros that come with the software.  I have been using FLDIGI for the last 3 years so I am forgetting what the HRD macros should look like but I know there are no TX tags in HRD macros.  There is a <stop> tag to end TX however.  This is a typical sample for HRD:

CQ CQ de <my:callsign> <my:callsign>
CQ CQ de <my:callsign> <my:callsign>
PSE K <stop>

Maybe someone can advise if I am understanding this correctly,

73

Mark
KK2L

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L


Alain Reiner <alain@...>
 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS


Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :
Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS

Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L



-- 
Alain Reiner


Alain Reiner <alain@...>
 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD
              connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD
              program options

4) DM780 program options

DM780
              program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780
              TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS

Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L



-- 
Alain Reiner

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

Thank you for these ideas.  I haven’t checked on them.  The fact that I’m experiencing the same problems with two different radios indicates that I have overlooked something really simple.  I know for sure that I have not checked off the mode enabling as you suggest for the macros.  I will let you know soon.

73

Mark
KK2L

73

Mark
KK2L




On Mon, Jan 6, 2020 at 4:10 PM -0500, "Alain Reiner" <alain@...> wrote:

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD
              connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD
              program options

4) DM780 program options

DM780
              program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780
              TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS

Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L



-- 
Alain Reiner

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

No luck, yet, but I think I am getting closer.  Here are two of my macros.  Neither one will go into TX when I click Send.  Do you see something wrong in the way they are written?

 

#++

#

#   End of a reply to the other station, his callsign

#   is taken from the Add Log Entry Callsign field.

#

#--

#

<his:callsign> <his:callsign> de <my:callsign> <my:callsign> I am reading you 599 599.  The name, here, is Mark.  How Copy?  BTU <his:callsign> de <my:callsign>  pse kn <stop>

 

 

 

 

#++

#

#   QRZ, stops TX when all text sent.

#

#--

#TX 0    //  TX = Off

QRZ QRZ QRZ de <my:callsign> <my:callsign> <my:callsign> pse k <stop>

 

 

 

 

 

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 4:10 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD
              connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD
              program options

4) DM780 program options

DM780
              program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780
              TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS


Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L




-- 
Alain Reiner



-- 
Alain Reiner


Alain Reiner <alain@...>
 

Mark,

Your 2 macros run just fine on my DM780. I do not see anything wrong. I attached the shots where you can see how I've set them up.

Did you do anything different ?

The only other way I see to help you is you give me a remote access to your computer (using team viewer) and I would compare your settings with mine. Or you could call the HRD help.

Have you another idea ?

Alain F4HFS


Le 07/01/2020 à 03:47, Mark Gottlieb a écrit :

No luck, yet, but I think I am getting closer.  Here are two of my macros.  Neither one will go into TX when I click Send.  Do you see something wrong in the way they are written?

 

#++

#

#   End of a reply to the other station, his callsign

#   is taken from the Add Log Entry Callsign field.

#

#--

#

<his:callsign> <his:callsign> de <my:callsign> <my:callsign> I am reading you 599 599.  The name, here, is Mark.  How Copy?  BTU <his:callsign> de <my:callsign>  pse kn <stop>

 

 

 

 

#++

#

#   QRZ, stops TX when all text sent.

#

#--

#TX 0    //  TX = Off

QRZ QRZ QRZ de <my:callsign> <my:callsign> <my:callsign> pse k <stop>

 

 

 

 

 

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 4:10 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD
                connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD
                program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS


Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L




-- 
Alain Reiner



-- 
Alain Reiner

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

Alain,

 

I like the TeamViewer idea.  We have a 6 hour time difference so I imagine a weekend day would be most convenient for you.  Let me know.  Merci Beaucoup!

 

73

 

Mark

KK2L

 

antenna sunset

 

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Tuesday, January 7, 2020 3:18 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Mark,

Your 2 macros run just fine on my DM780. I do not see anything wrong. I attached the shots where you can see how I've set them up.

Did you do anything different ?

The only other way I see to help you is you give me a remote access to your computer (using team viewer) and I would compare your settings with mine. Or you could call the HRD help.

Have you another idea ?

Alain F4HFS

Le 07/01/2020 à 03:47, Mark Gottlieb a écrit :

No luck, yet, but I think I am getting closer.  Here are two of my macros.  Neither one will go into TX when I click Send.  Do you see something wrong in the way they are written?

 

#++

#

#   End of a reply to the other station, his callsign

#   is taken from the Add Log Entry Callsign field.

#

#--

#

<his:callsign> <his:callsign> de <my:callsign> <my:callsign> I am reading you 599 599.  The name, here, is Mark.  How Copy?  BTU <his:callsign> de <my:callsign>  pse kn <stop>

 

 

 

 

#++

#

#   QRZ, stops TX when all text sent.

#

#--

#TX 0    //  TX = Off

QRZ QRZ QRZ de <my:callsign> <my:callsign> <my:callsign> pse k <stop>

 

 

 

 

 

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 4:10 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD
                connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD
                program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS



Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L





-- 
Alain Reiner




-- 
Alain Reiner



-- 
Alain Reiner


Alain Reiner <alain@...>
 

OK, sure. As I am working for a living, Saturday would be just fine. I will see my son and my grand daughters on Sunday. Could be 9 or 10 AM your side ( 3 or 4 PM in Paris ) as you prefer.

73, Alain
F4HFS

Le 07/01/2020 à 21:24, Mark Gottlieb a écrit :

Alain,

 

I like the TeamViewer idea.  We have a 6 hour time difference so I imagine a weekend day would be most convenient for you.  Let me know.  Merci Beaucoup!

 

73

 

Mark

KK2L

 

antenna sunset

 

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Tuesday, January 7, 2020 3:18 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Mark,

Your 2 macros run just fine on my DM780. I do not see anything wrong. I attached the shots where you can see how I've set them up.

Did you do anything different ?

The only other way I see to help you is you give me a remote access to your computer (using team viewer) and I would compare your settings with mine. Or you could call the HRD help.

Have you another idea ?

Alain F4HFS

Le 07/01/2020 à 03:47, Mark Gottlieb a écrit :

No luck, yet, but I think I am getting closer.  Here are two of my macros.  Neither one will go into TX when I click Send.  Do you see something wrong in the way they are written?

 

#++

#

#   End of a reply to the other station, his callsign

#   is taken from the Add Log Entry Callsign field.

#

#--

#

<his:callsign> <his:callsign> de <my:callsign> <my:callsign> I am reading you 599 599.  The name, here, is Mark.  How Copy?  BTU <his:callsign> de <my:callsign>  pse kn <stop>

 

 

 

 

#++

#

#   QRZ, stops TX when all text sent.

#

#--

#TX 0    //  TX = Off

QRZ QRZ QRZ de <my:callsign> <my:callsign> <my:callsign> pse k <stop>

 

 

 

 

 

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 4:10 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS



Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L





-- 
Alain Reiner




-- 
Alain Reiner



-- 
Alain Reiner

-- 
Alain Reiner


Mark Gottlieb <kk2l@...>
 

Alain,

 

This Saturday morning, my time, I will not be available.  We can look at the next week if you like.  I am in no urgent hurry and appreciate your offer of assistance.

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Tuesday, January 7, 2020 3:42 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

OK, sure. As I am working for a living, Saturday would be just fine. I will see my son and my grand daughters on Sunday. Could be 9 or 10 AM your side ( 3 or 4 PM in Paris ) as you prefer.

73, Alain
F4HFS

Le 07/01/2020 à 21:24, Mark Gottlieb a écrit :

Alain,

 

I like the TeamViewer idea.  We have a 6 hour time difference so I imagine a weekend day would be most convenient for you.  Let me know.  Merci Beaucoup!

 

73

 

Mark

KK2L

 

antenna sunset

 

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Tuesday, January 7, 2020 3:18 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Mark,

Your 2 macros run just fine on my DM780. I do not see anything wrong. I attached the shots where you can see how I've set them up.

Did you do anything different ?

The only other way I see to help you is you give me a remote access to your computer (using team viewer) and I would compare your settings with mine. Or you could call the HRD help.

Have you another idea ?

Alain F4HFS


Le 07/01/2020 à 03:47, Mark Gottlieb a écrit :

No luck, yet, but I think I am getting closer.  Here are two of my macros.  Neither one will go into TX when I click Send.  Do you see something wrong in the way they are written?

 

#++

#

#   End of a reply to the other station, his callsign

#   is taken from the Add Log Entry Callsign field.

#

#--

#

<his:callsign> <his:callsign> de <my:callsign> <my:callsign> I am reading you 599 599.  The name, here, is Mark.  How Copy?  BTU <his:callsign> de <my:callsign>  pse kn <stop>

 

 

 

 

#++

#

#   QRZ, stops TX when all text sent.

#

#--

#TX 0    //  TX = Off

QRZ QRZ QRZ de <my:callsign> <my:callsign> <my:callsign> pse k <stop>

 

 

 

 

 

 

73

 

Mark

KK2L

 

antenna sunset

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 4:10 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Sorry Mark, I did not help.

other thoughts on the macro side. please check in the macro window  :
- Are the macros enabled ? (checkbox at the top left)
- Do you need the text to be sent immediately ? (checkbox)
- Do you have a mode enabled in the "Enable By Mode" window ?
I use the macro by first displaying the text in the TX window for possible edition, and then I send the text using the send button (DM780).

Do you have another TRx which HRD/DM780 would properly work with ?
 
What is your version of HRD + DM780 ?

73,
Alain F4HFS

Le 06/01/2020 à 21:28, Mark Gottlieb a écrit :

Hello Alain,

 

I have HRD already configured as you describe here.  The TX button, in the radio section, in DM780 will key up the radio if I manually apply it.  My problem is that when I am attempting to send a macro the radio will not go in TX.  I have attempted to set up with both HRD and Mini-Deluxe 2.1, which takes less processing, and I have achieved the same results in that the radio will not go into TX unless I manually apply the button.    I am getting the exact same results with the ELAD and with my FLEX 6400.  BTW, I have been using HRD since 2014.   Thank-you for offering your assistance.

 

73

 

Mark

KK2L

 

From: EladSDR@groups.io <EladSDR@groups.io> On Behalf Of Alain Reiner
Sent: Monday, January 6, 2020 3:14 PM
To: EladSDR@groups.io
Subject: Re: [EladSDR] HAM RADIO DELUXE PTT

 

Hello Mark, all,

Let's begin by the obvious. I'm using only the CAT command for PTT.

1) DUO
- the PTT setup : I've set it at IN + RTS because I use the RTS with wsjtx for the FT8. So for my using DM780, IN alone is enough.
- CAT BitRate : 9600 b/s, so I can use my DUO with MMSSTV. You may put whatever bitrate you want, but you have to set the HRD connection accordingly, of course. Sorry for the (very) obvious.

2) the CAT connection with HRD

HRD connection

NB : As DM780 needs the logbook to properly work, I don't launch automatically DM780 at HRD startup. The logbook is quite long to launch. HRD Rig control launches first, then the log book. Once the logbook is opened and stable, I launch DM780 from the logbook window.

3) HRD Program options

HRD program options

4) DM780 program options

DM780 program options

NB : take care to connect DM780 to HRD. You must do it at least once. Then it is kept up.

All that is quite obvious. I don't expect you missed any of them. The real trick is the next one. I bet you missed this one :-).

5) DM780 (hidden) TX button

to show the tx button (green ellipse), you have to click on the "Radio" button (red circle). This is only for using it manually. With the DUO turned on, HRD connected, DM780 connected to HRD, try and click on the TX button. If the DUO don't transmit, that's it !

To program the TX button, you have to click on the configuration button (blue circle). Then you click on TX in the new "Configure Radio Pane" and you may chose the action associated with the TX button. Personally, I've trivially chosen the TX button to turn the DUO in transmission (TX). I know, it's very common... I like it this way. Please, don't ask me why they've done that, ok ?

The real trick is that there is no default programming in this button. When you install a new TRX connection, DM780 will prompt you for programming the TX button, only once. If you missed it the first time, there won't be a second time.

DM780 TX Button


Let me know your results. If none of this worked, we would see what to do next.

73,
Alain F4HFS




Le 05/01/2020 à 22:18, Mark Gottlieb a écrit :

Hello Alain,

I am still having the same issue.  It is exactly the same for my FLEX 6400 and my ELAD FM DUO so it must be something simple that I am not doing to enable PTT using these radios.  I am able to manually click on TX, in the radio section of HRD, and both radios will go into TX mode.  In addition, I have full audio capability in terms of decoding and I do have rig control, for both radios, where I can switch bands, increase volume, etc. from HRD.

Please advise.

73

Mark
KK2L






-- 
Alain Reiner





-- 
Alain Reiner




-- 
Alain Reiner



-- 
Alain Reiner