Topics

WSJT-X with DXLab and Flex radio, how to CAT?

Andy (KU7T)
 

HI,

 

I am trying to follow these instructions: https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModesDirect

 

Hitting Test CAT does not work. What am I doing wrong?  The instructions say

 

In the Rig dropdown menu, select DXLab Suite Commander

·         This enables WSJT-X to control your radio via Commander, rather than via a serial port, or a virtual serial port created by a USB connection.

·         If you've configured Commander to use other than TCP port 52002, then specify the port TCP Commander is using in the CAT Control panel's Network Server box

 

Its not clear to me what needs to be set in Commander…

 

Any help is appreciated,

Andy

KU7T

 

 

 

Sent from Mail for Windows 10

 

Dave AA6YQ
 

+ AA6YQ comments below

I am trying to follow these instructions: https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModesDirect
<https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModesDirect>

Hitting Test CAT does not work. What am I doing wrong? The instructions say

In the Rig dropdown menu, select DXLab Suite Commander

. This enables WSJT-X to control your radio via Commander, rather than via a serial port, or a virtual serial port created
by a USB connection.

. If you've configured Commander <http://www.dxlabsuite.com/commander/Help/NetworkService.htm> to use other than TCP port
52002, then specify the port TCP Commander is using in the CAT Control panel's Network Server box

Its not clear to me what needs to be set in Commander.

+ On the General tab of Commander's Configuration window, click the Radio panel's "Net Serv" button (along the right margin).

+ In the "Network Service" window that appears, what is specified the "TCP Network Service" panel as the "Base Port" ?

73,

Dave, AA6YQ

Andy (KU7T)
 

Base port is set to 5002, which is the port for Slice A. But I do not what if that is what it is supposed to be. Its not clear to me how commander needs to work differently from before using WSJT-X. Before, I used just the drop down and all worked. Now, what is different? Do I need to use CAT?

Andy

Andy (KU7T)
 

This now started working, CAT that is via port 5002. Takes 5 - 10 s to light up the button up green. Clicking hte PTT button keys the rig, but using WSJT-X does not key the rig. If I switch WSJT-x to use native Flex control all is working. What do I lose by using native Flex control vs. Commander?

Andy
KU7T

Dave AA6YQ
 

+ AA6YQ comment sbelow

Base port is set to 5002, which is the port for Slice A.

+ Commander's "Base Port" specifies the base of a block of TCP ports that are used to accept directives from other applications. Commander uses the 2nd port in the block -- so if you have the "Base Port" set to 5002, that means Commander is accepting directives from port 5004 - so on the Radio tab of the WSJT-X Settings window,

1. set the Rig selector to "DX Lab Suite Commander"

2. set the "CAT Control" panel's "Network Server" to 5004

+ These settings enable WSJT-X to send TCP directives to Commander, like "switch from RX to TX". They have nothing to do with "slice A" or anything else specific to the model transceiver you are using.


But I do not what if that is what it is supposed to be. Its not clear to me how commander needs to work differently from before using WSJT-X. Before, I used just the drop down and all worked. Now, what is different?

+ Commander's default Base port is 52000, which means it responds to incoming directives on port 52002. WSJT-X knows that this is Commander's default, so if you leave WSJT-X's "CAT Control" panel's "Network Server" setting blank, it defaults to 52002. That's why step 3.a in the "Configuring WSJT-X" section of

< https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModesDirect>

says

"If you've configured Commander to use other than TCP port 52002, then specify the port TCP Commander is using in the CAT Control panel's Network Server box"

+ Did you intentionally change Commander's Base Port to 5002?

Do I need to use CAT?

+ No. Commander doesn't use CAT to control Flex Signature radios.

73,

Dave, AA6YQ

Dave AA6YQ
 

+ AA6YQ comments below

This now started working, CAT that is via port 5002. Takes 5 - 10 s to light up the button up green. Clicking hte PTT button keys the rig

+ To what "PTT button" are you referring?

, but using WSJT-X does not key the rig.

+ Then it's not working. Before proceeding, I suggest that you review this post:

< https://groups.io/g/DXLab/message/186378>


If I switch WSJT-x to use native Flex control all is working.

+ What is "native Flex control"?

73,

Dave, AA6YQ

Andy (KU7T)
 

Ok, I apologize, but this is really confusing. Now, I followed your instructions to the teeth, and I am back to the situation where I get green on "TEST CAT" and red on "TEST PTT" but the radio is not keyed. 

current settings:
Commander: UDP Network service disabled, TCP network service/Base port 5002
WSJT-X: Rig: commander, network server: localhost:5004, PTT method: CAT

Since you said that even though I specified 5002/5004 in the applications, it will use 5004. I have not configured 5004 in SmartSDR CAT. Do I have to?

Btw, I am running SSDR v3.1.2 (alpha)

73
Andy
KU7T

Dave AA6YQ
 

+ AA6YQ comments below

Ok, I apologize, but this is really confusing. Now, I followed your instructions to the teeth, and I am back to the situation where I get green on "TEST CAT" and red on "TEST PTT" but the radio is not keyed.

+ I'll defer to Bill G4WJS (WSJT-X development team leader), but that sounds like defective transceiver behavior. Since you state below that you are using SmartSDR version 3.1.2 - of whose existence I only learned earlier today - you are operating outside the bounds of supported configurations.

+ At this point in time, the only version of SmartSDR that I know works reliably is 2.4.9.


current settings:
Commander: UDP Network service disabled, TCP network service/Base port 5002
WSJT-X: Rig: commander, network server: localhost:5004, PTT method: CAT

Since you said that even though I specified 5002/5004 in the applications, it will use 5004. I have not configured 5004 in SmartSDR CAT. Do I have to?

+ What I posted is that if in Commander you specify the Base Port to be 5002, then you should configure WSJT-X to use port 5004 (Settings window, Radio tab, "CAT Control" panel", "Network Server" box).

+ I also posted that

- Commander's Base Port setting has nothing to do with its interaction with Flex Signature transceivers.

- Commander does not use serial port CAT to interact with Flex Signature transceivers. There is no need to run "SmartSDR CAT", much less configure it.

73,

Dave, AA6YQ

John Battin
 

I use 2.4.9

No CAT

JT Alert sends log to keeper.

Use vox and not ptt

 

Sent from Mail for Windows 10

 


From: DXLab@groups.io <DXLab@groups.io> on behalf of Dave AA6YQ <aa6yq@...>
Sent: Monday, June 24, 2019 2:23:23 PM
To: DXLab@groups.io
Cc: Steve Hicks - N5AC; Eric Wachsmann
Subject: Re: [DXLab] WSJT-X with DXLab and Flex radio, how to CAT?
 
+ AA6YQ comments below

Ok, I apologize, but this is really confusing. Now, I followed your instructions to the teeth, and I am back to the situation where I get green on "TEST CAT" and red on "TEST PTT" but the radio is not keyed.

+ I'll defer to Bill G4WJS (WSJT-X development team leader), but that sounds like defective transceiver behavior. Since you state below that you are using SmartSDR version 3.1.2 - of whose existence I only learned earlier today - you are operating outside the bounds of supported configurations.

+ At this point in time, the only version of SmartSDR that I know works reliably is 2.4.9.


current settings:
Commander: UDP Network service disabled, TCP network service/Base port 5002
WSJT-X: Rig: commander, network server: localhost:5004, PTT method: CAT

Since you said that even though I specified 5002/5004 in the applications, it will use 5004. I have not configured 5004 in SmartSDR CAT. Do I have to?

+ What I posted is that if in Commander you specify the Base Port to be 5002, then you should configure WSJT-X to use port 5004 (Settings window, Radio tab, "CAT Control" panel", "Network Server" box).

+ I also posted that

- Commander's Base Port setting has nothing to do with its interaction with Flex Signature transceivers.

- Commander does not use serial port CAT to interact with Flex Signature transceivers. There is no need to run "SmartSDR CAT", much less configure it.

          73,

               Dave, AA6YQ





g4wjs
 

On 24/06/2019 20:23, Dave AA6YQ wrote:
Ok, I apologize, but this is really confusing. Now, I followed your instructions to the teeth, and I am back to the situation where I get green on "TEST CAT" and red on "TEST PTT" but the radio is not keyed. 

+ I'll defer to Bill G4WJS (WSJT-X development team leader), but that sounds like defective transceiver behavior. Since you state below that you are using SmartSDR version 3.1.2 - of whose existence I only learned earlier today - you are operating outside the bounds of supported configurations.

Hi Dave and Andy,

the first thing I need to understand is why are port number 5002 and 5004 being mentioned in this thread. The default port Command listens for CAT commands from WSJT-X if 52002 and as Dave has said you can leave the "Network host" box in WSJT-X blank if the default is being used in the Commander setup, i.e.:

in the "Commander->Config->General->Net Serv" panel.

So why is any port number change being used?

Secondly, what option in WSJT-X is selected for "Setings->Radio->PTT Method"?

73
Bill
G4WJS.


--
73

Bill

G4WJS.

g4wjs
 

On 24/06/2019 23:06, g4wjs wrote:

Commander setup, i.e.:

in the "Commander->Config->General->Net Serv" panel.

Hi again,

sorry, I thought I might get away with a small inline image but it was not small enough and got stripped by Groups.io. You can find the image here:

https://www.dropbox.com/s/fwo8fibdvnnarfu/Commander%20Net%20Serv%20Default.PNG?dl=0

73
Bill
G4WJS.


--
73

Bill

G4WJS.