Topics

WSJT-X 3 second delay in PTT of Commander


John K3TN
 

I've been migrating my shack computer to a refurb Win 10 machine, slowly getting everything going again. 

I have WSJT-X integrated to DXLabs per the directions, first by turning off Commander and setting rig to K3S in WSJT-X. That works fine, both working stations and logging them in DXkeeper. Latest version of WSJT-X, latest versions of DXLab programs.

Then, followed the instructions here to have WSJT-X talk to Commander. First hint of an issue was the Test CAT button was slow to turn green. Then, answering a few FT8 CQs, the radio would PTT 3 seconds late every time and I get no responses.

My time synch is fine, .1 seconds off at most as shown in the WSJT-X screen. 

Go back to turning Commander off, WSJT-X talk to the K3S, all good.

Any idea what would cause the 3 second lag? Tried turning the UDP setting off, no difference.

Thanks and 73 John K3TN


BILL KENNAMER
 

I have noticed something similar with my FTdx101. A delay when testing CAT and when calling stations when using Commander. I have not tried using the WSJT radio control.

On Monday, January 11, 2021, 7:40 AM, John K3TN via groups.io <jpescatore@...> wrote:

I've been migrating my shack computer to a refurb Win 10 machine, slowly getting everything going again. 

I have WSJT-X integrated to DXLabs per the directions, first by turning off Commander and setting rig to K3S in WSJT-X. That works fine, both working stations and logging them in DXkeeper. Latest version of WSJT-X, latest versions of DXLab programs.

Then, followed the instructions here to have WSJT-X talk to Commander. First hint of an issue was the Test CAT button was slow to turn green. Then, answering a few FT8 CQs, the radio would PTT 3 seconds late every time and I get no responses.

My time synch is fine, .1 seconds off at most as shown in the WSJT-X screen. 

Go back to turning Commander off, WSJT-X talk to the K3S, all good.

Any idea what would cause the 3 second lag? Tried turning the UDP setting off, no difference.

Thanks and 73 John K3TN


g4wjs
 

On 11/01/2021 13:40, John K3TN via groups.io wrote:
I've been migrating my shack computer to a refurb Win 10 machine, slowly getting everything going again. 

I have WSJT-X integrated to DXLabs per the directions, first by turning off Commander and setting rig to K3S in WSJT-X. That works fine, both working stations and logging them in DXkeeper. Latest version of WSJT-X, latest versions of DXLab programs.

Then, followed the instructions here to have WSJT-X talk to Commander. First hint of an issue was the Test CAT button was slow to turn green. Then, answering a few FT8 CQs, the radio would PTT 3 seconds late every time and I get no responses.

My time synch is fine, .1 seconds off at most as shown in the WSJT-X screen. 

Go back to turning Commander off, WSJT-X talk to the K3S, all good.

Any idea what would cause the 3 second lag? Tried turning the UDP setting off, no difference.

Thanks and 73 John K3TN

Hi John,

try setting the WSJT-X option "Settings->Radio->Mode->None", then set USB DATA A mode on the rig manually or from Commander.

73
Bill
G4WJS.


--
73

Bill

G4WJS.


John K3TN
 

Thanks, Bill - that fixed the delay! Of course, now when I QSY I have to manually set the mode.

I guess WSJT trying to check and set the mode each time causes that delay??

Thanks and 73 John K3TN


g4wjs
 

On 11/01/2021 21:23, John K3TN via groups.io wrote:
Thanks, Bill - that fixed the delay! Of course, now when I QSY I have to manually set the mode.

I guess WSJT trying to check and set the mode each time causes that delay??

Thanks and 73 John K3TN
Hi John,

the root issue is within the Elecraft K3 series rigs, they talk exponentially longer periods to process redundant mode change CAT commands. You can try selecting the other "Settings->Radio->Split Operating" option and see if mode settings can be used with that.

73
Bill
G4WJS.



--
73

Bill

G4WJS.


Dave AA6YQ
 

+ AA6YQ comments below

I have noticed something similar with my FTdx101. A delay when testing CAT and when calling stations when using Commander. I have not tried using the WSJT radio control.

+ WSJT-X is conservative; it checks to the see that the transceiver has implemented previously sent directives before proceeding.

73,

Dave, AA6YQ


John K3TN
 

Played with this a bit yesterday.  When having WSJT-X talk to Commander, turning off Radio settings driving the mode does  eliminate the 3 second delay. But, it is a big pain to  have to get the K3 back to Data and then to the right Data Mode on every band change. 

For now, I'm going back to just turning off Commander for my relatively infrequent FT8 sessions, will post on the WSJT-X Group to suggest a fix in WSJT-X approach t that.

73 John K3TN


Jim N7US
 

I eliminated the delay with PTT using RTS for my K3S.  I have a microKEYER III but previously used a RTTY interface from AA5AU’s website that has PTT on the RTS line.

 

73,  Jim N7US

 

From: DXLab@groups.io <DXLab@groups.io> On Behalf Of John K3TN via groups.io
Sent: Wednesday, January 13, 2021 04:58
To: DXLab@groups.io
Subject: Re: [DXLab] WSJT-X 3 second delay in PTT of Commander

 

Played with this a bit yesterday.  When having WSJT-X talk to Commander, turning off Radio settings driving the mode does  eliminate the 3 second delay. But, it is a big pain to  have to get the K3 back to Data and then to the right Data Mode on every band change. 

For now, I'm going back to just turning off Commander for my relatively infrequent FT8 sessions, will post on the WSJT-X Group to suggest a fix in WSJT-X approach t that.

73 John K3TN

_._,_._,_


Andy - K0AF
 

John, I had a 3 second TX delay with my IC7300 when using the WSJT-X / Commander setup you described. In WSJT-X, changing File>Settings>Radio>Split Operation from "Rig" to "Fake It" as Bill/G4WJS suggested reduced the delay to about 300 ms. It may not fix the delay on K3 but it's worth trying and reporting back.

73 Andy K0AF


Robie - AJ4F
 

Try setting Split to Fake It.  

Robie -AJ4F

On Wed, Jan 13, 2021, 4:57 AM John K3TN via groups.io <jpescatore=aol.com@groups.io> wrote:
Played with this a bit yesterday.  When having WSJT-X talk to Commander, turning off Radio settings driving the mode does  eliminate the 3 second delay. But, it is a big pain to  have to get the K3 back to Data and then to the right Data Mode on every band change. 

For now, I'm going back to just turning off Commander for my relatively infrequent FT8 sessions, will post on the WSJT-X Group to suggest a fix in WSJT-X approach t that.

73 John K3TN


Lou Laderman W0FK
 

I’ve found a delay with my Flex 6600 when VOX is on. Turning it off eliminated the delay. Perhaps that might help. Note, I haven’t noticed that issue with my IC-7610.

73, Lou W0FK


John K3TN
 

Jim's suggestion solved my problem - going from CAT PTT to RTS PTT, and setting a COM Port to PTT in Microham's Router software for my MK2R+ eliminated the delay, no rig control errors from WSJT and mode is set correctly by WSJT when QSYing.

Thanks to all for suggestions, 73 John K3TN