Windows Registry indicates that the Launcher is not installed


RowlandA
 

Hi Dave - 
Sorry to bother you with this one but I've tried installing / uninstalling a couple of times and I'm not getting past this error.
I first installed all the DXLab applications using all defaults (C:\DXLab folder).
It showed Launcher as at 1.9.7 with 2.1.4 available.

Clicking the Upgrade button next to Launcher in the Launcher Config dialog gave the error "the Windows Registry indicates that the Launcher is not installed."

I terminated Launcher and restarted it with the same results.

I checked Windows Add or Remove Programs and it does not show Launcher.

I tried reinstalling Launcher, same results.

Is there a way to clean the registry so I can start fresh, or should I try some other approach?

Thanks and 73,

Rowland K4XD


Dave AA6YQ
 

+ AA6YQ comments below
Sorry to bother you with this one but I've tried installing / uninstalling a couple of times and I'm not getting past this error.
I first installed all the DXLab applications using all defaults (C:\DXLab folder).
It showed Launcher as at 1.9.7 with 2.1.4 available.

Clicking the Upgrade button next to Launcher in the Launcher Config dialog gave the error "the Windows Registry indicates that the Launcher is not installed."

I terminated Launcher and restarted it with the same results.

I checked Windows Add or Remove Programs and it does not show Launcher.

I tried reinstalling Launcher, same results.

Is there a way to clean the registry so I can start fresh, or should I try some other approach?

+ I don't know, Rowland. If you direct Windows to install the Launcher, but Windows then reports that the Launcher is not installed, I would say that Windows i broken. You could either contact Microsoft Support, or take your chances with a "Registry Cleaner" application that you direct to remove all vestiges of the Launcher; whether the latter will be successful, I can't say. The only "guaranteed cure" would be to re-install Windows from scratch (after first backing up everything of value).

       73,

                Dave, AA6YQ

 

 


RowlandA
 

Thanks for the quick reply Dave.  This was a weird one.

Good news, I got it working without reinstalling Windows (which, ironically, is a new installation from only a week ago!).

Just for the record, here's what I did:
1)  Loaded a system restore point from 3PM yesterday, before I did the initial DXLab installation
2)  Ran both CCleaner and Ashampoo PC Optimizer, backing up the registry first (CCleaner offers that option)
3)  Ran the DXLab Launcher installer and it successfully did the upgrade to the latest Launcher.
4)  Installed the remaining DXLab apps from the Launcher.

So all good for now.  Would be nice to know exactly what the problem was, but I'll take the results anyway :) .
73,

Rowland K4XD


Dave AA6YQ
 

+ AA6YQ comments below

Thanks for the quick reply Dave. This was a weird one.

Good news, I got it working without reinstalling Windows (which, ironically, is a new installation from only a week ago!).

Just for the record, here's what I did:
1) Loaded a system restore point from 3PM yesterday, before I did the initial DXLab installation
2) Ran both CCleaner and Ashampoo PC Optimizer, backing up the registry first (CCleaner offers that option)
3) Ran the DXLab Launcher installer and it successfully did the upgrade to the latest Launcher.
4) Installed the remaining DXLab apps from the Launcher.

So all good for now. Would be nice to know exactly what the problem was, but I'll take the results anyway :) .

+ I'm glad that you got it sorted, Rowland!

73,

Dave, AA6YQ