Topics

User commands for ten tec eagle

lmeeny
 

Hello,

To control the noise reduction function in the Eagle a command sequence is sent to the radio, RMNN#<cr> where RMNN are in hex, 52, 4D. 4E and 4E respectively.  # represents the level of noise reduction in hex where 0 turns noise reduction off and 1, 2, etc. more aggressive levels of reduction.

To turn noise reduction OFF for instanc I entered 524D4E4E300D for RMNN0<cr>. The command doesn't work as hoped. I'd appreciate help in finding my error.

73

Ed W2GHD

d_ziolkowski
 

Ed -- 

on off

'*RMNN0<13>

'*RMNN1<13>

slider to control level

lower bound 0
upper bound
Small step 1
big step 3
label NR <value>
function Noise Reduction
command '*RMNN<D1><13>

also see files section of this group

Dan KC2STA




Joe Subich, W4TV
 

To turn noise reduction OFF for instanc I entered 524D4E4E300D for
RMNN0<cr>.
Try '*RMM0<13> as an ASCII string ...

If you insist on Hex, don't forget the leading * (2Ah) which makes
the string a "Set" command to the Ten-Tec.

73,

... Joe, W4TV


On 2020-07-01 4:03 PM, lmeeny wrote:
Hello,
To control the noise reduction function in the Eagle a command sequence is sent to the radio, RMNN#<cr> where RMNN are in hex, 52, 4D. 4E and 4E respectively.  # represents the level of noise reduction in hex where 0 turns noise reduction off and 1, 2, etc. more aggressive levels of reduction.
To turn noise reduction OFF for instanc I entered 524D4E4E300D for RMNN0<cr>. The command doesn't work as hoped. I'd appreciate help in finding my error.
73
Ed W2GHD

lmeeny
 

Joe, Dan,

Thank you. Joe, I didn't realize the "*" was part of the command! I kept looking for the note I thought it referred to Hi Hi. I'll be on the rig later this evening and let you know how I make out.

Dan I'll try the slider option later, little steps first.

Joe, I used hex because the Eagle programming manual listed all the commands in hex. What other alternatives do I have?

Again, thanks,

Ed W2GHD

d_ziolkowski
 

Ed 

Programmers guide from tentec is all ascii. Where are you seeing hex?

Dan kc2sta

On Wed, Jul 1, 2020, 19:30 lmeeny <emachak@...> wrote:
Joe, Dan,

Thank you. Joe, I didn't realize the "*" was part of the command! I kept looking for the note I thought it referred to Hi Hi. I'll be on the rig later this evening and let you know how I make out.

Dan I'll try the slider option later, little steps first.

Joe, I used hex because the Eagle programming manual listed all the commands in hex. What other alternatives do I have?

Again, thanks,

Ed W2GHD

Joe Subich, W4TV
 

Joe, I used hex because the Eagle programming manual listed all the
commands in hex. What other alternatives do I have?
Commander's on-line Help hows both Hex and ASCII forms of the user
defined commands. ASCII forms are prefixed with an apostrophe (').
Your command would be 'RMNN0<13> which is very close to what is
shown in the Eagle Programmer's documentation shows on page 10.

Note: for Commander <13> is the CR ...

73,

... Joe, W4TV


On 2020-07-01 7:30 PM, lmeeny wrote:
Joe, Dan,
Thank you. Joe, I didn't realize the "*" was part of the command! I kept looking for the note I thought it referred to Hi Hi. I'll be on the rig later this evening and let you know how I make out.
Dan I'll try the slider option later, little steps first.
Joe, I used hex because the Eagle programming manual listed all the commands in hex. What other alternatives do I have?
Again, thanks,
Ed W2GHD

lmeeny
 

Hello,

Inserting the missing asterisk at the beginning of the command string did the trick.

Thank you,

Ed

lmeeny
 

Joe,

I overlooked the info in the Commander help file on using a leading apostrophe for ASCII characters. Thanks you very much.

Ed W2GHD