Startup Issue with DXLab Suite and Smart SDR


Jim Studer
 

I start my SmartSDR software and all is good.  Then I start DXLab Suite and if I'm on 20 meters (maybe other bands) SmartSDR shifts to LSB.  It happens every time I start DXLab Suite.  I then have to change back to USB and things are normal.  Any idea what's going on? 


Dave AA6YQ
 

+ AA6YQ comments below
I start my SmartSDR software and all is good.  Then I start DXLab Suite and if I'm on 20 meters (maybe other bands) SmartSDR shifts to LSB.  It happens every time I start DXLab Suite.  I then have to change back to USB and things are normal.  Any idea what's going on? 

+ Which DXLab applications are you starting? Which one causes SmartSDR to change modes?

+ Do you have Commander configured to execute an initial command, or an initial command sequence? Do any of your WinWarbler startup macros direct Commander to issue commands to your transceiver?

         73,

                 Dave, AA6YQ


Jim Studer
 

I normally start DXLab Suite by clicking the Start button on the Launcher.  I started each application manually and WinWarbler is the app that changes the mode.  I never use WW and have it go to a reduced status to avoid taking up valuable screen space.  I really don't know much about WW as I use other programs for this function.  You mention WW startup macros.  I don't see any place where I'd enter this.  Can you give me a point?

Jim AK4I


Dave AA6YQ
 

+ AA6YQ comments below
I normally start DXLab Suite by clicking the Start button on the Launcher.  I started each application manually and WinWarbler is the app that changes the mode.  I never use WW and have it go to a reduced status to avoid taking up valuable screen space.  I really don't know much about WW as I use other programs for this function.  You mention WW startup macros.  I don't see any place where I'd enter this.  Can you give me a point?

+ When WinWarbler starts up, it directs Commander to place the transceiver in the mode specified on the appropriate tab of its Configuration window. Step-by-step configuration instructions are here:

https://www.dxlabsuite.com/dxlabwiki/Multimode_Setup

+ I suggest that you start by reveiwing

https://www.dxlabsuite.com/dxlabwiki/GettingStarted

+ Since you're not using WinWarbler, I suggest that you open the Launcher's Configuration window, select the "DXLab Apps" tab, and uncheck WinWarbler's "Enab" box; then the Launcher won't start WinWarbler when you click the former's Start button. Do the same for any other DXLab applications that you're not yet using and thus haven't yet configured.

        73,

               Dave, AA6YQ

 

 


Jim Studer
 

Got it!  I do use WW when I'm running RTTY.  I guess one time I was using RTTY on 40 meters so when I turned on the Flex on 20 meters and started to program it still reverted to LSB.  However, you second suggestion was the best. I unchecked WW in the Launcher and it doesn't matter.

Thanks for the amazing help!

73, Jim AK4I


w6de
 

Regarding DXLab Launcher Config.  Periodically open it and check for program updates by clicking the “New?” Box in the upper right corner.  New application versions will show up in Avail with the new version number in Red, click the adjacent Upgrade button for each available new application.  Keeping the DXLab Suite up-to-date will make life with DXLabs easier.  More info here: http://www.dxlabsuite.com/Launcher/Help/InstallUpgrade.htm

 

73,

Dave, w6de

 

From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Jim Studer via groups.io
Sent: Sunday, August 15, 2021 17:51
To: DXLab@groups.io
Subject: Re: [DXLab] Startup Issue with DXLab Suite and Smart SDR

 

Got it!  I do use WW when I'm running RTTY.  I guess one time I was using RTTY on 40 meters so when I turned on the Flex on 20 meters and started to program it still reverted to LSB.  However, you second suggestion was the best. I unchecked WW in the Launcher and it doesn't matter.

Thanks for the amazing help!

73, Jim AK4I


Dave AA6YQ
 

+ AA6YQ comments below

Got it! I do use WW when I'm running RTTY. I guess one time I was using RTTY on 40 meters so when I turned on the Flex on 20 meters and started to program it still reverted to LSB.

+ The transceiver mode to be used when operating RTTY with WinWarbler is specified in the "Modulation and transceiver mode" panel on the RTTY tab of WinWarbler's Configuration window. Configuration instructions are available here:

https://www.dxlabsuite.com/dxlabwiki/Multimode_Setup

73,

Dave, AA6YQ