Topics

Odd behavior observed- any suggestions?


Dave K2XR
 

Recently I have had the opportunity to work on several large ( > 300k qso’s) and old ( 1960 to present) dxk logs. 

If  choose no filter [X] and the built in UTC filter, the most recent qso shows at the bottom of the list in the log display area as expected. If I use the scroll bars to go to the top of the log... no qso’s prior to a date in 1999 are showing. It is as if a filter that said begin > #1999-03-06 00:00# was in effect.
If I create my own version of the UTC sort and filter that explicitly includes all records, indeed they are all there and in the expected order.   Is there anyway I could have hosed the database or in some way altered the behavior of the UTC sort radio button  ?
It appears to be mdb specific but is hard to be certain. 
  Thanks for any guidance. 

     Dave K2XR 


Dave AA6YQ
 

+ AA6YQ comments below

Recently I have had the opportunity to work on several large ( > 300k qso’s) and old ( 1960 to present) dxk logs.

If choose no filter [X] and the built in UTC filter, the most recent qso shows at the bottom of the list in the log display area as expected. If I use the scroll bars to go to the top of the log... no qso’s prior to a date in 1999 are showing. It is as if a filter that said begin > #1999-03-06 00:00# was in effect.
If I create my own version of the UTC sort and filter that explicitly includes all records, indeed they are all there and in the expected order. Is there anyway I could have hosed the database or in some way altered the behavior of the UTC sort radio button ?
It appears to be mdb specific but is hard to be certain.
Thanks for any guidance.

+ Depress the CTRL key while clicking the Filter panel's X button. Now do you see all QSOs in the Log Page Display?

73,

Dave, AA6YQ


Dave K2XR
 

No, same as before.  Sorry for the delay but the log was near the end of a >36 hour  initial Sync LoTW QSO's operation, and I could not attempt it until the process completed.

In addition, to see if perhaps it was the mdb itself.

1: Filter None

2:  Sorted log by QSO_Begin

3: Export standard ADIF

4: Config :  Log  :  Log File  [New]    new_logname

5: Import Standard ADIF

Whole process worked as expected, but stated problem persists.

Can demonstrate in any number of ways, or will do as you ask/suggest.

   XR

On 7/27/2020 11:07:09 PM, Dave AA6YQ wrote:
+ AA6YQ comments below

Recently I have had the opportunity to work on several large ( > 300k qso’s) and old ( 1960 to present) dxk logs.

If choose no filter [X] and the built in UTC filter, the most recent qso shows at the bottom of the list in the log display area as expected. If I use the scroll bars to go to the top of the log... no qso’s prior to a date in 1999 are showing. It is as if a filter that said begin > #1999-03-06 00:00# was in effect.
If I create my own version of the UTC sort and filter that explicitly includes all records, indeed they are all there and in the expected order. Is there anyway I could have hosed the database or in some way altered the behavior of the UTC sort radio button ?
It appears to be mdb specific but is hard to be certain.
Thanks for any guidance.

+ Depress the CTRL key while clicking the Filter panel's X button. Now do you see all QSOs in the Log Page Display?

73,

Dave, AA6YQ




Dave K2XR
 

In addition, I just tried it on another machine.  Same issue.

On 7/28/2020 12:54:05 PM, Dave K2XR via groups.io wrote:
No, same as before.  Sorry for the delay but the log was near the end of a >36 hour  initial Sync LoTW QSO's operation, and I could not attempt it until the process completed.

In addition, to see if perhaps it was the mdb itself.

1: Filter None

2:  Sorted log by QSO_Begin

3: Export standard ADIF

4: Config :  Log  :  Log File  [New]    new_logname

5: Import Standard ADIF

Whole process worked as expected, but stated problem persists.

Can demonstrate in any number of ways, or will do as you ask/suggest.

   XR

On 7/27/2020 11:07:09 PM, Dave AA6YQ wrote:
+ AA6YQ comments below

Recently I have had the opportunity to work on several large ( > 300k qso’s) and old ( 1960 to present) dxk logs.

If  choose no filter [X] and the built in UTC filter, the most recent qso shows at the bottom of the list in the log display area as expected. If I use the scroll bars to go to the top of the log... no qso’s prior to a date in 1999 are showing. It is as if a filter that said begin > #1999-03-06 00:00# was in effect.
If I create my own version of the UTC sort and filter that explicitly includes all records, indeed they are all there and in the expected order.   Is there anyway I could have hosed the database or in some way altered the behavior of the UTC sort radio button  ?
It appears to be mdb specific but is hard to be certain.
   Thanks for any guidance.

+ Depress the CTRL key while clicking the Filter panel's X button. Now do you see all QSOs in the Log Page Display?

          73,

                 Dave, AA6YQ





Dave AA6YQ
 

+ AA6YQ comments below

No, same as before. Sorry for the delay but the log was near the end of a >36 hour initial Sync LoTW QSO's operation, and I could not attempt it until the process completed.

In addition, to see if perhaps it was the mdb itself.

1: Filter None

2: Sorted log by QSO_Begin

3: Export standard ADIF

4: Config : Log : Log File [New] new_logname

5: Import Standard ADIF

Whole process worked as expected, but stated problem persists.

Can demonstrate in any number of ways, or will do as you ask/suggest.

+ Please place the log file (suffix: .mdb) in a zip archive, attach the archive to an email message, and send it to me via

aa6yq (at) ambersoft.com

73,

Dave, AA6YQ