Launcher installation issues


dxradio33
 

Hello folks.  I am trying to install Launcher on a Dell Windows 11 laptop so that I may load the other suite apps.  What follows is the process and results.

1.  Download Launcher from http://www.dxlabsuite.com/download.htm
2.  Run the installation program as instructed and did not change any file locations. 
3.  After install completes, launching the program (Launcher) results in  a short delay while the program loads.
4.  After a moment MS UAC pops up and wants to know if I want to allow 'Launcher' to make changes to this computer and I say "yes"
5.  No launcher window appears.  If  I double click on the Icon it says "Launcher is already running on this machine"
6.  The app was installed using ADMINISTRATOR privilege's.
7.  The app is being run using administrator privilege's.
8.  I have killed the app numerous times using task manager and tried different things like running in compatibility mode etc. all to no avail.  Same results.

Thanks in advance.

Joe K8FC


Dave AA6YQ
 

+ AA6YQ comments below

Hello folks. I am trying to install Launcher on a Dell Windows 11 laptop so that I may load the other suite apps. What follows is the process and results.

1. Download Launcher from http://www.dxlabsuite.com/download.htm
2. Run the installation program as instructed and did not change any file locations.
3. After install completes, launching the program (Launcher) results in a short delay while the program loads.
4. After a moment MS UAC pops up and wants to know if I want to allow 'Launcher' to make changes to this computer and I say "yes"
5. No launcher window appears. If I double click on the Icon it says "Launcher is already running on this machine"
6. The app was installed using ADMINISTRATOR privilege's.
7. The app is being run using administrator privilege's.
8. I have killed the app numerous times using task manager and tried different things like running in compatibility mode etc. all to no avail. Same results.

+ Most likely, your anti-malware is interfering. Configure it to consider DXLabLauncher.exe to be safe; do the same with every other DXLab application you install.

+ Every publicly-released DXLab application has been reviewed by Microsoft and deemed free of malware. If you're using Windows Defender, direct it to update its virus definitions via

https://www.microsoft.com/en-us/wdsi/definitions

73,

Dave, AA6YQ


neil_zampella
 

Don't run with Administrator privileges .... the 'Getting Started' article listed here:  http://www.dxlabsuite.com/dxlabwiki/RunningOnWin7
specifically points out to install as normal, and use the default user permissions, and default directory.

I'd uninstall, then run the install file again using all defaults.    If you're the main user on the computer, you should already have the proper permissions needed, no need to do anything about the program 'running as administrator'.

Neil, KN3ILZ

On 12/29/2021 2:19 PM, dxradio33 wrote:
Hello folks.  I am trying to install Launcher on a Dell Windows 11 laptop so that I may load the other suite apps.  What follows is the process and results.

1.  Download Launcher from http://www.dxlabsuite.com/download.htm
2.  Run the installation program as instructed and did not change any file locations. 
3.  After install completes, launching the program (Launcher) results in  a short delay while the program loads.
4.  After a moment MS UAC pops up and wants to know if I want to allow 'Launcher' to make changes to this computer and I say "yes"
5.  No launcher window appears.  If  I double click on the Icon it says "Launcher is already running on this machine"
6.  The app was installed using ADMINISTRATOR privilege's.
7.  The app is being run using administrator privilege's.
8.  I have killed the app numerous times using task manager and tried different things like running in compatibility mode etc. all to no avail.  Same results.

Thanks in advance.

Joe K8FC


dxradio33
 

Dave, I have no anti-malware configured other than Windows Defender. Windows Defender is up to date. I have added incoming and outgoing rules to Windows Defender and the results are the same. On the allowed apps and features tab of Windows Defender is this: 'DxLab Launcher as well as DXLab Launcher Upgrade agent.' The method I used to add the programs in Defender was the rule wizard that navigates to the exact application you want to allow. No ambiguity or mistakes in the addition. Also, I uninstalled the DXLab Launcher program after instantiating the rules. I re-installed DXLab Launcher using the downloaded file (ran as an administrator) as before and checked that the program was allowed by Defender. The results are the same. Running out of things to do.

Thanks

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 15:53
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

+ AA6YQ comments below

Hello folks. I am trying to install Launcher on a Dell Windows 11 laptop so that I may load the other suite apps. What follows is the process and results.

1. Download Launcher from http://www.dxlabsuite.com/download.htm
2. Run the installation program as instructed and did not change any file locations.
3. After install completes, launching the program (Launcher) results in a short delay while the program loads.
4. After a moment MS UAC pops up and wants to know if I want to allow 'Launcher' to make changes to this computer and I say "yes"
5. No launcher window appears. If I double click on the Icon it says "Launcher is already running on this machine"
6. The app was installed using ADMINISTRATOR privilege's.
7. The app is being run using administrator privilege's.
8. I have killed the app numerous times using task manager and tried different things like running in compatibility mode etc. all to no avail. Same results.

+ Most likely, your anti-malware is interfering. Configure it to consider DXLabLauncher.exe to be safe; do the same with every other DXLab application you install.

+ Every publicly-released DXLab application has been reviewed by Microsoft and deemed free of malware. If you're using Windows Defender, direct it to update its virus definitions via

https://www.microsoft.com/en-us/wdsi/definitions

73,

Dave, AA6YQ


dxradio33
 

Niel,  the instructions say “Log into an account with administrator privilege”  I am, of course, the administrator on this laptop.  So I have done exactly what the instructions said accepting all the defaults  and that is why the original message was sent.  I went through all these other iterations trying to see if something would work.  If you have read the last message I posted  about Windows Defender you can see my multiple attempts at trying to fix this.  Also, by default the Icon that appears on the desktop after installation appears with a Windows shield on it indicating that it wants to be run with elevated privileges.  So, in any iteration of trying to run this ap, it runs but does not display the Launcher window.

 

Thanks

 

Joe

 

From: DXLab@groups.io <DXLab@groups.io> On Behalf Of neil_zampella
Sent: Wednesday, December 29, 2021 15:55
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

 

Don't run with Administrator privileges .... the 'Getting Started' article listed here:  http://www.dxlabsuite.com/dxlabwiki/RunningOnWin7
specifically points out to install as normal, and use the default user permissions, and default directory.

I'd uninstall, then run the install file again using all defaults.    If you're the main user on the computer, you should already have the proper permissions needed, no need to do anything about the program 'running as administrator'.

Neil, KN3ILZ

On 12/29/2021 2:19 PM, dxradio33 wrote:

Hello folks.  I am trying to install Launcher on a Dell Windows 11 laptop so that I may load the other suite apps.  What follows is the process and results.

1.  Download Launcher from http://www.dxlabsuite.com/download.htm
2.  Run the installation program as instructed and did not change any file locations. 
3.  After install completes, launching the program (Launcher) results in  a short delay while the program loads.
4.  After a moment MS UAC pops up and wants to know if I want to allow 'Launcher' to make changes to this computer and I say "yes"
5.  No launcher window appears.  If  I double click on the Icon it says "Launcher is already running on this machine"
6.  The app was installed using ADMINISTRATOR privilege's.
7.  The app is being run using administrator privilege's.
8.  I have killed the app numerous times using task manager and tried different things like running in compatibility mode etc. all to no avail.  Same results.

Thanks in advance.

Joe K8FC


Dave AA6YQ
 

+ AA6YQ comments below

Niel, the instructions say “Log into an account with administrator privilege” I am, of course, the administrator on this laptop. So I have done exactly what the instructions said accepting all the defaults and that is why the original message was sent. I went through all these other iterations trying to see if something would work. If you have read the last message I posted about Windows Defender you can see my multiple attempts at trying to fix this. Also, by default the Icon that appears on the desktop after installation appears with a Windows shield on it indicating that it wants to be run with elevated privileges. So, in any iteration of trying to run this ap, it runs but does not display the Launcher window.

+ Logging into an account with administrator privilege is only required if you install a DXLab application into a folder that Windows considers "protected", like

C:\Program Files (x86)\DXLab

+ If you install your DXLab applications into the default folder C:\DXLab this is not required.

+ After you start the Launcher, please start the Windows Task Manager. Does "DXLabLauncher" appear in the list of running applications?

73,

Dave, AA6YQ


dxradio33
 

Thank you Dave, I know you are busy with a ton of stuff. I am not critical with this as it just an effort to use a laptop with a new small rig. I can do something else if it comes to that. As far as the 'administrator' thread in these messages go, I am aware of the need to be elevated if you decide to move the folder to a protected area. This is not the case and never has been. Launcher was installed as directed.

Launcher does appear in the task manager. This is the only way I have been able to kill the process without rebooting and trying to re-run the application after a change has been made.

One little bit more information, this is a fairly new Dell i7 machine that came with windows 10. I accepted the invitation to upgrade to Windows 11 and that is its current state. To be fair, I never tried to load Launcher under the previous OS so I cannot comment on usability with Windows 10 (on this laptop).

So, it really is more upsetting because I cannot solve this issue than it is not having the ability to run DXLabs on this laptop.

Again, no need to spend any more time on this. I will muddle with it and let you know if I come up with anything.

Thanks again for your help. And thank you Neil for your input.

Joe

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 18:41
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

+ AA6YQ comments below

Niel, the instructions say “Log into an account with administrator privilege” I am, of course, the administrator on this laptop. So I have done exactly what the instructions said accepting all the defaults and that is why the original message was sent. I went through all these other iterations trying to see if something would work. If you have read the last message I posted about Windows Defender you can see my multiple attempts at trying to fix this. Also, by default the Icon that appears on the desktop after installation appears with a Windows shield on it indicating that it wants to be run with elevated privileges. So, in any iteration of trying to run this ap, it runs but does not display the Launcher window.

+ Logging into an account with administrator privilege is only required if you install a DXLab application into a folder that Windows considers "protected", like

C:\Program Files (x86)\DXLab

+ If you install your DXLab applications into the default folder C:\DXLab this is not required.

+ After you start the Launcher, please start the Windows Task Manager. Does "DXLabLauncher" appear in the list of running applications?

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below
Thank you Dave, I know you are busy with a ton of stuff.

+ Helping users overcome problems with DXLab applications is my highest priority.

 

I am not critical with this as it just an effort to use a laptop with a new small rig. I can do something else if it comes to that. As far as the 'administrator' thread in these messages go, I am aware of the need to be elevated if you decide to move the folder to a protected area. This is not the case and never has been. Launcher was installed as directed.

+ In what folder is the Launcher installed?

 

Launcher does appear in the task manager. This is the only way I have been able to kill the process without rebooting and trying to re-run the application after a change has been made.

+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

+ Is there any difference in behavior if you use Windows Explorer to navigate to your Launcher folder an double-click the entry for

DXLabLauncher.exe 

?

     73,

             Dave, AA6YQ


dxradio33
 

Dave,

+ In what folder is the Launcher installed?

Launcher is installed in C:\DXLab\Launcher

 

+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

 

No!  Launcher does NOT appear in the Windows task bar.  That is the first clue I had that something was amiss.   I was hoping that the window was just off the display screen and I could bring it back by Shift+(right-click) and moving it back.  But that is not the case.  Launcher (launches) and never appears on the task bar but it is running as indicated by the Task Manager. 

 

+ Is there any difference in behavior if you use Windows Explorer to navigate to your Launcher folder an double-click the entry for
DXLabLauncher.exe 


Ok, if I navigate to the folder (using Windows Explorer) and double click on Launcher.exe the same result, no window but Launcher appears in the task manager (consuming 0 zero CPU resources and 1.3 mb of memory)  I checked Launcher on my desktop regular machine that I use daily with DXLabs and launcher is consuming 0% CPU but 4 MB of memory).  Also, according to the task manager properties of Launcher (on the laptop) it says (I cannot cut and paste because I am using the mail client on a different machine) “DXLabLauncher.exe Process ID = 2476 Status=running User name = k8fc CPU=00 Memory (actual)=1356K Description = DXLabLauncher.

 

So, I believe I have answered your questions.  Thanks again.

 

Joe

 

From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 19:21
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

 

+ AA6YQ comments below

Thank you Dave, I know you are busy with a ton of stuff.

+ Helping users overcome problems with DXLab applications is my highest priority.

 

I am not critical with this as it just an effort to use a laptop with a new small rig. I can do something else if it comes to that. As far as the 'administrator' thread in these messages go, I am aware of the need to be elevated if you decide to move the folder to a protected area. This is not the case and never has been. Launcher was installed as directed.

+ In what folder is the Launcher installed?

 

Launcher does appear in the task manager. This is the only way I have been able to kill the process without rebooting and trying to re-run the application after a change has been made.

+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

+ Is there any difference in behavior if you use Windows Explorer to navigate to your Launcher folder an double-click the entry for

DXLabLauncher.exe 

?

     73,

             Dave, AA6YQ


Dave AA6YQ
 

* more AA6YQ comments below

+ In what folder is the Launcher installed?

Launcher is installed in C:\DXLab\Launcher

* Perfect. There is no need for Admin privileges, then. Please try starting the Launcher without them.


+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

No! Launcher does NOT appear in the Windows task bar. That is the first clue I had that something was amiss. I was hoping that the window was just off the display screen and I could bring it back by Shift+(right-click) and moving it back.

* I had the same corrective action in mind.


+ Is there any difference in behavior if you use Windows Explorer to
+ navigate to your Launcher folder an double-click the entry for
DXLabLauncher.exe

Ok, if I navigate to the folder (using Windows Explorer) and double click on Launcher.exe the same result, no window but Launcher appears in the task manager (consuming 0 zero CPU resources and 1.3 mb of memory) I checked Launcher on my desktop regular machine that I use daily with DXLabs and launcher is consuming 0% CPU but 4 MB of memory). Also, according to the task manager properties of Launcher (on the laptop) it says (I cannot cut and paste because I am using the mail client on a different machine) “DXLabLauncher.exe Process ID = 2476 Status=running User name = k8fc CPU=00 Memory (actual)=1356K Description = DXLabLauncher.

* The Launcher uses no CPU resources unless you direct it to install or update an application.

* If starting the Launcher without Admin privileges doesn't help, then the next step will be to send you a script that enables the Launcher's "Log debugging info" setting in the Windows Registry. This would reveal how far the Launcher is getting after startup -- if it's really being started.

* I don't recall anyone ever reporting this behavior...

73,

Dave, AA6YQ


dxradio33
 

Well, good news. I have it working but not quite the way I had envisioned.

It seemed logical to me that my elevated user status may have been somewhat responsible for this behavior.

My solution is as follows:

Since I was the one and only user on this laptop, I of course was an administrator. Thinking that this may be part of the problem, I created a new user account. Not that easy as I had to create a new email address in my domain that was legal. Once I created the user and email account I was able to create a normal user account without administrative privileges. I logged out of my main account and logged in as the new user (dxlabuser). When the setup process completed I created a link to Launcher on the desktop. It opens immediately. Of course, all dots are black as I have not installed any apps yet. But, it is working and I can start using it. I am probably better off using this account with the Ten Tec Argonaut as I can install apps to support the radio and contesting with this little rig.

Although I have nothing tangible as to cause and effect, it would seem that my user status was the issue.

Thanks for the dialog and help Dave.

Problem is solved to my satisfaction.

Joe

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 21:01
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

* more AA6YQ comments below

+ In what folder is the Launcher installed?

Launcher is installed in C:\DXLab\Launcher

* Perfect. There is no need for Admin privileges, then. Please try starting the Launcher without them.


+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

No! Launcher does NOT appear in the Windows task bar. That is the first clue I had that something was amiss. I was hoping that the window was just off the display screen and I could bring it back by Shift+(right-click) and moving it back.

* I had the same corrective action in mind.


+ Is there any difference in behavior if you use Windows Explorer to
+ navigate to your Launcher folder an double-click the entry for
DXLabLauncher.exe

Ok, if I navigate to the folder (using Windows Explorer) and double click on Launcher.exe the same result, no window but Launcher appears in the task manager (consuming 0 zero CPU resources and 1.3 mb of memory) I checked Launcher on my desktop regular machine that I use daily with DXLabs and launcher is consuming 0% CPU but 4 MB of memory). Also, according to the task manager properties of Launcher (on the laptop) it says (I cannot cut and paste because I am using the mail client on a different machine) “DXLabLauncher.exe Process ID = 2476 Status=running User name = k8fc CPU=00 Memory (actual)=1356K Description = DXLabLauncher.

* The Launcher uses no CPU resources unless you direct it to install or update an application.

* If starting the Launcher without Admin privileges doesn't help, then the next step will be to send you a script that enables the Launcher's "Log debugging info" setting in the Windows Registry. This would reveal how far the Launcher is getting after startup -- if it's really being started.

* I don't recall anyone ever reporting this behavior...

73,

Dave, AA6YQ


neil_zampella
 

FWIW ... I also am the only user on my dedicated radio laptop, and I
didn't have to go through those hoops to get it to run. There's
something else weird going on.

Neil, KN3ILZ

On 12/29/2021 10:32 PM, dxradio33 wrote:
Well, good news. I have it working but not quite the way I had envisioned.

It seemed logical to me that my elevated user status may have been somewhat responsible for this behavior.

My solution is as follows:

Since I was the one and only user on this laptop, I of course was an administrator. Thinking that this may be part of the problem, I created a new user account. Not that easy as I had to create a new email address in my domain that was legal. Once I created the user and email account I was able to create a normal user account without administrative privileges. I logged out of my main account and logged in as the new user (dxlabuser). When the setup process completed I created a link to Launcher on the desktop. It opens immediately. Of course, all dots are black as I have not installed any apps yet. But, it is working and I can start using it. I am probably better off using this account with the Ten Tec Argonaut as I can install apps to support the radio and contesting with this little rig.

Although I have nothing tangible as to cause and effect, it would seem that my user status was the issue.

Thanks for the dialog and help Dave.

Problem is solved to my satisfaction.

Joe

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 21:01
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

* more AA6YQ comments below

+ In what folder is the Launcher installed?

Launcher is installed in C:\DXLab\Launcher

* Perfect. There is no need for Admin privileges, then. Please try starting the Launcher without them.


+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

No! Launcher does NOT appear in the Windows task bar. That is the first clue I had that something was amiss. I was hoping that the window was just off the display screen and I could bring it back by Shift+(right-click) and moving it back.

* I had the same corrective action in mind.


+ Is there any difference in behavior if you use Windows Explorer to
+ navigate to your Launcher folder an double-click the entry for
DXLabLauncher.exe

Ok, if I navigate to the folder (using Windows Explorer) and double click on Launcher.exe the same result, no window but Launcher appears in the task manager (consuming 0 zero CPU resources and 1.3 mb of memory) I checked Launcher on my desktop regular machine that I use daily with DXLabs and launcher is consuming 0% CPU but 4 MB of memory). Also, according to the task manager properties of Launcher (on the laptop) it says (I cannot cut and paste because I am using the mail client on a different machine) “DXLabLauncher.exe Process ID = 2476 Status=running User name = k8fc CPU=00 Memory (actual)=1356K Description = DXLabLauncher.

* The Launcher uses no CPU resources unless you direct it to install or update an application.

* If starting the Launcher without Admin privileges doesn't help, then the next step will be to send you a script that enables the Launcher's "Log debugging info" setting in the Windows Registry. This would reveal how far the Launcher is getting after startup -- if it's really being started.

* I don't recall anyone ever reporting this behavior...

73,

Dave, AA6YQ











dxradio33
 

That's exactly right. That is what started this thread. It would not work on that laptop with one administrative user, me. There are a zillion one user laptops in the world and I am sure they are all able to run launcher. My laptop does not. I suspect it is a combination of Windows 11, some old Windows 10 glue and black magic. In any event, it works as designed with a different user. In this case, the end justifies the means.

73

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of neil_zampella
Sent: Wednesday, December 29, 2021 23:48
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

FWIW ... I also am the only user on my dedicated radio laptop, and I didn't have to go through those hoops to get it to run. There's something else weird going on.

Neil, KN3ILZ

On 12/29/2021 10:32 PM, dxradio33 wrote:
Well, good news. I have it working but not quite the way I had envisioned.

It seemed logical to me that my elevated user status may have been somewhat responsible for this behavior.

My solution is as follows:

Since I was the one and only user on this laptop, I of course was an administrator. Thinking that this may be part of the problem, I created a new user account. Not that easy as I had to create a new email address in my domain that was legal. Once I created the user and email account I was able to create a normal user account without administrative privileges. I logged out of my main account and logged in as the new user (dxlabuser). When the setup process completed I created a link to Launcher on the desktop. It opens immediately. Of course, all dots are black as I have not installed any apps yet. But, it is working and I can start using it. I am probably better off using this account with the Ten Tec Argonaut as I can install apps to support the radio and contesting with this little rig.

Although I have nothing tangible as to cause and effect, it would seem that my user status was the issue.

Thanks for the dialog and help Dave.

Problem is solved to my satisfaction.

Joe

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, December 29, 2021 21:01
To: DXLab@groups.io
Subject: Re: [DXLab] Launcher installation issues

* more AA6YQ comments below

+ In what folder is the Launcher installed?

Launcher is installed in C:\DXLab\Launcher

* Perfect. There is no need for Admin privileges, then. Please try starting the Launcher without them.


+ Thanks. When you start it, does the Launcher appear on the Windows Task Bar?

No! Launcher does NOT appear in the Windows task bar. That is the first clue I had that something was amiss. I was hoping that the window was just off the display screen and I could bring it back by Shift+(right-click) and moving it back.

* I had the same corrective action in mind.


+ Is there any difference in behavior if you use Windows Explorer to
+ navigate to your Launcher folder an double-click the entry for
DXLabLauncher.exe

Ok, if I navigate to the folder (using Windows Explorer) and double click on Launcher.exe the same result, no window but Launcher appears in the task manager (consuming 0 zero CPU resources and 1.3 mb of memory) I checked Launcher on my desktop regular machine that I use daily with DXLabs and launcher is consuming 0% CPU but 4 MB of memory). Also, according to the task manager properties of Launcher (on the laptop) it says (I cannot cut and paste because I am using the mail client on a different machine) “DXLabLauncher.exe Process ID = 2476 Status=running User name = k8fc CPU=00 Memory (actual)=1356K Description = DXLabLauncher.

* The Launcher uses no CPU resources unless you direct it to install or update an application.

* If starting the Launcher without Admin privileges doesn't help, then the next step will be to send you a script that enables the Launcher's "Log debugging info" setting in the Windows Registry. This would reveal how far the Launcher is getting after startup -- if it's really being started.

* I don't recall anyone ever reporting this behavior...

73,

Dave, AA6YQ












Dave AA6YQ
 

+ AA6YQ comments below
That's exactly right. That is what started this thread. It would not work on that laptop with one administrative user, me. There are a zillion one user laptops in the world and I am sure they are all able to run launcher. My laptop does not. I suspect it is a combination of Windows 11, some old Windows 10 glue and black magic. In any event, it works as designed with a different user. In this case, the end justifies the means.

+ I'm glad you got it running, Joe. As I reported earlier , your experience was unique, but I suspect we'd need help with someone with deep Windows internal experience to provide an explanation.

      73,

             Dave, AA6YQ


Stephen Schrack
 

Hello,

I know this topic is 6 months old but, this issue is happening to me as well.  I am a long time user of DXLab and have migrated DXLab to a number of new computers each time I upgrade my desktop computer to new hardware.  In fact, back in March I did a complete clean install of Windows 11 and had no issues getting DXLab up and running again.  Now this past week I swapped out motherboard, processor, RAM and new SSD hard drive.  So in effect brand new computer.  Clean installed Windows 11 and did a few days of burn in to make sure everything is up and running nicely.  I installed DXLauncher to begin the process of reinstalling DXLab.  No matter what I did last night Launcher installed successfully but the window would not come up.  It is running, as task manager shows it running, but the window never appears.  I have experienced previously DXLauncher being delayed before the window appears but never where it would not come up at all.  There is something to be looked at here.  Any thoughts?  I am the only user on this computer at the moment and do not really want to create another account as mentioned above to get it working.  Everything described above by the original poster is exactly what I am seeing including the steps he took.  I have not created another account yet.  I have 30 years of IT and system building experience so not afraid to take troubleshooting steps if anybody has some suggestions.

Thanks and 73 Steve N3MX


Joe Subich, W4TV
 

As previously discussed, your problem is symptomatic of Windows opening
a program off screen. Use Google, search for "Windows off screen" and
use one of the many suggestions from there.

73,

... Joe, W4TV

On 2022-06-21 9:48 AM, Stephen Schrack wrote:
Hello,
I know this topic is 6 months old but, this issue is happening to me as well.  I am a long time user of DXLab and have migrated DXLab to a number of new computers each time I upgrade my desktop computer to new hardware.  In fact, back in March I did a complete clean install of Windows 11 and had no issues getting DXLab up and running again.  Now this past week I swapped out motherboard, processor, RAM and new SSD hard drive.  So in effect brand new computer.  Clean installed Windows 11 and did a few days of burn in to make sure everything is up and running nicely.  I installed DXLauncher to begin the process of reinstalling DXLab.  No matter what I did last night Launcher installed successfully but the window would not come up.  It is running, as task manager shows it running, but the window never appears.  I have experienced previously DXLauncher being delayed before the window appears but never where it would not come up at all.  There is something to be looked at here.  Any thoughts?  I am the only user on this computer at the moment and do not really want to create another account as mentioned above to get it working.  Everything described above by the original poster is exactly what I am seeing including the steps he took.  I have not created another account yet.  I have 30 years of IT and system building experience so not afraid to take troubleshooting steps if anybody has some suggestions.
Thanks and 73 Steve N3MX


Stephen Schrack
 

Hi Joe,

If that were the case, DXLauncher would still show up on the taskbar but it does not.  I do have two monitors and they are operating at the recommended screen resolution.  

73 Steve N3MX


Dave AA6YQ
 

+ AA6YQ comments below
If that were the case, DXLauncher would still show up on the taskbar but it does not.  I do have two monitors and they are operating at the recommended screen resolution
+ Please reboot Windows into "Safe mode with networking", and then start the Launcher. What happens?

       73,

              Dave, AA6YQ


Stephen Schrack
 

Hi Dave,

I will do this when I get home around 6 or 6:30pm EDT today and report back.

Steve N3MX


Stephen Schrack
 

Hi Dave,

DXLauncher does work in Safe Mode with Networking.  I updated it to 2.17.  However, I still cannot launch DXLauncher from my main account in normal mode.  Any suggestions?

73 Steve N3MX