Topics

Interesting Issue with DXC/WSJT-X and Kenwood TS-590sg

Hasan Schiers N0AN
 

Win10 Pro, Latest, 8 gB Ram, Intel Core I5
On FT8 (or any digital mode of WSJT-X.)

I was frequently being told by a distant station (while we were experimenting and troubleshooting) that the freq I said I was tx'ing on was NOT the freq I was really on. Many times during our experiment I was 500 or 1000 Hz off. (Always, exactly that amount).

After playing around with as many variables that seemed to be potentially connected to the problem, I stumbled on it:

In WSJT-X > Settings > Radio, I had to increase the Poll Interval (Extreme Right from Rig:), from 1 sec to 2 sec.

Problem solved. The freq was not getting properly updated.

Just in case anyone has a similar problem.

In FT8, the problem is not obvious, because FT8 doesn't care what freq you transmit own, it decodes the entire passband. I only noticed it when we were trying to fix another fellow's Anan, which was showing frequency instability (slanted decodes).

73, N0AN
Hasan

Dave AA6YQ
 

+ AA6YQ comments below

Win10 Pro, Latest, 8 gB Ram, Intel Core I5

On FT8 (or any digital mode of WSJT-X.)

I was frequently being told by a distant station (while we were experimenting and troubleshooting) that the freq I said I was tx'ing on was NOT the freq I was really on. Many times during our experiment I was 500 or 1000 Hz off. (Always, exactly that amount).

After playing around with as many variables that seemed to be potentially connected to the problem, I stumbled on it:

In WSJT-X > Settings > Radio, I had to increase the Poll Interval (Extreme Right from Rig:), from 1 sec to 2 sec.

Problem solved. The freq was not getting properly updated.

Just in case anyone has a similar problem.

In FT8, the problem is not obvious, because FT8 doesn't care what freq you transmit own, it decodes the entire passband. I only noticed it when we were trying to fix another fellow's Anan, which was showing frequency instability (slanted decodes).

+ If you have WSJT-X configured to use Commander for transceiver control, then when receiving or transmitting, the frequency shown in the bottom left corner of the WSJT-X window should track the frequency shown on Commander's Main window at the rate specified by the WSJT-X "Poll Interval". If it doesn't, there's a problem to be tracked down and corrected.

+ The fact that your transmit frequency was "500 or 1000 Hz off" sounds like a problem with "Split Operation". How do you have this panel configured on the Radio tab of the WSJT-X Settings window?

73,

Dave, AA6YQ

Hasan Schiers N0AN
 

It acted the same whether I had Rig or Fake It set for Split operation, Dave. I normally run it in Rig.
The problem was the change in freq would not "take" until I changed the Poll Interval from 1 sec to 2 sec. Every since then, it has worked perfectly.

Every since I made the change (1 to 2 sec), I now hear the 590sg ack the change (it produces a tone anytime the CAT causes a freq change). If I go back to 1 sec, the ack from the 590sg does not happen, and it is then I find that X says the freq has changed, but Commander has not successfully caused the 590sg to actually change. As soon as I changed Poll Interval to 2 sec, they all move together in sync.

I assumed there was just a timing issue. I wasn't reporting a bug, just something that I needed to do to get it to "talk to each other" properly. It is possible I have some other setting wrong, but this is the same setup I've been using in X for years. The only new thing was integrating it with DXLab which has gone very, very well.

This Suite of programs is simply outstanding! Let me know if there is something else I should do.
73, N0AN
Hasan


On Mon, Jan 20, 2020 at 2:37 PM Dave AA6YQ <aa6yq@...> wrote:
+ AA6YQ comments below

Win10 Pro, Latest, 8 gB Ram, Intel Core I5

On FT8 (or any digital mode of WSJT-X.)

I was frequently being told by a distant station (while we were experimenting and troubleshooting) that the freq I said I was tx'ing on was NOT the freq I was really on. Many times during our experiment I was 500 or 1000 Hz off. (Always, exactly that amount).

After playing around with as many variables that seemed to be potentially connected to the problem, I stumbled on it:

In WSJT-X > Settings > Radio, I had to increase the Poll Interval (Extreme Right from Rig:), from 1 sec to 2 sec.

Problem solved. The freq was not getting properly updated.

Just in case anyone has a similar problem.

In FT8, the problem is not obvious, because FT8 doesn't care what freq you transmit own, it decodes the entire passband. I only noticed it when we were trying to fix another fellow's Anan, which was showing frequency instability (slanted decodes).

+ If you have WSJT-X configured to use Commander for transceiver control, then when receiving or transmitting, the frequency shown in the bottom left corner of the WSJT-X window should track the frequency shown on Commander's Main window at the rate specified by the WSJT-X "Poll Interval". If it doesn't, there's a problem to be tracked down and corrected.

+ The fact that your transmit frequency was "500 or 1000 Hz off" sounds like a problem with "Split Operation". How do you have this panel configured on the Radio tab of the WSJT-X Settings window?

       73,

              Dave, AA6YQ






Dave AA6YQ
 

+ AA6YQ comments below

It acted the same whether I had Rig or Fake It set for Split operation, Dave. I normally run it in Rig.
The problem was the change in freq would not "take" until I changed the Poll Interval from 1 sec to 2 sec. Every since then, it has worked perfectly.

Every since I made the change (1 to 2 sec), I now hear the 590sg ack the change (it produces a tone anytime the CAT causes a freq change). If I go back to 1 sec, the ack from the 590sg does not happen, and it is then I find that X says the freq has changed, but Commander has not successfully caused the 590sg to actually change. As soon as I changed Poll Interval to 2 sec, they all move together in sync.

I assumed there was just a timing issue. I wasn't reporting a bug, just something that I needed to do to get it to "talk to each other" properly. It is possible I have some other setting wrong, but this is the same setup I've been using in X for years. The only new thing was integrating it with DXLab which has gone very, very well.

This Suite of programs is simply outstanding! Let me know if there is something else I should do.


+ So that I can see what's going on, please do the following:

1. on the General tab of Commander's Configuration window, check the "Log Debugging Info" box

2. terminate Commander

3. set the WSJT-X polling interval to "1 s"

4. reduce your transceiver's RF power output to 0

5. using its front panel, set your transceiver to 7005 in CW

5. start Commander

6. choose a new FT8 band in WSJT-X, and wait for Commander to QSY to that band

7. set WSJT-X to transmit on a clear frequency around an offset of 1000 hz, and initiate a CQ

8. when transmitting, the frequency shown in the lower-left corner of the WSJT-X window should QSY down 500 hz

9. when the transmission is complete,

9a . on the General tab of Commander's Configuration window, uncheck the "Log Debugging Info" box

9b. restore your radio's RF power output to its normal setting

9c. attach the errorlog.txt file from your Commander folder to an email message, and send the message to me via

aa6yq (at) ambersoft.com

73,

Dave, AA6YQ

Hasan Schiers N0AN
 

Ok Dave, I'll try to do that tomorrow.
73, N0AN
Hasan


On Mon, Jan 20, 2020 at 3:25 PM Dave AA6YQ <aa6yq@...> wrote:
+ AA6YQ comments below

It acted the same whether I had Rig or Fake It set for Split operation, Dave. I normally run it in Rig.
The problem was the change in freq would not "take" until I changed the Poll Interval from 1 sec to 2 sec. Every since then, it has worked perfectly.

Every since I made the change (1 to 2 sec), I now hear the 590sg ack the change (it produces a tone anytime the CAT causes a freq change). If I go back to 1 sec, the ack from the 590sg does not happen, and it is then I find that X says the freq has changed, but Commander has not successfully caused the 590sg to actually change. As soon as I changed Poll Interval to 2 sec, they all move together in sync.

I assumed there was just a timing issue. I wasn't reporting a bug, just something that I needed to do to get it to "talk to each other" properly. It is possible I have some other setting wrong, but this is the same setup I've been using in X for years. The only new thing was integrating it with DXLab which has gone very, very well.

This Suite of programs is simply outstanding! Let me know if there is something else I should do.


+ So that I can see what's going on, please do the following:

1.  on the General tab of Commander's Configuration window, check the "Log Debugging Info" box

2. terminate Commander

3. set the WSJT-X polling interval to "1 s"

4. reduce your transceiver's RF power output to 0

5. using its front panel, set your transceiver to 7005 in CW

5. start Commander

6. choose a new FT8 band in WSJT-X, and wait for Commander to QSY to that band

7. set WSJT-X to transmit on a clear frequency around an offset of 1000 hz, and initiate a CQ

8. when transmitting,  the frequency shown in the lower-left corner of the WSJT-X window should QSY down 500 hz

9. when the transmission is complete,

9a . on the General tab of Commander's Configuration window, uncheck the "Log Debugging Info" box

9b. restore your radio's RF power output to its normal setting

9c. attach the errorlog.txt file from your Commander folder to an email message, and send the message to me via

aa6yq (at) ambersoft.com

        73,

                Dave, AA6YQ





Dave AA6YQ
 

+ AA6YQ comments below

Ok Dave, I'll try to do that tomorrow.

+ At your convenience...

73,

Dave, AA6YQ