Incorrect ITU country prefix logged


Steve, N5EP
 

Today I worked a station in Northern Ireland with call beginning "MI0".  MI is one of the prefixes used for Northern Ireland, but in DXKeeper's DXCC field it was saved as "G" (England) instead of "GI".  Last November I worked another station with call beginning "MI5", and it correctly saved the DXCC value "GI".  Why was today's contact saved with the wrong value? 

Last December, between the two QSOs, I did move to a new computer, so I suspect something like my copy of the DXCC database or something else is out of date.  Is that the problem?

Thanks.

Steve, N5EP


Joe Subich, W4TV
 

On 2021-10-23 4:20 PM, Steve, N5EP via groups.io wrote:
Today I worked a station in Northern Ireland with call beginning
"MI0". MI is one of the prefixes used for Northern Ireland, but in
DXKeeper's DXCC field it was saved as "G" (England) instead of "GI".
DXCC Database 2.6.1 properly recognizes MI0 callsigns as Northern
Ireland.

What was the specific callsign that was logged as G instead of GI?

Do you have a previous QSO with that callsign in DXKeeper? Do you
have an override for that callsign that defines G instead of GI?

73,

... Joe, W4TV


On 2021-10-23 4:20 PM, Steve, N5EP via groups.io wrote:
Today I worked a station in Northern Ireland with call beginning "MI0". MI is one of the prefixes used for Northern Ireland, but in DXKeeper's DXCC field it was saved as "G" (England) instead of "GI".  Last November I worked another station with call beginning "MI5", and it correctly saved the DXCC value "GI".  Why was today's contact saved with the wrong value?
Last December, between the two QSOs, I did move to a new computer, so I suspect something like my copy of the DXCC database or something else is out of date.  Is that the problem?
Thanks.
Steve, N5EP


Dave AA6YQ
 

Today I worked a station in Northern Ireland with call beginning "MI0". MI is one of the prefixes used for Northern Ireland, but in DXKeeper's DXCC field it was saved as "G" (England) instead of "GI". Last November I worked another station with call beginning "MI5", and it correctly saved the DXCC value "GI". Why was today's contact saved with the wrong value?

Last December, between the two QSOs, I did move to a new computer, so I suspect something like my copy of the DXCC database or something else is out of date. Is that the problem?

+ The current DXCC database (version 2.6.1) considers any callsign beginning with MI as "Northern Ireland". To see this, type MI or MI0 into DXView's callsign box, and strike the Enter key.

+ Possible reasons why your MI0 QSO was logged with a DXCC entity of "England":

1. the QSO was logged from another application that conveyed the QSO to DXKeeper with a DXCC entity of "England"

2. DXView's "Override List" contains an entry for the callsign that specifies its DXCC entity as "England"

3. You have a previously logged QSO with the callsign that specifies a DXCC entity of "England"

4. You have DXKeeper configured to perform a callbook lookup, which reported the callsign's DXCC entity as "England"

73,

Dave, AA6YQ


Steve, N5EP
 

None of the first three possible reasons apply.  The QSO was logged in DXKeper.  There are no entries in DXView's "Override List".  I have no previously logged QSOs with MI0HOZ, the callsign in question.

DXKeeper's Callbook config tab has my login info for QRZ.com XML Data.  However, the box for "Automatically use callbook data to initialize new QSOs is NOT checked.  Is there some other place where DXKeeper is configured to perform a callbook lookup? 

MI0HOZ's information in QRZ.com appears to be correct.

Steve, N5EP


Dave AA6YQ
 

+ AA6YQ comments below

None of the first three possible reasons apply. The QSO was logged in DXKeper. There are no entries in DXView's "Override List". I have no previously logged QSOs with MI0HOZ, the callsign in question.

DXKeeper's Callbook config tab has my login info for QRZ.com XML Data. However, the box for "Automatically use callbook data to initialize new QSOs is NOT checked. Is there some other place where DXKeeper is configured to perform a callbook lookup?

MI0HOZ's information in QRZ.com appears to be correct.

+ OK. Please do the following:

1. terminate SpotCollector, if it's running

2. in DXKeeper, temporarily disable any automatic uploading of QSOs to Club Log, eQSL, or LoTW

3. in the "Log file" panel on the Log tab of DXKeeper's Configuration window, change the pathname to Test.mdb in the same folder as your current log file and click the Create button

4. on the Configuration window's log tab, check the "Log debugging info" box

5. terminate DXKeeper

6. start DXKeeper

7. using the Capture window, log a QSO with MI0HOZ

8. on the Configuration window's log tab, uncheck the "Log debugging info" box

9. What DXCC entity was logged with the QSO? If not "Northern Ireland", attach the errorlog.txt file from your DXKeeper folder to an email message, and send the message to me via

aa6yq (at) ambersof.com

10. in the "Log file" panel on the Log tab of DXKeeper's Configuration window, click the Select button and use the "Select existing log..." window to select your log file

11. restore any automatic uploading of QSOs to Club Log, eQSL, or LoTW that you disabled in step 2 above

73,

Dave, AA6YQ


Steve, N5EP
 

Dave, sorry it took me a few days to run your experiment. 

I did not need to disable automatic uploading, as I don't use it.  I always upload to LOTW manually.

Using the Capture window, I logged a QSO with MI0HOZ in the new Test database.  It automatically filled in "GI" in the DXCC field, which is the correct value for Northern Ireland. 

Note that when I logged the QSO that prompted my original posting on 10/23/2021, I had used the main Log QSOs tab instead of the Capture window.  So I created a second test database called Test2 and repeated the experiment, this time logging the QSO from the main Log QSOs tab.  The result was the same:  "GI" was automatically filled in the DXCC field.

Steve, N5EP


Dave AA6YQ
 

+ AA6YQ comments below

I did not need to disable automatic uploading, as I don't use it. I always upload to LOTW manually.

Using the Capture window, I logged a QSO with MI0HOZ in the new Test database. It automatically filled in "GI" in the DXCC field, which is the correct value for Northern Ireland.

Note that when I logged the QSO that prompted my original posting on 10/23/2021, I had used the main Log QSOs tab instead of the Capture window. So I created a second test database called Test2 and repeated the experiment, this time logging the QSO from the main Log QSOs tab. The result was the same: "GI" was automatically filled in the DXCC field.

+ Thanks, Steve. If you find a way to replicate the earlier behavior or if it recurs, please let me know.

73,

Dave, AA6YQ


Steve, N5EP
 

Will do, Dave.  And thanks for your help.

73, 

Steve, N5EP