Topics

DXLabs, WSJT-X (ft8) and Yaesu FT-950


Jerome Sodus
 

Hello,
Using DXLabs to set-up a Yaesu FT-950 for WSJT-X (ft8).
WSJT-X gives me for "split operation" three choices, which are "None", "Rig", "Fake It".
I've read Hinson's page 18 and still don't understand which choice I should click.
For completeness sake, the Mode is set for "Data/Pkt" and I see that on the FT-950 display.
TIA for any help.
73 jerry km3k 


Jerome Sodus
 

Passing along the answer (to my problem) from another site; the definitive reply came from Bill G4WJS.
"Hi Jerry,
"Settings->Radio->Split Operating->Rig" is preferred, if you have problems with it then try "Fake It".
One or the other should work.
They essentially do the same thing but "Rig" uses two VFOs on your rig for a smoother transition between Rx, Tx, and back.
For example some Yaesu rigs have limited Rx bandwidth in USB-DATA mode,
but you should not give up the Tx benefits of USB-DATA mode if you rig is like that,
instead use "Rig" split mode, set "Mode" to "None",
then you can set USB on the Rx VFO and USB-DATA on the Tx VFO.
You will need to set the rig modes manually.
73 Bill G4WJS."

73 jerry km3k


Jerome Sodus
 

Hello Dave,
Relative to Bill G4WJS's reply, I'm making a command sequence to put VFO-A in USB and VFO-B at USB-PKT; both set at 7074000 Hz.
It is not working; perhaps you can spot my error(s) or omission(s).

Here is my code per Yaesu's CAT-manual and your email about 'split':
FA7074000;
MD02;
FB7074000;
MD0C;
FT3;

TIA for any help.
73 jerry km3k
PS..it is a great feeling to be 'coding' again.


Dave AA6YQ
 

+ AA6YQ comments below

Here is my code per Yaesu's CAT-manual and your email about 'split':
FA7074000;
MD02;
FB7074000;
MD0C;
FT3;

+ When specifying CAT instructions in a Command Sequence, instructions specified in ASCII (as opposed to hexadecimal) must be preceded by a single apostrophe:

' FA7074000;
'MD02;
'FB7074000;
'MD0C;
'FT3;
<END>

+ Some advice: proceed one instruction at a time. In this case, start with a sequence that just issues

' FA7074000;

+ Then add the

'MD02;

+ This quickly exposes cases where adding the second command causes the first command to malfunction. For example, some radios require that the mode be changed before changing the frequency, and some vice versa. And in some cases (cough Elecraft cough), it may be necessary to insert <WAIT> instructions between commands.

73,

Dave, AA6YQ


g4wjs
 

On 14/06/2020 01:39, Jerome Sodus wrote:
Hello Dave,
Relative to Bill G4WJS's reply, I'm making a command sequence to put VFO-A in USB and VFO-B at USB-PKT; both set at 7074000 Hz.
It is not working; perhaps you can spot my error(s) or omission(s).

Here is my code per Yaesu's CAT-manual and your email about 'split':
FA7074000;
MD02;
FB7074000;
MD0C;
FT3;

TIA for any help.
73 jerry km3k
PS..it is a great feeling to be 'coding' again.

Jerome,

you don't need to set any frequencies or SPLIT. Try this:

'VS1;
'MD0C;
'VS0;
'MD02
<END>

This is assuming that the FT-950 does limit the Rx passband in USB-DATA mode, the user manual doesn't make it clear. If it doesn't then just check the WSJT-X option "Settings->Radio->Mode->Data/Pkt" and let WSJT-X sort it out for you.


--
73

Bill

G4WJS.


Jackson McNees
 

Very pleased to see this discussion.  Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine.  Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite.  Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.  Looked high and low through Commander docs to see if something there but found nothing.  Based on this discussion, will have to see if I have to set up a command sequence to change mode after transmitting.  Hopefully this will give the fix I need!

 

Jack, K4IJQ

 

From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of g4wjs
Sent: Saturday, June 13, 2020 9:07 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

 

On 14/06/2020 01:39, Jerome Sodus wrote:

Hello Dave,
Relative to Bill G4WJS's reply, I'm making a command sequence to put VFO-A in USB and VFO-B at USB-PKT; both set at 7074000 Hz.
It is not working; perhaps you can spot my error(s) or omission(s).

Here is my code per Yaesu's CAT-manual and your email about 'split':
FA7074000;
MD02;
FB7074000;
MD0C;
FT3;

TIA for any help.
73 jerry km3k
PS..it is a great feeling to be 'coding' again.

Jerome,

you don't need to set any frequencies or SPLIT. Try this:

'VS1;
'MD0C;
'VS0;
'MD02
<END>

This is assuming that the FT-950 does limit the Rx passband in USB-DATA mode, the user manual doesn't make it clear. If it doesn't then just check the WSJT-X option "Settings->Radio->Mode->Data/Pkt" and let WSJT-X sort it out for you.


--
73

Bill

G4WJS.


Dave AA6YQ
 

+ AA6YQ comments below

Very pleased to see this discussion. Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine. Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite. Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.

+ Does the post-TX switch from DATA to USB happen if Commander is not running?

73,

Dave, AA6YQ


g4wjs
 

On 15/06/2020 22:29, Jackson McNees wrote:

Very pleased to see this discussion.  Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine.  Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite.  Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.  Looked high and low through Commander docs to see if something there but found nothing.  Based on this discussion, will have to see if I have to set up a command sequence to change mode after transmitting.  Hopefully this will give the fix I need!

 

Jack, K4IJQ

Jack,

is this with WinWarbler, WSJT-X, or some other data comms application?


--
73

Bill

G4WJS.


Jackson McNees
 

Bill,

 

This is with WinWarbler and WSJT-X connected through Commander.

 

Jack

 

From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of g4wjs
Sent: Monday, June 15, 2020 7:36 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

 

On 15/06/2020 22:29, Jackson McNees wrote:

Very pleased to see this discussion.  Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine.  Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite.  Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.  Looked high and low through Commander docs to see if something there but found nothing.  Based on this discussion, will have to see if I have to set up a command sequence to change mode after transmitting.  Hopefully this will give the fix I need!

 

Jack, K4IJQ

Jack,

is this with WinWarbler, WSJT-X, or some other data comms application?


--
73

Bill

G4WJS.


g4wjs
 

Hi Jack,

with respect to WSJT-X, ensure that you have the option "Settings->Radio->Mode->Data/Pkt" checked.

73
Bill
G4WJS.

On 16/06/2020 01:44, Jackson McNees wrote:

Bill,

 

This is with WinWarbler and WSJT-X connected through Commander.

 

Jack

 

From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of g4wjs
Sent: Monday, June 15, 2020 7:36 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

 

On 15/06/2020 22:29, Jackson McNees wrote:

Very pleased to see this discussion.  Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine.  Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite.  Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.  Looked high and low through Commander docs to see if something there but found nothing.  Based on this discussion, will have to see if I have to set up a command sequence to change mode after transmitting.  Hopefully this will give the fix I need!

 

Jack, K4IJQ

Jack,

is this with WinWarbler, WSJT-X, or some other data comms application?


--
73

Bill

G4WJS.



--
73

Bill

G4WJS.


Jackson McNees
 

Dave,

Got frustrated with this and other problems so in midst of changing some things around when this discussion started. I will check this out when I get things back together. Thanks!

Jack

-----Original Message-----
From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Dave AA6YQ
Sent: Monday, June 15, 2020 5:38 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

+ AA6YQ comments below

Very pleased to see this discussion. Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine. Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite. Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.

+ Does the post-TX switch from DATA to USB happen if Commander is not running?

73,

Dave, AA6YQ


Dave AA6YQ
 

* more AA6YQ comments below

Got frustrated with this and other problems so in midst of changing some things around when this discussion started. I will check this out when I get things back together. Thanks!

* Frustration is the enemy of methodical debugging. Start with a simple configuration. If that works, make one change and test again. If at any point your encounter a repeatable failure, let me know and I'll suggest the appropriate diagnostic step. Every DXLab application includes the ability to create a log of its actions; typically, this quickly exposes the root cause of adverse behavior.

73,

Dave, AA6YQ


Jackson McNees
 

Dave,

Finally got the testing done.

Rig by itself does not switch modes after going to transmit.

Same for when only Commander is running.

However, started Commander and then WSJT-X.

Rig in DATA/USB mode
Click Test CAT button and all OK
Click Test PTT and get pop-up error window with message:
Rig failure. DXLab Suite Commander sent an unrecognized mode: **
Rig now switched to USB mode

Saved log file in case you want it.

Jack

-----Original Message-----
From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Dave AA6YQ
Sent: Monday, June 15, 2020 5:38 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

+ AA6YQ comments below

Very pleased to see this discussion. Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine. Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite. Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.

+ Does the post-TX switch from DATA to USB happen if Commander is not running?

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below

 

However, started Commander and then WSJT-X.

Rig in DATA/USB mode
Click Test CAT button and all OK
Click Test PTT and get pop-up error window with message:
Rig failure. DXLab Suite Commander sent an unrecognized mode: **
Rig now switched to USB mode

Saved log file in case you want it.

+ Please do the following:

1. On the General tab of Commander's Configuration window, check the "Log debugging info" box

2. Terminate Commander

3. Place Rig in DATA/USB mode

4. Start WSJT-X if it's not already running

5. Start Commander

6. Wait 30 seconds

7. Click the WSJT-X Test PTT button

8. Wait 30 seconds

9. On the General tab of Commander's Configuration window, uncheck the "Log debugging info" box

10. Attach the errorlog.txt file from your Commander folder to an email message, and send the message to me via

aa6yq (at) ambersoft.com

     73,

           Dave, AA6YQ


g4wjs
 

Hi Jack,

which WSJT-X option do you have set for the group "Settings->Radio->Mode"?

73
Bill
G4WJS.

On 22/06/2020 16:49, Jackson McNees wrote:
Dave,

Finally got the testing done.

Rig by itself does not switch modes after going to transmit.

Same for when only Commander is running.

However, started Commander and then WSJT-X.

Rig in DATA/USB mode
Click Test CAT button and all OK
Click Test PTT and get pop-up error window with message:
Rig failure. DXLab Suite Commander sent an unrecognized mode: **
Rig now switched to USB mode

Saved log file in case you want it.

Jack

-----Original Message-----
From:DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Dave AA6YQ
Sent: Monday, June 15, 2020 5:38 PM
To:DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

+ AA6YQ comments below

Very pleased to see this discussion. Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine. Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite. Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.

+ Does the post-TX switch from DATA to USB happen if Commander is not running?

73,

Dave, AA6YQ
--
73

Bill

G4WJS.


Jackson McNees
 

Bill,

All set like WIKI instructs:
Rig: DxLab Suite Commander
Poll: 1 sec
PTT Method: CAT
Mode: DATA/PKT
Split: Rig

Jack

-----Original Message-----
From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of g4wjs
Sent: Monday, June 22, 2020 1:32 PM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

Hi Jack,

which WSJT-X option do you have set for the group "Settings->Radio->Mode"?

73
Bill
G4WJS.

On 22/06/2020 16:49, Jackson McNees wrote:
Dave,

Finally got the testing done.

Rig by itself does not switch modes after going to transmit.

Same for when only Commander is running.

However, started Commander and then WSJT-X.

Rig in DATA/USB mode
Click Test CAT button and all OK
Click Test PTT and get pop-up error window with message:
Rig failure. DXLab Suite Commander sent an unrecognized mode: **
Rig now switched to USB mode

Saved log file in case you want it.

Jack

-----Original Message-----
From:DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Dave AA6YQ
Sent: Monday, June 15, 2020 5:38 PM
To:DXLab@groups.io
Subject: Re: [DXLab] DXLabs, WSJT-X (ft8) and Yaesu FT-950

+ AA6YQ comments below

Very pleased to see this discussion. Sometime back I used a Yeasu FT-920 with SignalLinkUSB to the mike port and worked fine. Recently decided to get back active again but decided to switch to the data port to free up mike and to start using DxLab Suite. Although the FT-920 is in DATA mode, after transmitting, the 920 changes to USB.

+ Does the post-TX switch from DATA to USB happen if Commander is not running?

73,

Dave, AA6YQ



--
73

Bill

G4WJS.