DXLabs won't start after computer shut down


Larry Bryan
 

Dave,

I was installing an update for WinZip today. Not sure if that was the culprit or not, but nothing will launch after I shut down the computer a while ago and then powered it up again.

Applications started with launcher just say they don't exist. If I try to start applications from their individual folders, It says TABCTL32.OCX or one of its dependencies is missing or not registered properly.

I tried to see if security had quarantined it for some reason, but I don't see it in the list. So before I mess around and screw something else up I wanted to get your feedback. It's been running just fine, so this is frustrating.

Larry
W8LIG


Dave AA6YQ
 

+ AA6YQ comments below
I was installing an update for WinZip today. Not sure if that was the culprit or not, but nothing will launch after I shut down the computer a while ago and then powered it up again.
 
Applications started with launcher just say they don't exist.

+ Are the "Program Paths" correctly specified on the "DXLab Apps" tab of the Launcher's Configuration window?

If I try to start applications from their individual folders, It says TABCTL32.OCX or one of its dependencies is missing or not registered properly.

+ That implies that there's been damage to your Window Registry. Whether that damaged was caused by installing another application, or is the result of a Windows defect, or is the result of a hardware failure -- I can't say.

 
I tried to see if security had quarantined it for some reason, but I don't see it in the list. So before I mess around and screw something else up I wanted to get your feedback. It's been running just fine, so this is frustrating.
+ I suggest that you not change anything until you determine what actually happened. Check the Windows Event Logs to see if any hardware or software errors have been recorded since things were last working correctly.

         73,

              Dave, AA6YQ


Larry Bryan
 


+ Are the "Program Paths" correctly specified on the "DXLab Apps" tab of the Launcher's Configuration window?


I can't confirm this as trying to launch the Config also generates the error. I"m working on the other comments.

Larry
W8LIG


Larry Bryan
 

Fixed by removing DXLabs suite, restarting and reinstalling. Program picked up my workspace and I'm up and running again.

Larry
W8LIG


Dave AA6YQ
 

+ AA6YQ comments below
Fixed by removing DXLabs suite, restarting and reinstalling. Program picked up my workspace and I'm up and running again.

+ I'm glad that your recovery was smooth, Larry. Did you find the root cause?

     73,

          Dave, AA6YQ


Larry Bryan
 

+ I'm glad that your recovery was smooth, Larry. Did you find the root cause?

Not really, I looked at the error log and it was still pointing to the Tabctl32.ocx file. I explored that error message on the net and followed MS instructions on how to fix it, but that did not work. So I made a copy of the DXLab directory on my backup drive in case I needed something, and then uninstalled each program. I was hoping that a fresh install would re-register that OCX file since it is shared by several programs and it did.

I'm still leaning toward the Winzip install/upgrade as the time in the error log is about the time I was working on that issue.

Larry
W8LIG