dxlab commander to rf2k interface


Pat
 

I am looking to config my rf2k amp to commander.
I have been in network service in commander.  i have ip address of 127.0.0.1 and port 52002.
in rf2k udp port window I have  52002 and listening to active radio.

if someone is using this amp to commander  or from a Kenwood ts-590sg can you email me.

amp works great with universal setting.. or rf sensing.. 
tnx
Murf
n7uvh


Dave AA6YQ
 

+ AA6YQ comments below
I am looking to config my rf2k amp to commander.
I have been in network service in commander.  i have ip address of 127.0.0.1 and port 52002.
in rf2k udp port window I have  52002 and listening to active radio.

+ I went looking for documentation that would explain how the RF2K implements "CAT data through IP (UDP)" - but found none.

+ Port 52002 is what Commander utilizes to interoperate with other DXLab applications, and thus will not be used to communicate with your RF2K.. To convey frequency reports to your RF2K, you will likely configure Commander's "UDP Network Service" to send N1MM-style frequency update packets to an appropriate port:

https://www.dxlabsuite.com/commander/Help/NetworkService.htm#UDP_Network_Service

     73,

           Dave, AA6YQ


Wolf, DK1FW
 

Although I do not own an RF2K I have checked the available information some time ago.

An english manual is available at https://rf-kit.de/files/User_Manual_RF2K-S_ENG_V14.pdf
Section 5.2.6  provides information on CAT- and UDP-Interface
According to that the default UDP port of the RF2K is 12060
So configuring Commanders "UDP Network Service" to send frequency information to port 12060 should get things going

Hope that helps
73 de Wolf, Dk1FW

Am 08.08.2022 um 08:27 schrieb Dave AA6YQ:

+ AA6YQ comments below
I am looking to config my rf2k amp to commander.
I have been in network service in commander.  i have ip address of 127.0.0.1 and port 52002.
in rf2k udp port window I have  52002 and listening to active radio.

+ I went looking for documentation that would explain how the RF2K implements "CAT data through IP (UDP)" - but found none.

+ Port 52002 is what Commander utilizes to interoperate with other DXLab applications, and thus will not be used to communicate with your RF2K.. To convey frequency reports to your RF2K, you will likely configure Commander's "UDP Network Service" to send N1MM-style frequency update packets to an appropriate port:

https://www.dxlabsuite.com/commander/Help/NetworkService.htm#UDP_Network_Service

     73,

           Dave, AA6YQ



Joe Subich, W4TV
 

So configuring Commanders "UDP Network Service" to send frequency
information to port 12060 should get things going
You will also need to provide the IP address of the RF2K,
127.0.0.1 is the "loopback" address on the PC running Commander
and will not reach an external device.

73,

... Joe, W4TV

On 2022-08-08 7:31 AM, Wolf, DK1FW wrote:
Although I do not own an RF2K I have checked the available information some time ago.
An english manual is available at https://rf-kit.de/files/User_Manual_RF2K-S_ENG_V14.pdf
Section 5.2.6  provides information on CAT- and UDP-Interface
According to that the default UDP port of the RF2K is 12060
So configuring Commanders "UDP Network Service" to send frequency information to port 12060 should get things going
Hope that helps
73 de Wolf, Dk1FW
Am 08.08.2022 um 08:27 schrieb Dave AA6YQ:
+ AA6YQ comments below

I am looking to config my rf2k amp to commander.
I have been in network service in commander.  i have ip address of
127.0.0.1 and port 52002.
in rf2k udp port window I have  52002 and listening to active radio.

+ I went looking for documentation that would explain how the RF2K implements "CAT data through IP (UDP)" - but found none.

+ Port 52002 is what Commander utilizes to interoperate with other DXLab applications, and thus will not be used to communicate with your RF2K.. To convey frequency reports to your RF2K, you will likely configure Commander's "UDP Network Service" to send N1MM-style frequency update packets to an appropriate port:

https://www.dxlabsuite.com/commander/Help/NetworkService.htm#UDP_Network_Service

     73,

           Dave, AA6YQ


bill steffey NY9H
 

I have a question ...

RFKIT & Commander work fine .

However this thread has me checking my settings...   commander indeed is set to 12060  for  127.0.0.1 AND rfkit also 12060 to xxx.183

Also sending 127.0.0.1 port # 2237.     However my amp shows port 5900 ???

why would it be talking to itself 0.0.1   on two different ports..???

and I have no clue what is going on with  2237.


(And for Joe 'TV'... next I'll be adding today an ARCO ... another network funtime ...

bill

On 8/8/2022 8:51 AM, Joe Subich, W4TV wrote:

So configuring Commanders "UDP Network Service" to send frequency
information to port 12060 should get things going
You will also need to provide the IP address of the RF2K,
127.0.0.1 is the "loopback" address on the PC running Commander
and will not reach an external device.

73,

   ... Joe, W4TV

On 2022-08-08 7:31 AM, Wolf, DK1FW wrote:
Although I do not own an RF2K I have checked the available information some time ago.

An english manual is available at https://rf-kit.de/files/User_Manual_RF2K-S_ENG_V14.pdf
Section 5.2.6  provides information on CAT- and UDP-Interface
According to that the default UDP port of the RF2K is 12060
So configuring Commanders "UDP Network Service" to send frequency information to port 12060 should get things going

Hope that helps
73 de Wolf, Dk1FW

Am 08.08.2022 um 08:27 schrieb Dave AA6YQ:
+ AA6YQ comments below

    I am looking to config my rf2k amp to commander.
    I have been in network service in commander.  i have ip address of
    127.0.0.1 and port 52002.
    in rf2k udp port window I have  52002 and listening to active radio.

+ I went looking for documentation that would explain how the RF2K implements "CAT data through IP (UDP)" - but found none.

+ Port 52002 is what Commander utilizes to interoperate with other DXLab applications, and thus will not be used to communicate with your RF2K.. To convey frequency reports to your RF2K, you will likely configure Commander's "UDP Network Service" to send N1MM-style frequency update packets to an appropriate port:

https://www.dxlabsuite.com/commander/Help/NetworkService.htm#UDP_Network_Service

     73,

           Dave, AA6YQ





Dave AA6YQ
 

+ AA6YQ comments below

Although I do not own an RF2K I have checked the available information some time ago.

An english manual is available at https://rf-kit.de/files/User_Manual_RF2K-S_ENG_V14.pdf
Section 5.2.6 provides information on CAT- and UDP-Interface According to that the default UDP port of the RF2K is 12060 So configuring Commanders "UDP Network Service" to send frequency information to port 12060 should get things going

+ Thanks, Wolf! Page 25 of that manual provides the necessary information.

73,

Dave,. AA6YQ


Pat
 

Thanks guys for all the help and tip
 My first time using UDP.
 I was able to find what the PI address was in the RF2K-S. I think that was the hardest part learning how to do that.

 Once I found my IP address.. entered it in the Network Services in Command, and matched up the port address, Boob! There it is.  I am hard wired to my router by the way.. So amp to router with an ethernet cable.  I dont know how Commander finds my router.. over my pay scale... 
Tnx Dave for the best software in ham radio!
Murf
n7uvh


Dave AA6YQ
 

+ AA6YQ comments below
Thanks guys for all the help and tip
 My first time using UDP.
 I was able to find what the PI address was in the RF2K-S. I think that was the hardest part learning how to do that.

 Once I found my IP address.. entered it in the Network Services in Command, and matched up the port address, Boob! There it is. 

+ I'm glad to hear that it worked, Murf. Kudos to the N1MM developers for establishing a standard UDP format for realtime radio updates. Enjoy!

      73,

             Dave, AA6YQ