Topics

dxkeeper and wsjtx and gridtracker (on another hosts) scenario.


The Romagni's
 

Hi Guys,

I am going in circles here, here is what I am trying to do, I am trying to integrate WSJT so the log info goes to Gridtracker and DXKeeper - Here is what I got so far, and where I am having issues:

1- WSJTX sending data to Gridtracker in another hosts (LINUX Raspbian) - using IP 224.0.0.251 (multicast) and port 2239. This works perfectly.
2- My issues is getting now that data into dxkeeper, I played with GridTracker Logging section, enabled DXKeeper, and I tried using port 52001 both as localhost or setting back to a multicast address (Not working).

I am going in circles with part 2, maybe I am overcomplicating things... any suggestions?

Thanks

Steve
W4DTA


Dave AA6YQ
 

+ AA6YQ comments below

I am going in circles here, here is what I am trying to do, I am trying to integrate WSJT so the log info goes to Gridtracker and DXKeeper - Here is what I got so far, and where I am having issues:

1- WSJTX sending data to Gridtracker in another hosts (LINUX Raspbian) - using IP 224.0.0.251 (multicast) and port 2239. This works perfectly.
2- My issues is getting now that data into dxkeeper, I played with GridTracker Logging section, enabled DXKeeper, and I tried using port 52001 both as localhost or setting back to a multicast address (Not working).

I am going in circles with part 2, maybe I am overcomplicating things... any suggestions?

+ Step-by-step instructions for configuring interoperation between DXLab and WSJT-X are here:

https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModesDirect

+ I have not investigated interoperation between GridTracker and DXLab because DXView provides all functionality provided by GridTracker. For example, see "Plotting Worked and Confirmed Grid Squares on the DX Atlas World Map" in

https://www.dxlabsuite.com/dxlabwiki/GridPlottingDXAtlas

73,

Dave, AA6YQ


Carl - WC4H
 

Steve,
 
I do exactly what you want to do when I use my Raspberry Pi 4B.  You do not need the multicast feature.
Two scenarios:
1. With GridTracker running on the PC but not not on Linux
   -  Setup wsjtx checking the 3 boxes in the UDP sections under the Reporting tab.
   -  Change the IP address to that of the Windows PC with DXKeeper
   -  Leave the port as 2237
   -  On the Windows PC,  Launch GridTracker
   -  In the General tab set the Receive UDP port to 2237 (uncheck multicast box if checked).
   -  In the Logging Tab go down to DXKeeper and use 127.0.0.1 for the IP and leave the port as 52000 
      and make sure to click on the checkbox to log to DXKeeper.
   -  You can also add the QSO to the wsjtx_log.adi if you make a symboilic link to from it to 
      GridTracker_QSO.adif and check the Log box in the Logging tab of GridTracker for the first line (GirdTracker line).
 
2. With GridTracker running on Linux
  - In wsjtx use ip 127.0.0.1 and port 2237 for the UDP port
  - On GridTracker general tab use port 2237 for the Receive UDP port.
  - On the Logging tab use the IP of the PC with DXKeeper in the IP field of the DXKeeper line. Leave
    he port as 520000.
 
With Raspberry Pi 4B & 64bit OS (arm64), you would use option 1 since GridTracker doesn't run on arm64.
With a 32bit RPi OS (armhd) you can use either option.
 
In either case, you can still upload to LoTW, eQSL. Clublog, etc.
 
Actually, I foward the UDP data back to Linux from the PC so that CQRLOG can also log it with the
link it has to wsjtx.  I just use GridTracker to forward to the RPi IP on port 2238 and use port 2238 as the
wsjtx port in CQRLOG.
 
NOTE:  This is only good for wsjt modes.  If you are doing CW, SSB, etc. it would be a more manual
sollution.

73.
Carl - WC4H
 
 
 


Dave AA6YQ
 

+ AA6YQ comments below

I do exactly what you want to do when I use my Raspberry Pi 4B. You do not need the multicast feature.
Two scenarios:
1. With GridTracker running on the PC but not not on Linux
- Setup wsjtx checking the 3 boxes in the UDP sections under the Reporting tab.
- Change the IP address to that of the Windows PC with DXKeeper
- Leave the port as 2237
- On the Windows PC, Launch GridTracker
- In the General tab set the Receive UDP port to 2237 (uncheck multicast box if checked).
- In the Logging Tab go down to DXKeeper and use 127.0.0.1 for the IP and leave the port as 52000
and make sure to click on the checkbox to log to DXKeeper.
- You can also add the QSO to the wsjtx_log.adi if you make a symboilic link to from it to
GridTracker_QSO.adif and check the Log box in the Logging tab of GridTracker for the first line (GirdTracker line).

2. With GridTracker running on Linux
- In wsjtx use ip 127.0.0.1 and port 2237 for the UDP port
- On GridTracker general tab use port 2237 for the Receive UDP port.
- On the Logging tab use the IP of the PC with DXKeeper in the IP field of the DXKeeper line. Leave
he port as 520000.

With Raspberry Pi 4B & 64bit OS (arm64), you would use option 1 since GridTracker doesn't run on arm64.
With a 32bit RPi OS (armhd) you can use either option.

In either case, you can still upload to LoTW, eQSL. Clublog, etc.

Actually, I foward the UDP data back to Linux from the PC so that CQRLOG can also log it with the link it has to wsjtx. I just use GridTracker to forward to the RPi IP on port 2238 and use port 2238 as the wsjtx port in CQRLOG.

NOTE: This is only good for wsjt modes. If you are doing CW, SSB, etc. it would be a more manual sollution.

+ What is it that GridTracker does that DXLab doesn't do that warrants the complex multiple computer, multiple operating system topology described above?

73,

Dave, AA6YQ


The Romagni's
 

On Sat, Feb 20, 2021 at 08:26 PM, Carl - WC4H wrote:
In wsjtx use ip 127.0.0.1 and port 2237 for the UDP port
Thanks Carl for your suggestion - so I got now wsjtx (main pc) sending the info to Gridtracker on the Raspberry, now I need to get GridTracker to send the info to dxlabs (DXKeeper) for logging. On the Gridtracker logging page setup I have:
DXKeeper Log enable, then a multicast address 224.0.0.251 and port 52000, but that is not working as far as getting the qso info over to DX Keeper.


Steve


The Romagni's
 

Nevermind!!! I had a senior IT moment for a minute... now all is working... here is my setup and solution if anyone is interested:

1- WSJTX runinning on my main Ham Radio PC a long with dxlabs (dx keeper)...
on wsjtx I set up muticasting at udp to 224.0.0.251 and port 237.

2- on Raspberry Pi running Gridtracker, I have enable the multicast address and port to match wsjtx. So maps in Gridtracker are now working.

3- Now lets get the qso's over to dxkeeper by going into the Logging setup secction of GridTracker, and enable dxKeeper, and add the IP address of my Ham PC and port 520000


All working now... Again Carl thanks for your post, that allowed to see beyond the issue... you know us IT Guys love to complicate things sometimes...

Steve
W4DTA


Carl - WC4H
 

Great Steve.  Enjoy.

73.
Carl - WC4H