DX Commander - buffer overflow - system restore


St. Cuda
 
Edited

2021 October 2 night, my system was working fine upon shutdown.  The next morning, WSJT would not transmit......again, DXCommander, and my rotor control quit.  
After working on WSJT for hours and checking different sources, one thing I was finding was that Windows update was/could be the cause. 
Now, looking back,this happens about monthly to me. The Error file for DXCommander said Buffer Overflow.  I did a full Defender virus check which
found exactly nothing.  I had reloaded each program without a working FT8 system and I had tried to redo the settings.  This time was the worst so far. 

I know enough about Windows 8.1 (my ham computer) to get me in trouble.  8.1 updates has been turned off a long time ago.  Radio:  Yaesu FTDX-10.

The short version, I was lucky and there was a System Restore point a day earlier.  Nothing to loose, I thought.  System restore it was.  On WSJT,
I had to redo the General Tab including my call and info and the Audio Tab settings.  Commander and HyGain DCU-3 had to redo their Com settings to match.  

As of now, all seems to be working.  What can be done to stop the monthly trouble with Windows?  What setting(s) am I missing?

TIA!

73, Steven KN0L

Dave, thanks for great software and support!!!


Dave AA6YQ
 

+ AA6YQ comments below
2021 October 2 night, my system was working fine upon shutdown.  The next morning, WSJT would not transmit......again, DXCommander, and my rotor control quit.  
After working on WSJT for hours and checking different sources, one thing I was finding was that Windows update was/could be the cause. 
Now, looking back,this happens about monthly to me. The Error file for DXCommander said Buffer Overflow.  I did a full Defender virus check which
found exactly nothing.  I had reloaded each program without a working FT8 system and I had tried to redo the settings.  This time was the worst so far. 

I know enough about Windows 8.1 (my ham computer) to get me in trouble.  8.1 updates has been turned off a long time ago.  Radio:  Yaesu FTDX-10.

The short version, I was lucky and there was a System Restore point a day earlier.  Nothing to loose, I thought.  System restore it was.  On WSJT,
I had to redo the General Tab including my call and info and the Audio Tab settings.  Commander and HyGain DCU-3 had to redo their Com settings to match.  

As of now, all seems to be working.  What can be done to stop the monthly trouble with Windows?  What setting(s) am I missing?

+ The behavior you report could be the result of a defect in Windows 8, or a hardware failure. Have you checked the Windows event logs?

      73,

             Dave AA6YQ


St. Cuda
 

Tnx Dave!  Looking at it now and will be looking at the help section to see what I am looking for.  The Event Log is new to me.  Tnx!

Maybe time for a new computer!!!!