Topics

Commander - ICOM 7300 - Waterfall problem

Joseph Willis
 

Hello Dave and others - I have successfully connected DXLAB Commander to my computer from my Icom 7300 for everything except the Waterfall screen.  The documentation explains that I need to set the baud rate at 115200 (Silicon Labs CP210X) port.  However, when I try to bump up the speed from 9600 on the Config tab in Commander, I lose the connection, even though I previously set the port to 115200 on my computer !  Googling, I found this on the Silicon Labs web site:

"Icom radios use the version 6.xxx drivers.  Windows update has installed the Universal Windows Driver.  This drivers reports a maximum baud rate of 23800 when used with Microsoft .NET", but there is no fix. 

Have others been able to overcome this limitation with their 7300's ?

Thank you, 
VE2CY

Rick Ellison
 

You need to change the baud rate on the radio and then open Commander and change it there..

 

73 Rick n2AMG

 

From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Joseph Willis via Groups.Io
Sent: Saturday, September 14, 2019 7:15 PM
To: DXLab@groups.io
Subject: [DXLab] Commander - ICOM 7300 - Waterfall problem

 

Hello Dave and others - I have successfully connected DXLAB Commander to my computer from my Icom 7300 for everything except the Waterfall screen.  The documentation explains that I need to set the baud rate at 115200 (Silicon Labs CP210X) port.  However, when I try to bump up the speed from 9600 on the Config tab in Commander, I lose the connection, even though I previously set the port to 115200 on my computer !  Googling, I found this on the Silicon Labs web site:

"Icom radios use the version 6.xxx drivers.  Windows update has installed the Universal Windows Driver.  This drivers reports a maximum baud rate of 23800 when used with Microsoft .NET", but there is no fix. 

Have others been able to overcome this limitation with their 7300's ?

Thank you, 
VE2CY


Virus-free. www.avast.com

Dave AA6YQ
 

+ AA6YQ comments below

Hello Dave and others - I have successfully connected DXLAB Commander to my computer from my Icom 7300 for everything except the Waterfall screen. The documentation explains that I need to set the baud rate at 115200 (Silicon Labs CP210X) port. However, when I try to bump up the speed from 9600 on the Config tab in Commander, I lose the connection, even though I previously set the port to 115200 on my computer ! Googling, I found this on the Silicon Labs web site:

"Icom radios use the version 6.xxx drivers. Windows update has installed the Universal Windows Driver. This drivers reports a maximum baud rate of 23800 when used with Microsoft .NET", but there is no fix.

Have others been able to overcome this limitation with their 7300's ?

Rick N2AMG wrote:
You need to change the baud rate on the radio and then open Commander and change it there..

+ And for the record, DXLab does not use .NET

73,

Dave, AA6YQ

Carl - WC4H
 

Hi Joseph.

Make sure it's the "CI-V USB Baud Rate"  not the normal one (there are 2 on the IC-7300).
Also, just above that setting, CI-V USB Port -- Unlink from [REMOTE].

73.
Carl - WC4H

g4wjs
 

On 15/09/2019 00:14, Joseph Willis via Groups.Io wrote:
Hello Dave and others - I have successfully connected DXLAB Commander to my computer from my Icom 7300 for everything except the Waterfall screen.  The documentation explains that I need to set the baud rate at 115200 (Silicon Labs CP210X) port.  However, when I try to bump up the speed from 9600 on the Config tab in Commander, I lose the connection, even though I previously set the port to 115200 on my computer !  Googling, I found this on the Silicon Labs web site:

"Icom radios use the version 6.xxx drivers.  Windows update has installed the Universal Windows Driver.  This drivers reports a maximum baud rate of 23800 when used with Microsoft .NET", but there is no fix. 

Have others been able to overcome this limitation with their 7300's ?

Thank you, 
VE2CY

OM,

have you taken note of this rig MENU setting described in the manual like this:

CI-V USB Baud Rate (Default: Auto)
Selects the CI-V data transfer rate when remotely
controlling the IC-7300 through the [USB] CI-V port.
L When “Auto” is selected, the baud rate is
automatically set according to the data rate of
external controller.
L This setting is valid only when the “CI-V USB Port”
item is set to “Unlink from [REMOTE].”

Note that the higher baud rates for CI-V over the USB virtual serial port are only available when the "Unlink from [REMOTE]" option is used. I am assuming you are actually using the USB virtual serial port and not the REMOTE jack on the rig (the REMOTE jack is limited to 19200 baud, I believe, and doesn't support the waterfall data stream).



--
73

Bill

G4WJS.

Joseph Willis
 

Top Drawer ! - this reflector is one of the best in ham radio ! - Thanks for setting the tone Dave !!!!! (all working).

WF3W@...
 

Hi Joe & the group,
 
For what it mite b worth: I have had a merry time with COM Ports in Ham apps.
 
With Silicon Labs CP210X, make sure u have STANDARD & ENHANCED drivers/ports [usually Ports 5 & 6].
 
There was a time - and still is a time - when opening a Ham program [whose name I will not divulge, initials HRD] I needed to alter/update/change port assignments daily.
 
Take it easy,
 
73
 
Phil, WF3W