Default QSL Message not being retained


Dave AA6YQ
 

+ AA6YQ comments below

Thanks for the response, Dave. I followed your instructions as outlined below. I am noticing that the Default QSL message is not retained even if I just simply close DXKeeper, and don't change Workspaces. In other words, after I have selected the Default QSL message I want in the Config, and confirmed it is working, I close DXKeeper. Then I re-open DXKeeper, without changing Workspaces, and the Default QSL message does not re-appear in either the Config -> Defaults tab, or in a newly logged QSO.

+ So that I can see what's going on, Ken, please do the following:

1. On the Configuration window's General tab, check the "Log debugging info" box

2. On the Configuration window's Defaults tab, select a "Default QSL Message"

3. Terminate DXKeeper

4. Start DXKeeper

5. After DXKeeper displays its Main window, on the Configuration window's General tab, uncheck the "Log debugging info" box

6. Attach the errorlog.txt file from your DXKeeper folder to an email message, and send the message to me via

aa6yq (at) ambersoft.com

73,

Dave, AA6YQ


Ken Bandy, KJ9B
 

Thanks for the response, Dave. I followed your instructions as outlined below. I am noticing that the Default QSL message is not retained even if I just simply close DXKeeper, and don't change Workspaces. In other words, after I have selected the Default QSL message I want in the Config, and confirmed it is working, I close DXKeeper. Then I re-open DXKeeper, without changing Workspaces, and the Default QSL message does not re-appear in either the Config -> Defaults tab, or in a newly logged QSO.

73,
Ken, KJ9B

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Dave AA6YQ
Sent: Wednesday, August 10, 2022 2:42 PM
To: DXLab@groups.io
Subject: Re: [DXLab] Default QSL Message not being retained

+ AA6YQ comments below

I am using a workspace, and that thought crossed my mind as well. I have updated the W9ISF workspace a couple of times after setting the default message. Doing so had no change in the behavior I'm seeing. Thanks for the thought, though.

+ Note: to update a Workspace with a modified setting,

1. modify the setting in the application (DXKeeper)

2. terminate the application (DXKeeper)

3. direct the Launcher to update the Workspace with the application's (DXKeeper's) settings

4. start the application (DXKeeper)

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below

I am using a workspace, and that thought crossed my mind as well. I have updated the W9ISF workspace a couple of times after setting the default message. Doing so had no change in the behavior I'm seeing. Thanks for the thought, though.

+ Note: to update a Workspace with a modified setting,

1. modify the setting in the application (DXKeeper)

2. terminate the application (DXKeeper)

3. direct the Launcher to update the Workspace with the application's (DXKeeper's) settings

4. start the application (DXKeeper)

73,

Dave, AA6YQ


Ken Bandy, KJ9B
 

Hi Joe. I am using a workspace, and that thought crossed my mind as well. I have updated the W9ISF workspace a couple of times after setting the default message. Doing so had no change in the behavior I'm seeing. Thanks for the thought, though.

73,
Ken, KJ9B

-----Original Message-----
From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Joe Subich, W4TV
Sent: Wednesday, August 10, 2022 10:11 AM
To: DXLab@groups.io
Subject: Re: [DXLab] Default QSL Message not being retained


Ken,

Are you loading a workspace at startup? If so, is the default QSL message stored in that workspace (did you update the workspace after setting the default QSL message)?

73,

... Joe, W4TV

On 2022-08-10 9:42 AM, Ken Bandy, KJ9B wrote:
Good morning, Dave. I have recently stumbled onto an issue that may
or may not be a problem. With the annual special event that I host, I
always have the default QSL Message set up in DXKeeper with "Thanks
from W9ISF!". I have noticed this year that when I start DXKeeper,
after logging a QSO, the QSL message is blank. I need to go to the
"Defaults" tab in "Config" and select my message in order for it to
show up once again. Once I do this, it will continue to automatically
fill until I terminate DXKeeper and re-start it. I don't recall
having to select this for every operating session in the past. If
this is normal behavior, then that's fine. I just wanted to point it out in case it's not.



Thanks as usual,

Ken, KJ9B


Joe Subich, W4TV
 

Ken,

Are you loading a workspace at startup? If so, is the default
QSL message stored in that workspace (did you update the workspace
after setting the default QSL message)?

73,

... Joe, W4TV

On 2022-08-10 9:42 AM, Ken Bandy, KJ9B wrote:
Good morning, Dave. I have recently stumbled onto an issue that may or may
not be a problem. With the annual special event that I host, I always have
the default QSL Message set up in DXKeeper with "Thanks from W9ISF!". I
have noticed this year that when I start DXKeeper, after logging a QSO, the
QSL message is blank. I need to go to the "Defaults" tab in "Config" and
select my message in order for it to show up once again. Once I do this, it
will continue to automatically fill until I terminate DXKeeper and re-start
it. I don't recall having to select this for every operating session in the
past. If this is normal behavior, then that's fine. I just wanted to point
it out in case it's not.
Thanks as usual,
Ken, KJ9B


Ken Bandy, KJ9B
 

Good morning, Dave.  I have recently stumbled onto an issue that may or may not be a problem.  With the annual special event that I host, I always have the default QSL Message set up in DXKeeper with “Thanks from W9ISF!”.  I have noticed this year that when I start DXKeeper, after logging a QSO, the QSL message is blank.  I need to go to the “Defaults” tab in “Config” and select my message in order for it to show up once again.  Once I do this, it will continue to automatically fill until I terminate DXKeeper and re-start it.  I don’t recall having to select this for every operating session in the past.  If this is normal behavior, then that’s fine.  I just wanted to point it out in case it’s not.

 

Thanks as usual,

Ken, KJ9B