Gemini DX 1200 Linear Remote Software Connection


Bernard Wehrli
 

I installed a Remote connection between my DX 1200 PA and my Win10 Computer
The Remote SW works in principal, but after a certain time following Error message appears and stops the communikcation: 
"Read Error, Error message 10054 Connection reset by peer."
My configuration is as follow:
I installed an additionale Ethernet connector on my Win10 PC via an 'Ethernet to USB3 Adapter'  ( Startech ASIX AX88179)
I used a crossover Ethernet cable to connect  PC and Gemini DX 1200 PA, and made a private network with an own IT Address Range.
(192.168.1.2 for the Ethernet Adapter, 192.168.1.10 for the the DX1200 PA, Submask 255-255.0.0)
I tried all kind of settings on th Adapter, the Network Menue on the PA and I also added the Remote SW on the Program list in the Firewall.
But this error message keeps coming after some some time ( can be 10 Seconds to several minutes)
Does somebody have an idea how to solve this problem?
73 de Bernard, HB9ALH


Steve Phillips - NS4P
 
Edited

My initial thought is you have made this too complicated.  Why not use an Ethernet switch and put everything on the same IP subnet?  It is possible to put two NICs in a PC and make it work but I don’t see the need for that in this application.


dxradio33
 

Bernard, good morning.  I do believe you have limited your connection by not defining the correct subnet range.  Your subnet mask should be 255.255.255.0.  This should match your configuration  of x.x.x.0-255.

 

Joe K8FC

 

From: DXLab@groups.io <DXLab@groups.io> On Behalf Of Bernard Wehrli
Sent: Thursday, June 10, 2021 05:34
To: DXLab@groups.io
Subject: [DXLab] Gemini DX 1200 Linear Remote Software Connection

 

I installed a Remote connection between my DX 1200 PA and my Win10 Computer
The Remote SW works in principal, but after a certain time following Error message appears and stops the communikcation: 
"Read Error, Error message 10054 Connection reset by peer."
My configuration is as follow:
I installed an additionale Ethernet connector on my Win10 PC via an 'Ethernet to USB3 Adapter'  ( Startech ASIX AX88179)
I used a crossover Ethernet cable to connect  PC and Gemini DX 1200 PA, and made a private network with an own IT Address Range.
(192.168.1.2 for the Ethernet Adapter, 192.168.1.10 for the the DX1200 PA, Submask 255-255.0.0)
I tried all kind of settings on th Adapter, the Network Menue on the PA and I also added the Remote SW on the Program list in the Firewall.
But this error message keeps coming after some some time ( can be 10 Seconds to several minutes)
Does somebody have an idea how to solve this problem?
73 de Bernard, HB9ALH