Weird radio behavior with WSJT-X


Rick
 

When using WSJT-X with my K3S I occasionally see very bizarre behaviors. Occasionally the radio remains in TX and can only be shut down by powering off the radio. Once in a while the radio goes into TX normally but there is no modulation. A "tune" produces no power -- occasionally.

What I've done to work with this:
1. Reviewed all available documentation. (There is a lot of very good documentation. I think all settings have been checked and are as recommended.)
2. Changed radios. (This exact problem also occurred with the Flex 6300 that was in use at this location before I changed back to Elecraft.)
3. Exited and re-entered WSJT-X. (This will solve the problem temporarily.)
4. Ensured the correct "sound cards" are elected. (They are -- even though Windoze occasionally tampers with them.)
5. Updated all software. (These events occurred with prior versions of Commander and WSJT-X and persist with the current versions.)
6. Checked other modes. (The lack of control occurred once while using RTTY, never with CW and never with phone.)
7. Checked all connections. (All OK. The K3S is connected to the computer via USB.)
8. Changed power. (Occurs at exciter power as well as when driving the KPA500 hard.)

Anyone have any suggestions as to where to go from here?


g4wjs
 

On 03/03/2021 12:30, Rick via groups.io wrote:
When using WSJT-X with my K3S I occasionally see very bizarre behaviors. Occasionally the radio remains in TX and can only be shut down by powering off the radio. Once in a while the radio goes into TX normally but there is no modulation. A "tune" produces no power -- occasionally.

What I've done to work with this:
1. Reviewed all available documentation. (There is a lot of very good documentation. I think all settings have been checked and are as recommended.)
2. Changed radios. (This exact problem also occurred with the Flex 6300 that was in use at this location before I changed back to Elecraft.)
3. Exited and re-entered WSJT-X. (This will solve the problem temporarily.)
4. Ensured the correct "sound cards" are elected. (They are -- even though Windoze occasionally tampers with them.)
5. Updated all software. (These events occurred with prior versions of Commander and WSJT-X and persist with the current versions.)
6. Checked other modes. (The lack of control occurred once while using RTTY, never with CW and never with phone.)
7. Checked all connections. (All OK. The K3S is connected to the computer via USB.)
8. Changed power. (Occurs at exciter power as well as when driving the KPA500 hard.)

Anyone have any suggestions as to where to go from here?
Rick,

you need to give us more information. Let;s start with just the K3. What do you have checked for "Settings->Radio->PTT Method" in WSJT-X? What PTT method are you using in Commander for your K3?



--
73

Bill

G4WJS.


Rick
 


Hi Bill. TU, PTT method in WSJT-X is "CAT" and using "DX Lab Suite Commander." In Commander DTR is "off;" RTS is "TX." On the "General" tab "PTT: Rcving" box is not checked.


>you need to give us more information. Let;s start with just the K3. What
>do you have checked for "Settings->Radio->PTT Method" in WSJT-X? What
>PTT method are you using in Commander for your K3?

--
73
Bill
G4WJS.


g4wjs
 

On 03/03/2021 12:56, Rick via groups.io wrote:

Hi Bill. TU, PTT method in WSJT-X is "CAT" and using "DX Lab Suite Commander." In Commander DTR is "off;" RTS is "TX." On the "General" tab "PTT: Rcving" box is not checked.


you need to give us more information. Let;s start with just the K3. What
do you have checked for "Settings->Radio->PTT Method" in WSJT-X? What
PTT method are you using in Commander for your K3?
--
73
Bill
G4WJS.
Hi Rick,

thanks for that. K3s are prone to locking up in SEND mode if multiple sources of PTT are enabled, AFAIK this issue is not resolved by firmware updates. Do you have any other sources of PTT other than the mic connected to your K3? For example do you have "Suppress CAT" unchecked in the Commander PTT panel?



--
73

Bill

G4WJS.


Rick
 

> For example do you have "Suppress CAT" unchecked
in the Commander PTT panel?

Bill, that box is not checked.
I feel fairly certain this is something *I* have screwed up -- I don't exactly hear a flood of folks with the same issue. And, there are a LOT of folks using this excellent software (DXLab and WSJT) with K3s.

Rick



g4wjs
 

On 03/03/2021 17:40, Rick via groups.io wrote:
For example do you have "Suppress CAT" unchecked
in the Commander PTT panel?

Bill, that box is not checked.
I feel fairly certain this is something *I* have screwed up -- I don't exactly hear a flood of folks with the same issue. And, there are a LOT of folks using this excellent software (DXLab and WSJT) with K3s.

Rick
Hi Rick,

that'll probably be the issue. Note item 4(d) here: http://www.dxlabsuite.com/dxlabwiki/TranceiverControlElecraft

I don't have any ideas on the similar issue with your Flex Radio 6300.



--
73

Bill

G4WJS.


Rick
 

Ahhh. OK, TU Bill. I'll give that a try. Very helpful.
Fortunately, the Flex is gone now so I won't have to concern myself with that. :<)

Rick


On Wednesday, March 3, 2021, 12:44:12 PM EST, g4wjs <bill.8@...> wrote:


On 03/03/2021 17:40, Rick via groups.io wrote:
> > For example do you have "Suppress CAT" unchecked
> in the Commander PTT panel?
>
> Bill, that box is not checked.
> I feel fairly certain this is something *I* have screwed up -- I don't
> exactly hear a flood of folks with the same issue. And, there are a
> LOT of folks using this excellent software (DXLab and WSJT) with K3s.
>
> Rick

Hi Rick,

that'll probably be the issue. Note item 4(d) here:
http://www.dxlabsuite.com/dxlabwiki/TranceiverControlElecraft

I don't have any ideas on the similar issue with your Flex Radio 6300.

--
73


Bill


G4WJS.


Rick
 

Bill: I unchecked the "suppress CAT" box, as per the instructions and found the radio no longer keys -- even when using the "TX" button on the main screen of Commander. Curious. I'm wondering it the issue lays elsewhere.


On Wednesday, March 3, 2021, 12:44:12 PM EST, g4wjs <bill.8@...> wrote:


On 03/03/2021 17:40, Rick via groups.io wrote:
> > For example do you have "Suppress CAT" unchecked
> in the Commander PTT panel?
>
> Bill, that box is not checked.
> I feel fairly certain this is something *I* have screwed up -- I don't
> exactly hear a flood of folks with the same issue. And, there are a
> LOT of folks using this excellent software (DXLab and WSJT) with K3s.
>
> Rick

Hi Rick,

that'll probably be the issue. Note item 4(d) here:
http://www.dxlabsuite.com/dxlabwiki/TranceiverControlElecraft

I don't have any ideas on the similar issue with your Flex Radio 6300.


g4wjs
 

Hi Rick,

sounds like you do not have the K3 menu option CONFIG:PTT-KEY set correctly for RTS keying via RS-232/USB. You said you have Commander set to key the rig using the CAT port RTS line. You probably need to select CONFIG:RTS-DTR to match your Commander configuration, or the default OFF-OFF and let Commander use CAT commands for PTT by unchecking "Suppress CAT".

It also seems you so not have multiple PTT sources, unless something like DATA-VOX is also enabled, so the initial diagnosis may be wrong.

73
Bill
G4WJS.

On 03/03/2021 18:12, Rick via groups.io wrote:
Bill: I unchecked the "suppress CAT" box, as per the instructions and found the radio no longer keys -- even when using the "TX" button on the main screen of Commander. Curious. I'm wondering it the issue lays elsewhere.


On Wednesday, March 3, 2021, 12:44:12 PM EST, g4wjs <bill.8@classdesign.com> wrote:


On 03/03/2021 17:40, Rick via groups.io wrote:
For example do you have "Suppress CAT" unchecked
in the Commander PTT panel?

Bill, that box is not checked.
I feel fairly certain this is something *I* have screwed up -- I don't
exactly hear a flood of folks with the same issue. And, there are a
LOT of folks using this excellent software (DXLab and WSJT) with K3s.

Rick
Hi Rick,

that'll probably be the issue. Note item 4(d) here:
http://www.dxlabsuite.com/dxlabwiki/TranceiverControlElecraft

I don't have any ideas on the similar issue with your Flex Radio 6300.
--
73

Bill

G4WJS.


Dave AA6YQ
 

+ AA6YQ comment sbelow
sounds like you do not have the K3 menu option CONFIG:PTT-KEY set correctly for RTS keying via RS-232/USB. You said you have Commander set to key the rig using the CAT port RTS line. You probably need to select CONFIG:RTS-DTR to match your Commander configuration, or the default OFF-OFF and let Commander use CAT commands for PTT by unchecking "Suppress CAT".

It also seems you so not have multiple PTT sources, unless something like DATA-VOX is also enabled, so the initial diagnosis may be wrong.

+ There are two ways to switch an Elecraft K3 between RX and TX:

1. by sending it the appropriate CAT command

2. by directing an external interface to assert or de-assert the PTT signal on the K3's backpanel

+ As Bill G4WJS has pointed out, a longstanding defect in the K3 can cause it to lock up if both of the above techniques are applied simultaneously.

+ I suggest that you first configure Commander to reliably switch your K3 between RX and TX using CAT commands.

1. To avoid the lockup defect, disconnect the external interface that is generating the backpanel PTT signal.

2. Uncheck the "Suppress CAT" box in the PTT panel on the Configuration window's General tab

3. Lower your K3's RF ouput power to 0, and tune to a clear amateur frequency

4. Using the TX and RX buttons in the PTT panel on the Configuration window's General tab, repeatedly switch between RX and TX. Does the K3 obey these commands without locking up?

73,

Dave, AA6YQ


g4wjs
 

On 04/03/2021 03:02, Dave AA6YQ wrote:
+ I suggest that you first configure Commander to reliably switch your K3 between RX and TX using CAT commands.

1. To avoid the lockup defect, disconnect the external interface that is generating the backpanel PTT signal.

2. Uncheck the "Suppress CAT" box in the PTT panel on the Configuration window's General tab

3. Lower your K3's RF ouput power to 0, and tune to a clear amateur frequency

4. Using the TX and RX buttons in the PTT panel on the Configuration window's General tab, repeatedly switch between RX and TX. Does the K3 obey these commands without locking up?

73,

Dave, AA6YQ
Hi Dave,

item (1) is tricky since with the K3S, or any K3 with a USB connection, the PTT signals are on the same virtual serial port as the CAT traffic. The RS-232 and USB virtual serial port RTS and DTR connections on a K3 are effectively in parallel.



--
73

Bill

G4WJS.


Dave AA6YQ
 

@ more AA6YQ comments below

+ I suggest that you first configure Commander to reliably switch your K3 between RX and TX using CAT commands.

1. To avoid the lockup defect, disconnect the external interface that is generating the backpanel PTT signal.

2. Uncheck the "Suppress CAT" box in the PTT panel on the
Configuration window's General tab

3. Lower your K3's RF ouput power to 0, and tune to a clear amateur
frequency

4. Using the TX and RX buttons in the PTT panel on the Configuration window's General tab, repeatedly switch between RX and TX. Does the K3 obey these commands without locking up?
item (1) is tricky since with the K3S, or any K3 with a USB connection, the PTT signals are on the same virtual serial port as the CAT traffic.
The RS-232 and USB virtual serial port RTS and DTR connections on a K3 are effectively in parallel.

@ Thanks, Bill! I should have included an additional step 2.5 in the instructions above:

2.5 For A K3S, or any K3 with a USB connection, On the Configuration window's Ports tab, set the DTR and RTS selectors in the "Primary CAT Serial Port" panel to "Off".

73,

Dave, AA6YQ


g4wjs
 

On 04/03/2021 03:34, Dave AA6YQ wrote:
@ more AA6YQ comments below

+ I suggest that you first configure Commander to reliably switch your K3 between RX and TX using CAT commands.

1. To avoid the lockup defect, disconnect the external interface that is generating the backpanel PTT signal.

2. Uncheck the "Suppress CAT" box in the PTT panel on the 
Configuration window's General tab

3. Lower your K3's RF ouput power to 0, and tune to a clear amateur 
frequency

4. Using the TX and RX buttons in the PTT panel on the Configuration window's General tab, repeatedly switch between RX and TX. Does the K3 obey these commands without locking up?
item (1) is tricky since with the K3S, or any K3 with a USB connection, the PTT signals are on the same virtual serial port as the CAT traffic. 
The RS-232 and USB virtual serial port RTS and DTR connections on a K3 are effectively in parallel.

@ Thanks, Bill! I should have included an additional step 2.5 in the instructions above:

2.5 For A K3S, or any K3 with a USB connection, On the Configuration window's Ports tab,  set the DTR and RTS selectors in the "Primary CAT Serial Port" panel to "Off".

       73,

                  Dave, AA6YQ

Hi Dave,

the default K3 configuration (CONFIG:PTT-KEY) has external PTT and FSK keying disabled, that applies to both the RS-232 port and the virtual USB serial port. So although it is correct to not configure Commander to try and PTT the rig via RTS or DTR if CAT PTT is being used, it will only have an effect if the rig's CONFIG:PTT-KEY option is also set to something like RTS-DTR as opposed to the default OFF-OFF.


--
73

Bill

G4WJS.


Dave AA6YQ
 

+ AA6YQ comments below
the default K3 configuration (CONFIG:PTT-KEY) has external PTT and FSK keying disabled, that applies to both the RS-232 port and the virtual USB serial port. So although it is correct to not configure Commander to try and PTT the rig via RTS or DTR if CAT PTT is being used, it will only have an effect if the rig's CONFIG:PTT-KEY option is also set to something like RTS-DTR as opposed to the default OFF-OFF

+ That makes an assumption about where the K3's "PTT lockup" defect lies. Setting Commander's RTS and DTR selectors to "OFF" eliminates any possible source of external PTT assertion.

+ If RX-TX switching via CAT command is reliable - first with Commander standalone, and then with WSJT-X - the user can then if desired change to using PTT for RX-TX switching instead of using CAT commands for that purpose. This maintains a "change only one thing at a time"  approach to debugging.

      73,

           Dave, AA6YQ