trying to interface my Yaesu FT991A with DxLab - no joy


Dave AA6YQ
 

+ AA6YQ comments below
I have the 991A away from my main station computer.  When I can, I’ll get you an answer.

+ No rush, Ed. Lance KK4DX got his FT-991 communicating with Commander. I'd just like to be sure that the documentation is comprehensive.

         73,

              Dave, AA6YQ


Ed
 

Dave,
I have the 991A away from my main station computer.  When I can, I’ll get you an answer.

Ed. WA6WGS


Dave AA6YQ
 

+ AA6YQ comments below
Ok. I finally deleted the drivers (enhanced and standard) and re-installed and I have comms now.
+ Good! Does Windows now inform you when you connect your radio to your computer?

     73,

            Dave,. AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below:
menu 32 CAT is 1000msec
menu 33 is RTS ENABLED
+ Thanks, Ed! I assume with those settings that you have RTS set to "Flow" in Commander's "Primary CAT Port" panel.

       73,

             Dave. AA6YQ


Lance HP
 

Ok. I finally deleted the drivers (enhanced and standard) and re-installed and I have comms now.
Thanks for your help. I wasn't sure what was happening before, but all good now.

Lance KK4DX


Ed
 

Hi Dave

menu 32 CAT is 1000msec
menu 33 is RTS ENABLED

Ed


Dave AA6YQ
 

+ AA6YQ comments below

I must be missing something. Baud rate matches up but still nothing.
Changed the settings in the radio as well to match (although parity is NOT defined anywhere that I can see).

I guess I will have to come back to this later and spend more time. There must be that 'magic checkbox easter egg' somewhere that I an not seeing.

+ The "Model-specific notes" section of

https://www.dxlabsuite.com/dxlabwiki/TranceiverControlYaesu

+ states that the FT-991 contains an internal SCU-17. The article to which it links

https://www.dxlabsuite.com/dxlabwiki/YaesuSCU-17

+ includes an "FT-991 Setup" section and a "Transceiver Control (CAT)" section.

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below

I must be missing something. Baud rate matches up but still nothing.
Changed the settings in the radio as well to match (although parity is NOT defined anywhere that I can see).

I guess I will have to come back to this later and spend more time. There must be that 'magic checkbox easter egg' somewhere that I an not seeing.

+ There is no "magic easter egg checkbox. All configuration items are documented.

+ Things to check:

1. that you've configured Commander's "Primary CAT Port" panel to control the correct virtual COM port created by your FT-991 device driver

2. that the USB cable you're using to connect the radio to your computer is "good", and properly seated at both ends.

3. try increasing the "CAT TOT" menu setting (32) to 1000.

4. the "CAT RTS" menu item (33) defaults to ENABLE. In typical Yaesu style, the meaning of this setting is not documented; try setting it to DISABLE.

+ Your earlier report that connecting your radio to your computer did not produce the expected notification from Windows is not a good sign. When you connect your radio to your computer, the Window Device Manager should show two new COM ports appearing. Trouble in this area requires engaging with Yaesu support.

+ Ed WA6WGS, how are menu items 32 and 33 configured on your FT-991?

73,

Dave, AA6YQ


Joe Subich, W4TV
 

I can communication with the radio using the programming software that I bought so I confirmed my cable is good and apparently that software is using a driver that works with the radio.
Are you connected to the transceiver using the USB connection or
using the RS-232 connection? Mentioning an external cable would
tend to indicate a third party cable connected to the GPS/CAT jack
and not a generic USB cable connected to the USB jack.

If you are using a third party cable connected to the GPS/CAT jack,
make sure that:
Menu item 028 "GPS/232C Select" is set to RS232C.
Menu item 029 "232C Rate" is set to 38.400 bps
Menu item 030 "232 TOT" is set to 1000 or higher

If you are using a USB A-B cable connected to the USB jack, make
sure that:
Menu item 031 "CAT Rate" is set to 38,400 bps
Menu item 032 "CAT TOT" is set to 1000 or higher
Menu item 033 "CAT RTS" is set to DISABLE
In addition, make sure that Commander is configured for the correct
virtual port created by the Yaesu USB driver (it creates two ports
one "Enhanced" port for CAT, one "Standard" port for FSK, PTT, CW,
etc.). See "FT-991A SCU-17 USB Driver Installation Manual" in the
Files area of the FT-991A listing at www.Yaesu.com.


73,

... Joe, W4TV


On 2021-02-04 10:54 AM, Lance HP wrote:
Hi. Trying to get the DXlab commander to communicate to the subject radio. I haven't had any luck so far. I don't really know what the communications setting should be for the radio (com port, baud rate, etc). I can communication with the radio using the programming software that I bought so I confirmed my cable is good and apparently that software is using a driver that works with the radio. I am not sure about DXLab though. I downloaded the driver from Yaesu and that didn't really change anything. I didn't change the default comm settings in commander and at a loss of what to change them to.
Any suggestions?
By the way, it occurred to me that I might have to upgrade my radio firmware, but I shied away from that 'rabbit hole' for now.


Lance HP
 

I must be missing something. Baud rate matches up but still nothing.
Changed the settings in the radio as well to match (although parity is NOT defined anywhere that I can see).

I guess I will have to come back to this later and spend more time. There must be that 'magic checkbox easter egg' somewhere that I an not seeing.

Lance KK4DX


Ed
 
Edited

Make sure you are using the correct port .  Your 991A should have made 2 com ports.  Not sure which one you are using.  You might test the port you are not using?


I don’t have my 991A hooked up right now, but works perfect with commander, with the right settings.

like Dave just indicated, make sure all your settings match the radio.

Ed WA6WGS


Dave AA6YQ
 

+ AA6YQ comments below
I followed the step by step instructions. Still not talking to commander.
When I have the radio plugged in, looking at the com port in device manager indicates that the port is working properly. When unplugged it recognizes that the port is not connected. The strange thing is that windows doesn't 'cue' me when I plug the radio into my computer.
I did modify the baud rate to 38,400, but where would I find the radio interface info? My FT991A operating manual does not contain that information.

+ If you configured Commander to use 38400 baud but didn't configure the radio to use 38,400 baud, that's one reason the two can't communicate.

+ Menu item 31 controls the CAT baud rate; see page 121 of your FT-991 "Operating Manual".

        73,

               Dave, AA6YQ


Lance HP
 

I followed the step by step instructions. Still not talking to commander.
When I have the radio plugged in, looking at the com port in device manager indicates that the port is working properly. When unplugged it recognizes that the port is not connected. The strange thing is that windows doesn't 'cue' me when I plug the radio into my computer.
I did modify the baud rate to 38,400, but where would I find the radio interface info? My FT991A operating manual does not contain that information.


Dave AA6YQ
 

+ AA6YQ comments below
Hi. Trying to get the DXlab commander to communicate to the subject radio. I haven't had any luck so far. I don't really know what the communications setting should be for the radio (com port, baud rate, etc). I can communication with the radio using the programming software that I bought so I confirmed my cable is good and apparently that software is using a driver that works with the radio. I am not sure about DXLab though. I downloaded the driver from Yaesu and that didn't really change anything. I didn't change the default comm settings in commander and at a loss of what to change them to.
Any suggestions?
By the way, it occurred to me that I might have to upgrade my radio firmware, but I shied away from that 'rabbit hole' for now

+ Step-by-step instructions are here:

https://www.dxlabsuite.com/dxlabwiki/TranceiverControlYaesu

+ If those don't get you going, let me know.

      73,

            Dave, AA6YQ

 


Lance HP
 

Hi. Trying to get the DXlab commander to communicate to the subject radio. I haven't had any luck so far. I don't really know what the communications setting should be for the radio (com port, baud rate, etc). I can communication with the radio using the programming software that I bought so I confirmed my cable is good and apparently that software is using a driver that works with the radio. I am not sure about DXLab though. I downloaded the driver from Yaesu and that didn't really change anything. I didn't change the default comm settings in commander and at a loss of what to change them to.
Any suggestions?
By the way, it occurred to me that I might have to upgrade my radio firmware, but I shied away from that 'rabbit hole' for now.