Topics

Using Two Icoms Radios with Commander


Michael Raskin
 

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer and have Commander control each rig, but I want to set up the “Multi Radio”panel correctly.  Under “Control” I have “Enable” checked for each radio but “Interrogate” and “Interval” are left blank.  Under “CAT Serial Port” Radio 1 (IC-7851) Port # is 5 while Radio 2 (IC-9700) Port # is 12.  Baud is 115200, Word 8, Parity N, Stop 1, DTR N, and RTS N, for both radios.  I have not filled out anything for “User-defined Control Sets” and I have “Selection by band” checked “Auto.”  When I attempt to use “Update” to “transfer” the settings from the “Ports” panel I don’t get proper switching.  I’m thinking maybe my “Ports” panel is not correctly configured.  My “Primary CAT Serial Port” is Port #5 (this is the virtual serial port created by the IC-7851), Baud 115200, Word 8, Parity None, Stop 1, DTR Off, RTS Off.  The “Secondary CAT Serial Port” is Port #8 (this is the physical serial port connected to the CT-17), Baud 19200.  Word, Parity, Stop DTR, RTS are the same as “Primary CAT Serial Port.”  I also have “Enable” checked. The “CAT Protocol” is “SteppIR” since I am using the CT-17 to control the SteppIR, Expert 2K Amp, and Hamplus antenna switch through the CI-V bus.  The radios are not connected to the CI-V bus.  My “General” tab under Commander has the Radio set as IC-7851 and not IC-9700.  I know someone out there has done this correctly.  What am I missing or doing wrong?
 
Mike W4UM


Dave AA6YQ
 

+ AA6YQ comments below

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer and have Commander control each rig, but I want to set up the “Multi Radio”panel correctly. Under “Control” I have “Enable” checked for each radio but “Interrogate” and “Interval” are left blank.

+ The "Interrogate" box must be checked for Commander to control those radios. I suggest setting the interval to 50 for each.

Under “CAT Serial Port” Radio 1 (IC-7851) Port # is 5 while Radio 2 (IC-9700) Port # is 12. Baud is 115200, Word 8, Parity N, Stop 1, DTR N, and RTS N, for both radios. I have not filled out anything for “User-defined Control Sets” and I have “Selection by band” checked “Auto.” When I attempt to use “Update” to “transfer” the settings from the “Ports” panel I don’t get proper switching.

+ The "Update" buttons perform no switching. Clicking one copies the settings from Configuration window's General and Ports tabs *to* the MultiRadio tab. If you configure the General and Ports tab so that Commander correctly controls the current transceiver, and you can then click the appropriate Update button on the "MultiRadio" tab to configure that radio's settings on the "MultiRadio" tab.

+ Radio switching is initiated by clicking one of the radio buttons beneath the Main window's "Main VFO" panel, highlighted in red in this screen shot:

<http://www.dxlabsuite.com/Wiki/Graphics/Commander/MultiSelect.jpg>

+ See

<https://www.dxlabsuite.com/dxlabwiki/ControlMultipleRadios>


73,

Dave, AA6YQ


Michael Raskin
 

Dave - Again, thanks for your reply. See my answers below.

-----Original Message-----
From: Dave AA6YQ
Sent: Saturday, May 23, 2020 9:11 PM
To: DXLab@groups.io
Subject: Re: [DXLab] Using Two Icoms Radios with Commander

+ AA6YQ comments below

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer and have Commander control each rig, but I want to set up the “Multi Radio”panel correctly. Under “Control” I have “Enable” checked for each radio but “Interrogate” and “Interval” are left blank.

+ The "Interrogate" box must be checked for Commander to control those radios. I suggest setting the interval to 50 for each.

++ I have now done this as you have suggested.

Under “CAT Serial Port” Radio 1 (IC-7851) Port # is 5 while Radio 2 (IC-9700) Port # is 12. Baud is 115200, Word 8, Parity N, Stop 1, DTR N, and RTS N, for both radios. I have not filled out anything for “User-defined Control Sets” and I have “Selection by band” checked “Auto.” When I attempt to use “Update” to “transfer” the settings from the “Ports” panel I don’t get proper switching.

+ The "Update" buttons perform no switching. Clicking one copies the settings from Configuration window's General and Ports tabs *to* the MultiRadio tab. If you configure the General and Ports tab so that Commander correctly controls the current transceiver, and you can then click the appropriate Update button on the "MultiRadio" tab to configure that radio's settings on the "MultiRadio" tab.

++ I assume that I need to click the "Update" button for each of the two radios. When I click of "Update" the window freezes and the only way to get out of it is to shut DXLab down. I know that can't be right. Also, he secondary CAT Protocol is "SteppIR' and I need to have the "Secondary CAT Serial Port" ENABLED or there is no band switching of the SteppIR, Expert 2K amp, or Ham Plus antenna switch. If I don't check "Enable" nothing switches. I must have something not correctly set with on of the panels.

+ Radio switching is initiated by clicking one of the radio buttons beneath the Main window's "Main VFO" panel, highlighted in red in this screen shot:

<http://www.dxlabsuite.com/Wiki/Graphics/Commander/MultiSelect.jpg>

+ See

<https://www.dxlabsuite.com/dxlabwiki/ControlMultipleRadios>

++ The "Main VFO" panel shows both radios.


73,

Dave, AA6YQ


Dave AA6YQ
 

* More AA6YQ comments below

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer and have Commander control each rig, but I want to set up the Multi Radio panel correctly. Under Control I have Enable checked for each radio but Interrogate and Interval are left blank.

Under CAT Serial Port Radio 1 (IC-7851) Port # is 5 while Radio 2
(IC-9700) Port # is 12. Baud is 115200, Word 8, Parity N, Stop 1, DTR N,
and RTS N, for both radios. I have not filled out anything for
User-defined Control Sets and I have Selection by band checked Auto.
When I attempt to use Update to transfer the settings from the Ports
panel I don t get proper switching.

+ The "Update" buttons perform no switching. Clicking one copies the
settings from Configuration window's General and Ports tabs *to* the
MultiRadio tab. If you configure the General and Ports tab so that Commander
correctly controls the current transceiver, and you can then click the
appropriate Update button on the "MultiRadio" tab to configure that radio's
settings on the "MultiRadio" tab.

++ I assume that I need to click the "Update" button for each of the two
radios. When I click of "Update" the window freezes and the only way to get
out of it is to shut DXLab down. I know that can't be right. Also, he
secondary CAT Protocol is "SteppIR' and I need to have the "Secondary CAT
Serial Port" ENABLED or there is no band switching of the SteppIR, Expert 2K
amp, or Ham Plus antenna switch. If I don't check "Enable" nothing
switches. I must have something not correctly set with on of the panels.

* I suggest that you focus first on being able to control either transceiver, so disable the Secondary CAT Port for now. Then

1. configure the Configuration window's General and Ports tab for use with your IC-7851

2. confirm that Commander can control Your IC-7851's frequency and mode, and can track your IC-7851's frequency and mode

3. on the Configuration window's MultiRadio tab, assuming that your IC-7851 will be "Radio 1",

3a. in the "CAT Serial port" panel, click Radio 1's Update button

3b. in the "Control" panel's Radio 1 row, set the Model to IC-7851, set the "CI-V Addr" to the correct value, check the Interrogate box, set the interval to 50, set the Name to IC-7851, and check the Enable box

4. configure the Configuration window's General and Ports tab for use with your IC-9700

5. confirm that Commander can control Your IC-9700's frequency and mode, and can track your IC-9700's frequency and mode

6. on the Configuration window's MultiRadio tab, assuming that your IC-9700 will be "Radio 2",

7a. in the "CAT Serial port" panel, click Radio 2's Update button

7b. in the "Control" panel's Radio 2 row, set the Model to IC-9700, set the "CI-V Addr" to the correct value, check the Interrogate box, set the interval to 50, set the Name to IC-9700, and check the Enable box

* You should now have two radio buttons below the Main window's "Main VFO" panel labeled IC-7851 and IC-9700

* Clicking either one should select the appropriate radio.

* If that's now working correct, enable the Secondary CAT Port.

73,

Dave, AA6YQ


Michael Raskin
 

"Dumb cockpit errors" were the cause of my problems, but I have them all
solved today on my 78th birthday. What a nice birthday present to myself.
Since you're wondering what the dumb cockpit error was, it was failing to
double click on the Default Address to set the CI-V address to radio's
default setting in the General tab of the Commander Configuration. Now I
can click on either the 7851 or 9700 in the Commander's VFO panel and
everything switches the way I want it. Since the 9700 is not connected to
the Expert amp, SteppIR, or antenna switch, there is no conflict. Thanks
again, Dave, for your step-by-step advice and hanging in there through my
memory lapses.

73,
Mike, W4UM
------------------------------------------

-----Original Message-----
From: Dave AA6YQ
Sent: Sunday, May 24, 2020 10:17 PM
To: DXLab@groups.io
Subject: Re: [DXLab] Using Two Icoms Radios with Commander

* More AA6YQ comments below

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer
and have Commander control each rig, but I want to set up the Multi Radio
panel correctly. Under Control I have Enable checked for each radio but
Interrogate and Interval are left blank.

Under CAT Serial Port Radio 1 (IC-7851) Port # is 5 while Radio 2
(IC-9700) Port # is 12. Baud is 115200, Word 8, Parity N, Stop 1, DTR N,
and RTS N, for both radios. I have not filled out anything for
User-defined Control Sets and I have Selection by band checked Auto.
When I attempt to use Update to transfer the settings from the Ports
panel I don t get proper switching.

+ The "Update" buttons perform no switching. Clicking one copies the
settings from Configuration window's General and Ports tabs *to* the
MultiRadio tab. If you configure the General and Ports tab so that Commander
correctly controls the current transceiver, and you can then click the
appropriate Update button on the "MultiRadio" tab to configure that radio's
settings on the "MultiRadio" tab.

++ I assume that I need to click the "Update" button for each of the two
radios. When I click of "Update" the window freezes and the only way to get
out of it is to shut DXLab down. I know that can't be right. Also, he
secondary CAT Protocol is "SteppIR' and I need to have the "Secondary CAT
Serial Port" ENABLED or there is no band switching of the SteppIR, Expert 2K
amp, or Ham Plus antenna switch. If I don't check "Enable" nothing
switches. I must have something not correctly set with on of the panels.

* I suggest that you focus first on being able to control either
transceiver, so disable the Secondary CAT Port for now. Then

1. configure the Configuration window's General and Ports tab for use with
your IC-7851

2. confirm that Commander can control Your IC-7851's frequency and mode, and
can track your IC-7851's frequency and mode

3. on the Configuration window's MultiRadio tab, assuming that your IC-7851
will be "Radio 1",

3a. in the "CAT Serial port" panel, click Radio 1's Update button

3b. in the "Control" panel's Radio 1 row, set the Model to IC-7851, set the
"CI-V Addr" to the correct value, check the Interrogate box, set the
interval to 50, set the Name to IC-7851, and check the Enable box

4. configure the Configuration window's General and Ports tab for use with
your IC-9700

5. confirm that Commander can control Your IC-9700's frequency and mode, and
can track your IC-9700's frequency and mode

6. on the Configuration window's MultiRadio tab, assuming that your IC-9700
will be "Radio 2",

7a. in the "CAT Serial port" panel, click Radio 2's Update button

7b. in the "Control" panel's Radio 2 row, set the Model to IC-9700, set the
"CI-V Addr" to the correct value, check the Interrogate box, set the
interval to 50, set the Name to IC-9700, and check the Enable box

* You should now have two radio buttons below the Main window's "Main VFO"
panel labeled IC-7851 and IC-9700

* Clicking either one should select the appropriate radio.

* If that's now working correct, enable the Secondary CAT Port.

73,

Dave, AA6YQ


Michael Raskin
 

"Dumb cockpit errors" were the cause of my problems, but I have them all
solved today on my 78th birthday. What a nice birthday present to myself.
Since you're wondering what the dumb cockpit error was, it was failing to
double click on the Default Address to set the CI-V address to radio's
default setting in the General tab of the Commander Configuration. Now I
can click on either the 7851 or 9700 in the Commander's VFO panel and
everything switches the way I want it. Since the 9700 is not connected to
the Expert amp, SteppIR, or antenna switch, there is no conflict. Thanks
again, Dave, for your step-by-step advice and hanging in there through my
memory lapses.

73,
Mike, W4UM
------------------------------------------

-----Original Message-----
From: Dave AA6YQ
Sent: Sunday, May 24, 2020 10:17 PM
To: DXLab@groups.io
Subject: Re: [DXLab] Using Two Icoms Radios with Commander

* More AA6YQ comments below

I am planning to connect two Icom rigs (IC-7851 and IC-9700) to my computer and have Commander control each rig, but I want to set up the Multi Radio panel correctly. Under Control I have Enable checked for each radio but Interrogate and Interval are left blank.

Under CAT Serial Port Radio 1 (IC-7851) Port # is 5 while Radio 2
(IC-9700) Port # is 12. Baud is 115200, Word 8, Parity N, Stop 1, DTR N,
and RTS N, for both radios. I have not filled out anything for
User-defined Control Sets and I have Selection by band checked Auto.
When I attempt to use Update to transfer the settings from the Ports
panel I don t get proper switching.

+ The "Update" buttons perform no switching. Clicking one copies the
settings from Configuration window's General and Ports tabs *to* the
MultiRadio tab. If you configure the General and Ports tab so that Commander
correctly controls the current transceiver, and you can then click the
appropriate Update button on the "MultiRadio" tab to configure that radio's
settings on the "MultiRadio" tab.

++ I assume that I need to click the "Update" button for each of the two
radios. When I click of "Update" the window freezes and the only way to get
out of it is to shut DXLab down. I know that can't be right. Also, he
secondary CAT Protocol is "SteppIR' and I need to have the "Secondary CAT
Serial Port" ENABLED or there is no band switching of the SteppIR, Expert 2K
amp, or Ham Plus antenna switch. If I don't check "Enable" nothing
switches. I must have something not correctly set with on of the panels.

* I suggest that you focus first on being able to control either transceiver, so disable the Secondary CAT Port for now. Then

1. configure the Configuration window's General and Ports tab for use with your IC-7851

2. confirm that Commander can control Your IC-7851's frequency and mode, and can track your IC-7851's frequency and mode

3. on the Configuration window's MultiRadio tab, assuming that your IC-7851 will be "Radio 1",

3a. in the "CAT Serial port" panel, click Radio 1's Update button

3b. in the "Control" panel's Radio 1 row, set the Model to IC-7851, set the "CI-V Addr" to the correct value, check the Interrogate box, set the interval to 50, set the Name to IC-7851, and check the Enable box

4. configure the Configuration window's General and Ports tab for use with your IC-9700

5. confirm that Commander can control Your IC-9700's frequency and mode, and can track your IC-9700's frequency and mode

6. on the Configuration window's MultiRadio tab, assuming that your IC-9700 will be "Radio 2",

7a. in the "CAT Serial port" panel, click Radio 2's Update button

7b. in the "Control" panel's Radio 2 row, set the Model to IC-9700, set the "CI-V Addr" to the correct value, check the Interrogate box, set the interval to 50, set the Name to IC-9700, and check the Enable box

* You should now have two radio buttons below the Main window's "Main VFO" panel labeled IC-7851 and IC-9700

* Clicking either one should select the appropriate radio.

* If that's now working correct, enable the Secondary CAT Port.

73,

Dave, AA6YQ


Dave AA6YQ
 

+ AA6YQ comments below

"Dumb cockpit errors" were the cause of my problems, but I have them all solved today on my 78th birthday. What a nice birthday present to myself.
Since you're wondering what the dumb cockpit error was, it was failing to double click on the Default Address to set the CI-V address to radio's default setting in the General tab of the Commander Configuration. Now I can click on either the 7851 or 9700 in the Commander's VFO panel and everything switches the way I want it. Since the 9700 is not connected to the Expert amp, SteppIR, or antenna switch, there is no conflict. Thanks again, Dave, for your step-by-step advice and hanging in there through my memory lapses.

+ Happy Birthday, Mike!

+ Glad you got your multi-radio configuration working.

73,

Dave, AA6YQ