DXLab and SDR Uno


Don Inbody AD0K
 

I have finally managed to get Commander and SDRUno talking together and playing nicely. QSYing rig or SDRUno, including band and mode changes, will cause the other to follow.

Set up as follows:
Establish virtual connected ports. I used Comm0comm to establish ports 15 (N), and 16 (N+1)
Rig (TS-590sg) connected to computer via USB port (Comm 6, in my case) 9600, 8,N,1,Off, On
Commander setup: Primary rig Comm 6, secondary rig port 15, 115200, 8, N, 1, Off, On
SDRUno Cat settings (RX/Settings/CAT) Comm 16, 115200 RX Mode Control checked, Enable and Connect checked

I don't yet know why a faster baud rate between the rig, Commander, and the computer did not work, but I am exploring further.

73, Don AD0K


Dave AA6YQ
 

+ AA6YQ comments below

I have finally managed to get Commander and SDRUno talking together and playing nicely. QSYing rig or SDRUno, including band and mode changes, will cause the other to follow.

Set up as follows:
Establish virtual connected ports. I used Comm0comm to establish ports 15 (N), and 16 (N+1) Rig (TS-590sg) connected to computer via USB port (Comm 6, in my case) 9600, 8,N,1,Off, On Commander setup: Primary rig Comm 6, secondary rig port 15, 115200, 8, N, 1, Off, On SDRUno Cat settings (RX/Settings/CAT) Comm 16, 115200 RX Mode Control checked, Enable and Connect checked

I don't yet know why a faster baud rate between the rig, Commander, and the computer did not work, but I am exploring further.

+ Please post your findings here, Don!

73,

Dave, AA6YQ


Don Inbody AD0K
 

Solved the baud rate issue. 
Open Device Manager
Open Ports (Com & LPT)
Locate Silicon Labs CP210x USB to UART Bridge (Com 6, in my case)
Right Click
Open Properties
Click Port Settings
Change Bits per second to 115200
Click OK
Close Device Manage
Change TS-590SG menu 68 to 115200
Leave Commander on 9600 baud.
Changing it to 115200 baud does not work - Still sorting that out.


Dave AA6YQ
 

+ AA6YQ comments below

Solved the baud rate issue.
Open Device Manager
Open Ports (Com & LPT)
Locate Silicon Labs CP210x USB to UART Bridge (Com 6, in my case) Right Click Open Properties Click Port Settings Change Bits per second to 115200 Click OK Close Device Manage Change TS-590SG menu 68 to 115200 Leave Commander on 9600 baud.
Changing it to 115200 baud does not work - Still sorting that out.

+ So something between Commander and your TS-590SG was putting an upper limit on the baud rate. Interesting...

73,

Dave, AA6YQ