Topics

DXLab Suite - SmartSDR help needed

K4PX K4PX
 

Ok thanks Dave.
Joe

On Fri, Apr 19, 2019, 11:45 PM Dave AA6YQ <aa6yq@...> wrote:
+ AA6YQ comments below

Please let me know when the new version is available so I can try it on my Flex thank you very much hopefully it will fix my problem

+ Every public release of every DXLab application is announced here.

       73,

               Dave, AA6YQ





Dave AA6YQ
 

+ AA6YQ comments below

Please let me know when the new version is available so I can try it on my Flex thank you very much hopefully it will fix my problem

+ Every public release of every DXLab application is announced here.

73,

Dave, AA6YQ

K4PX K4PX
 

Please let me know when the new version is available so I can try it on my Flex thank you very much hopefully it will fix my problem


On Fri, Apr 19, 2019, 4:46 PM Dave AA6YQ <aa6yq@...> wrote:
As has been reported here several times over the past weeks, the current version of Commander cannot reliably switch SmartSDR version 3 between TX and RX. Jamie WW3S and I are working with Flex personnel to determine why this is happening.

I've already updated the next version of Commander to handle a change in API command syntax in SmartSDR v3 that prevents the current version of Commander from muting a VFO. After we've resolved the "TX-RX" issue and Jamie confirms correct operation, I will make the new version of Commander publicly available.

       73,

             Dave, AA6YQ

-----Original Message-----
From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Jeff Schwartz via Groups.Io
Sent: Friday, April 19, 2019 10:27 AM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLab Suite - SmartSDR help needed

Gary,
Congrats on your 6600 purchase. It’s an amazing rig. Version 3.0.19 actually seems to continue to work well with most DX Labs applications as far as I can tell EXCEPT for the biggie TX /RX control. This has only affected WSJT-X and WinWarbler for me. Flex PTT, however, is easily control by creating an SDR CAT port for WSJT-X and an SDR CAT PTT port for WinWarbler. Both WSJT-X and WinWarbler need to be reconfigured to make that work but it is a simple process once you create the two ports mentioned in SDR CAT. WSJT-X needs to be configured for control by Flex instead of controlled by DX. lab Suites. As for CW and SSB PTT WinWarbler did not require any changes for me if I’m sending CW from WinWarbler or using my PTT hand switch plugged into the Flex.

You our are welcome to contact me at ki0kb@... and I can send you pictures on how to set this up.

Jeff Schwartz





Dave AA6YQ
 

As has been reported here several times over the past weeks, the current version of Commander cannot reliably switch SmartSDR version 3 between TX and RX. Jamie WW3S and I are working with Flex personnel to determine why this is happening.

I've already updated the next version of Commander to handle a change in API command syntax in SmartSDR v3 that prevents the current version of Commander from muting a VFO. After we've resolved the "TX-RX" issue and Jamie confirms correct operation, I will make the new version of Commander publicly available.

73,

Dave, AA6YQ

-----Original Message-----
From: DXLab@groups.io [mailto:DXLab@groups.io] On Behalf Of Jeff Schwartz via Groups.Io
Sent: Friday, April 19, 2019 10:27 AM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLab Suite - SmartSDR help needed

Gary,
Congrats on your 6600 purchase. It’s an amazing rig. Version 3.0.19 actually seems to continue to work well with most DX Labs applications as far as I can tell EXCEPT for the biggie TX /RX control. This has only affected WSJT-X and WinWarbler for me. Flex PTT, however, is easily control by creating an SDR CAT port for WSJT-X and an SDR CAT PTT port for WinWarbler. Both WSJT-X and WinWarbler need to be reconfigured to make that work but it is a simple process once you create the two ports mentioned in SDR CAT. WSJT-X needs to be configured for control by Flex instead of controlled by DX. lab Suites. As for CW and SSB PTT WinWarbler did not require any changes for me if I’m sending CW from WinWarbler or using my PTT hand switch plugged into the Flex.

You our are welcome to contact me at ki0kb@... and I can send you pictures on how to set this up.

Jeff Schwartz

Dave AA6YQ
 

+ AA6YQ comments below

I purchased a Visalia promotion Flex 6600 and Maestro and took delivery on it this past Wed. It came with SmartSDR v 3.0.x which is
of course not fully compatible with DXLab Suite.

+ I use SmartSDR 2.4.9 with my Flex 6500; I do not have a Maestro, but I'm not aware of any reported problems using the current
public version of Commander with any Flex configuration.

+ See

< https://www.dxlabsuite.com/dxlabwiki/FlexSignature>

73,

Dave, AA6YQ

Jeff Schwartz
 

Sounds like a good plan Gary. I have been back and forth between v 2.49 and v 3.0.19 a few times myself. I suspect Flex will correct the monitor bug in v 3 and who knows what else. I ended up setting up a workspace in DX Labs for both software versions should I switch again. Dave’s DX Labs program is so robust it seems to allow workarounds when programmers decide to go rouge. 

Jeff Schwartz

CSM\(r\) Gary Huber - AB9M
 

Thanks Jeff.  I have been having the WXJT-X and Winwarbler issues you stated below.  I just downloaded SmartSDR 2.4.9 and will give it a go shortly. I am mostly interested in DX and do contesting mostly as exercise for getting through pile-ups so I don't loose much using the earlier versions of SmartSDR since I'm not a SO2R guy.

Thanks for the insights on configuring the apps for Version 3.0.19, I'll be trying that a bit later after I'm a bit more used to the new 6600 and Maestro.

73 & DX,
Gary ~ AB9M


From: DXLab@groups.io <DXLab@groups.io> on behalf of Jeff Schwartz via Groups.Io <ki0kb@...>
Sent: Friday, April 19, 2019 9:26 AM
To: DXLab@groups.io
Subject: Re: [DXLab] DXLab Suite - SmartSDR help needed
 
Gary,
Congrats on your 6600 purchase. It’s an amazing rig. Version 3.0.19 actually seems to continue to work well with most DX Labs applications as far as I can tell EXCEPT for the biggie TX /RX control. This has only affected WSJT-X and WinWarbler for me. Flex PTT, however, is easily control by creating an SDR CAT port for WSJT-X and an SDR CAT PTT port for WinWarbler. Both WSJT-X and WinWarbler need to be reconfigured to make that work but it is a simple process once you create the two ports mentioned in SDR CAT. WSJT-X needs to be configured for control by Flex instead of controlled by DX. lab Suites. As for CW and SSB PTT WinWarbler did not require any changes for me if I’m sending CW from WinWarbler or using my PTT hand switch plugged into the Flex. 

You our are welcome to contact me at ki0kb@... and I can send you pictures on how to set this up. 

Jeff Schwartz

Bill Billingsley
 

I use SDR V2.3.9 on my 6600().  It works great with DXlabs.

Bill, N5IR

On Fri, Apr 19, 2019 at 6:32 AM CSM&#92;(r&#92;) Gary Huber - AB9M <glhuber@...> wrote:
I purchased a Visalia promotion Flex 6600 and Maestro and took delivery on it this past Wed. It came with SmartSDR v 3.0.x  which is of course not fully compatible with DXLab Suite. 

I am looking for help/ recommendations for earlier SmartSDR versions that will work with my new Flex 6600.

73 ES DX,

Gary - AB9M

Al Groff
 

Kent,
   As far as I know, a new V3 Flex can be downgraded to V2 at no additional cost.
AL, K0VM

On 4/19/2019 10:36 AM, Kent Olsen wrote:
Does anyone know if you purchase a new Flex radio with V3, is V2 included or do you have to purchase it?

Thanks
73
Kent
N6WT


On Fri, Apr 19, 2019 at 7:39 AM Jeff Schwartz via Groups.Io <ki0kb=icloud.com@groups.io> wrote:
BTW Gary, V 2.49 worked just fine with all aspects of DXLabs. Additionally the changes I mentioned above in WinWarbler for v 3.0 were required for RTTY use. There are likely other things that may not work correctly in DX Labs with the new version but if so I haven’t noticed them at this point and they haven’t affected my operating. 

Jeff Schwartz 

Jeff Schwartz
 

That’s a good question. I have no idea. I’m sure a note to Flex would answer that pretty quickly. Or you could download it and see if they try to make you buy it. 
Jeff Schwartz

Kent Olsen
 

Does anyone know if you purchase a new Flex radio with V3, is V2 included or do you have to purchase it?

Thanks
73
Kent
N6WT


On Fri, Apr 19, 2019 at 7:39 AM Jeff Schwartz via Groups.Io <ki0kb=icloud.com@groups.io> wrote:
BTW Gary, V 2.49 worked just fine with all aspects of DXLabs. Additionally the changes I mentioned above in WinWarbler for v 3.0 were required for RTTY use. There are likely other things that may not work correctly in DX Labs with the new version but if so I haven’t noticed them at this point and they haven’t affected my operating. 

Jeff Schwartz 

Jeff Schwartz
 

BTW Gary, V 2.49 worked just fine with all aspects of DXLabs. Additionally the changes I mentioned above in WinWarbler for v 3.0 were required for RTTY use. There are likely other things that may not work correctly in DX Labs with the new version but if so I haven’t noticed them at this point and they haven’t affected my operating. 

Jeff Schwartz 

Jeff Schwartz
 

Gary,
Congrats on your 6600 purchase. It’s an amazing rig. Version 3.0.19 actually seems to continue to work well with most DX Labs applications as far as I can tell EXCEPT for the biggie TX /RX control. This has only affected WSJT-X and WinWarbler for me. Flex PTT, however, is easily control by creating an SDR CAT port for WSJT-X and an SDR CAT PTT port for WinWarbler. Both WSJT-X and WinWarbler need to be reconfigured to make that work but it is a simple process once you create the two ports mentioned in SDR CAT. WSJT-X needs to be configured for control by Flex instead of controlled by DX. lab Suites. As for CW and SSB PTT WinWarbler did not require any changes for me if I’m sending CW from WinWarbler or using my PTT hand switch plugged into the Flex. 

You our are welcome to contact me at ki0kb@... and I can send you pictures on how to set this up. 

Jeff Schwartz

CSM\(r\) Gary Huber - AB9M
 

I purchased a Visalia promotion Flex 6600 and Maestro and took delivery on it this past Wed. It came with SmartSDR v 3.0.x  which is of course not fully compatible with DXLab Suite. 

I am looking for help/ recommendations for earlier SmartSDR versions that will work with my new Flex 6600.

73 ES DX,

Gary - AB9M