Re: Commander not reading radio


Lee Ratcliff
 

Hmmmmmmmmmmm, anyone know of a CI-V interface with USB that works on Win7? I hate to have to replace the interface, and get USB/Serial port adaptor. Would be nice if Prolific would fix this issue, but that's too much to ask.

Lee
KC4ART

--------------------------------------------------
From: "Joe Subich, W4TV" <lists@...>
Sent: Wednesday, December 09, 2009 8:49 PM
To: <dxlab@...>
Subject: RE: [dxlab] Commander not reading radio



The chipset is a Prolific.
Prolific are notorious for the 8020 errors. Their drivers have
a timing issue that cause the "character ready" interrupt to
arrive before the data under some circumstances. The Prolific
problem is well known in software circles but Prolific refuse
to provide an across the board fix for all versions of Windows.

73,

... Joe, W4TV




-----Original Message-----
From: dxlab@... [mailto:dxlab@...] On
Behalf Of Lee A. Ratcliff
Sent: Wednesday, December 09, 2009 7:51 PM
To: dxlab@...
Subject: Re: [dxlab] Commander not reading radio


Did a little more digging, and it seems that commander can
send info to the
radio, but cant receive info back. Both DTR and RTS are
marked as always
on.

The chipset is a Prolific.

Lee
KC4ART

--------------------------------------------------
From: "Joe Subich, W4TV" <lists@...>
Sent: Wednesday, December 09, 2009 2:13 PM
To: <dxlab@...>
Subject: RE: [dxlab] Commander not reading radio



"09-Dec-2009 16:05:43 > program error 8020 in module
CIVComm.ReadPort: Error reading comm device"
"Program Error 8020" indicates you have a problem with
your USB driver. Check the manufacturer's web site for
a Windows 7 update.

73,

... Joe, W4TV




-----Original Message-----
From: dxlab@... [mailto:dxlab@...]
On Behalf
Of Lee
Sent: Wednesday, December 09, 2009 11:10 AM
To: dxlab@...
Subject: [dxlab] Commander not reading radio


I have just switched over to WIN7, and haveing a problem with
Commander. It will not read the radio. It is throwing
this error in
the error log:

"09-Dec-2009 16:05:43 > program error 8020 in module
CIVComm.ReadPort: Error reading comm device"

The interface works fine with airmail, so I think the
problem is in
commander somewhere. I am useing the same port settings
as far as I
can tell. Settings in Commander are COM5 9600, none, 8,
1, DTR and
RTS always off. I have played with turning on the DTR and
RTS line
with no result.

Thanks

Lee
KC4ART




------------------------------------

Yahoo! Groups Links


Join DXLab@groups.io to automatically receive all group messages.