Re: Add Needed QSL ???


kk1w2000 <kk1w@...>
 

Rich,

Thanks for the tip but unfortunately I tried that one already. I can
do exactly as you suggest and clear the QSL_Sent_Via box. After the
log is modified the box is empty. However if I double click on the
address editor window the QSL manager is still filled is with "NONE".

I just tried it again in case I missed something the first time but
nope, they all say "NONE".

I don't see any way to clear that entry

I'm wondering if this is related to my import from DXbase or if I'm
still not just getting it.

Oh well, I'm off to run some errands - not much happening on the bands
here in NE this afternoon.

Thanks & '73...

Jim

--- In dxlab@..., "Richard Ferch" <ve3iay@...> wrote:

Jim,

I am guessing that your problem is due to the fact that you have the
word 'NONE' in all of your QSOs with no QSL manager. If the QSL via
boxes for these QSOs were empty, I believe that would resolve the
problem.

You can fix this by:

1. making a backup copy of your log

2. clicking on the Adv button just about the log display

3. entering
QSL_Via like 'NONE'
in one of the SQL text filter boxes and clicking on the corresponding
Filter button

4. in the Modify QSOs in Log Page Display pane at the bottom of the
Advanced ... dialog window, setting the Item ADIF Field Name to
QSL_Via and leaving the Item new value box empty (don't enter any
space characters, just leave it empty)

5. clicking on the Mod button.

This should change all the NONE entries to be empty, so that "Add
needed requests all with same qsl mgr" will ignore them.

73,
Rich VE3KI


--- In dxlab@..., "kk1w2000" <kk1w@> wrote:

Dave,

Thanks for solving my problem - doing as you suggested below
produces
the expected results when I click the 'Add Needed' button.

I'm still not clear on the logic behind the "Add Needed requests all
with same mgr" check box. My reasoning (obviously incorrect) was if
there are multiple QSO's with the same manager specified they would
all be picked for the QSL que. If there isn't a manager specified
with
the QSO then it should be ignored?

I did a few experiments setting the 'sent via' to B or D and get the
same results as 'none' (as I expected I would).

Is the only place to specify the manager's call in the capture
window
or by double clicking the address box in the log window?

It would seem the only time the check box would be of value is when
almost all the logged QSO's have managers specified? As soon as I
specify a manager in any of the QSO's the 'Add Needed' does not
select
them (as expected).

I guess I'm not getting the big picture here but I'm trying!

Thanks for all the help and truly a nice piece of software. The log
is
imported, I've got my labels and card printing all set and the
integration with SC and PF are really cool!

'73...

Jim


--- In dxlab@..., "Dave Bernstein" <aa6yq@> wrote:

Thanks for sending me your log, Jim.

My suspicion is that you have "Add Needed requests all with same
mgr"
checked on the "QSL Config" window's General tab.

Most of the QSOs in your log have their QSL_VIA item set to NONE.
So
if any QSO identified as needed has its QSL_VIA item set to NONE,
then DXKeeper will populate the QSL Queue with all other QSOs
having
their QSL_VIA item set to NONE -- the more than 7000 QSOs you
experienced. This would also explain the non-responsiveness of
the
Stop button, as the code that does the "add all QSOs with the
same
QSL_VIA" fails to check for your clicking the Stop button -- a
defect
I have corrected in DXKeeper 6.1.3.

Please try clearing the QSL queue, unchecking "Add Needed
requests
all with same mgr", and then invoke "Add Needed" again.

Better?

73,

Dave, AA6YQ

--- In dxlab@..., "kk1w2000" <kk1w@> wrote:

Dave,

My comments below but don't worry about it, have fun and watch
the
game!

Thanks, Jim


-- In dxlab@..., "Dave Bernstein" <aa6yq@> wrote:

AA6YQ comments below
--- In dxlab@..., "kk1w2000" <kk1w@> wrote:

I went through and manually flipped the V flag for
all 'verified'
cards from ARRL.

What does "flipped the V flag" mean? Did you set each of
your
verified QSO's QSL_RCVD items to 'V'?
Yes, set to 'V'.

When I run a progress report it looks just fine with the
correct
amount of counties worked and verified.

I assume you mean "countries" rather than "counties".
Exactly - countries it is.


I have set the 'Awards' tab for 5B DXCC. All the other check
boxes are
empty. The expiration age was set to 52 weeks.

So you've clicked the 80m, 40m, 20m, 15m, and 10m boxes in
the
the "DXCC/Toplist" panel on the Config window's Awards tab,
meaning
that you want to confirm every DXCC entity on each of those 5
bands.
Are all the other boxes in this panel unchecked?
Yes, all other boxes are unchecked.

There are 9464 Q's in the log and I have 207 countries
verified
by
ARRL.

I used the advanced window to filter the log for just the
last two
years QSO's and then modified those to clear the 'sent' field
(the
import set them all to N). My thought process here was I
wanted
to do
the QSL testing on just a subset of the log. That time period
comprises 352 Q's.

There is no difference between QSL_SENT being cleared and
QSL_SENT
being set to 'N'. Both mean "no card has been sent".
OK, I misunderstood. I thought a 'N' would never allow a QSL to
be
sent.


When I click the 'add needed' button on the QSL page DXKeeper
searches
the entire log and fills the QSL queue with 7001 records!

Unless you filtered the Log Page Display before
invoking "Add
Needed" searching the entire log is correct.
I did filter the log on a few attempts to just the last two
years.
The
results are the same but at least it takes less time to see it
happen.

Populating the QSL Queue with 7001 QSOs implies that
DXKeeper
thinks your looking for more than just confirming all 338
DXCC
entities on each of 5 bands.
Exactly, but I don't see what I'm missing

I have rebooted, tried changing the expiration age to 2,
nothing
seems to limit the search or prevent the que entries.

The "expiration age" setting has nothing to do witht he
operation
of "Add Needed" -- its used by the "QSL Aging" function to
set
QSL_RCVD to 'X' for QSOs whose request for confirmation has
been
outstanding for longer than a specified interval.
OK, I understand.


Looking at the details for some of the US contacts I find
them
all
confirmed and verified for the the band/mode. Not necessarily
those
specific Q's but requesting confirmation would not be
necessary.

Since over 9000 of the QSO's have their QSL send flag set
to 'N'
I'm
confused as to what is happening.

Setting QSL_SENT to 'N' (meaning "no card sent") would not
stop "Add Needed" from generating an outgoing request if the
QSO
was
needed.

The 'stop' button does not stop the process either
(unfortunately) so
I have to wait for it to fill the que, then a similar amount
of
time
to use the 'clear' button to empty the que.

I checked this with 6.1.2 and the Stop button immediately
terminates "Add Needed". I will examine the code to see under
what
conditions would fail.

My expectation is the 'add needed' button would search all
the Q's
back a year and find any that should be submitted for 5B
DXCC.
Instead
I'm getting almost 75% of the Q's in the log. Looking at any
one
of
the usually shows a 'V' so they are verified.

The fastest way to track this down would be for you to
place
your
log file in a zip archive, attach it to an email message, and
send it
to me at aa6yq@ . Thanks!
Thank you! I will keep at it a little longer before adding to
your
workload!!!



73,

Dave, AA6YQ

Join DXLab@groups.io to automatically receive all group messages.