Re: Spinning Blue Circle of Death with DXKeeper on upload to eqsl.cc when record exists


Dave AA6YQ
 

+ AA6YQ comments below

This is a report to see if others are experiencing the same issue....

+ All defect reports are welcome, whether or not anyone else is experiencing them.


Application: DXKeeper (past and present versions)

Stating condition: A record ALREADY EXISTS for one that is about to be uploaded either individually or in a stream of records to eQSL.CC

* Upload one or several records...
* Upload stream encounters that record
* DXKeeper starts an endless blue circle of death
* No useful logging information is available as the "Blue Circle of Death" has locked up operation (otherwise it would have been sent).

Consistent behaviour with that observed with uploads to LOTW is anticipated (i.e. an abort message if a duplicate is encountered). Yes I realise that LOTW and eQSL work in very different ways and have completely differnet upload interfaces and specifications.

I restate that NO USEFUL LOGGING INFORMATION is available as things are locked up...

The situation is only "clearable" by:

* Terminating the "zombied"-app at Task Manager,
* Locating the records that have been uploaded to eQSL and manually deleting these uploaded records (including the record causing issues)
* Re-sending the entire upload stream again (hopefully with no further issues).


+ I just submitted a logged QSO to eQSL.cc that was previously submitted back on January 21. eQSL.cc accepted the upload without complaint, and DXKeeper behaved as expected. Repeatedly resubmitting this QSO to eQSL.cc produced identical behavior.

+ So that I can see what's going on when you try this, please do the following:

1. on the General tab of DXKeeper's Configuration window, check the "Log debugging Info" box

2. terminate DXKeeper

3. start DXKeeper

4. replicate the misbehavior you report above

5. attach the errorlog.txt file from your DXKeeper folder to an email message, and send that message to me via

aa6yq (at) ambersoft.com

6. after you restart DXKeeper, on the General tab of DXKeeper's Configuration window, uncheck the "Log debugging Info" box

73,

Dave, AA6YQ

Join DXLab@groups.io to automatically receive all group messages.