Re: Apparent mode change misbehavior with Commander


Dave AA6YQ
 

+ AA6YQ comments below

I'm sorry, my report was poorly worded. I conflated the name of the mode on the radio, and in commander. My report was very confusing.

I created an errorlog for the below and have sent it by email as requested. Thank you sir!

Working Conditions:
Intel 'Hades Canyon' NUC. i7-8809G, 32G RAM.
Windows 10 Pro, 64 bit, OS build 19041.630
Radio: Icom IC-7610
Commander: 14.7.2
CAT via USB2 to radio, enumerated as COM3

The below was done from a fresh reboot. The only applications started are Launcher, and in turn Commander.

Replication:
Prior to starting Commander, radio is set to FM mode.
Start Commander
Observe FM on radio, FM in Commander
Using Commander, set mode to Data-U.
Observe USB-D1 on radio, Data-U in Commander Using radio, set mode RTTY
Observe RTTY on radio, RTTY in Commander Using Commander, set mode to Data-U
Observe RTTY on radio, Data-U in Commander Using Commander, set mode to FM
Observe FM on radio, FM in Commander
Using Commander change to Data-U
Observe USB-D1 on radio, Data-U in Commander.


+ Thanks for the errorlog, Jon, it exposed a latent defect of long standing:

"correctly change Icom transceiver's mode to a data mode from the Main window after the transceiver's mode was previously set to that same data mode from the Main window, and then set to a mode other than that same data mode from the radio's front panel."

+ I have corrected this defect in the next version of Commander, and sent it your way. Please let me know how it goes...

73,

Dave. AA6YQ

Join DXLab@groups.io to automatically receive all group messages.