vapor lock issue


Brett Wright
 

my 1947 Crosley CC with a replacement CI block has a stubborn tendency to vapor lock. It will do it after long climbs or even if I let it idle with the hood down for 15 minutes or so. It never does it cruising on the level. The cooling system has never boiled over but the gauge does move above normal or to about 3/4 range at least when it vapor locks. I know without a doubt the issue is vapor lock. I have done all of the following without changing the problem much.
1) changed the thermostat
2) recored the radiator with a much more efficient modern core(expensive)
3) rebuilt the water pump
4) installed a fuel pump shield and even wrapped that with aluminum foil for extra reflection
5) Verified the engine timing is spot on
6) doubled up on the isolation gasket between the fuel pump and the and the block
7) carburetor is rebuilt and adjusted properly
8) exhaust system is new from one end to the other
9) The radiator cap is original, I think, and is not a pressure cap

It has been suggested that I remove the square plates on the sides of the block to confirm there is not a sediment issue. I have not done that yet because the engine was recently rebuilt by others and hard to believe that was no cleaned. It is next on my list though. Engine runs good and has good power. I am open to any and all suggestions and wondering if this is a common problem? It is driving me nearly nuts. 
Brett

Join Crosley-Gang@groups.io to automatically receive all group messages.