Topics

Very low audio/hiss from uBitx speaker after Nextion 3.5 update #ubitx #nextion #v6 #ubitxv6


vu3gwn
 

Hi,

Trying to upgrade my uBitx v6 to a 3.5" Nextion display. 

1. Got the latest build from  https://github.com/phdlee/ubitx/releases/tag/v1.20 and updated the raduino.
2. Found a good build (I hope) for Nextion 3.5" enhanced which doesn't have the problem of small size. 
3. Flashed both raduino and the nextion display.
4. Since the Raduino's 7805 gets heated up too much, so connecting only the data to the Raduino board.
5. A separate power supply for Nextion providing 5v dc.
6. Display works perfectly and I am also able to see a signal line in the graph too...
7. Tx works fine and my external power meter shows a healthy 10w output.

But all I am hearing is a hiss and very low volume commercial radio near 40m.

If I flash back to uBitx v6 stock firmware and reattach the original display, the audio is coming perfect fine.

Any ideas on what the issue is and any resolution ?


Evan Hand
 

vu33gwn,
My first guess at your issue would be you have the wrong hex file loaded, or if you compiled from the source code that the #defaults are not set for the v5 (compatible with the v6).  I would suggest using Xloader and the file UBITXV5_CEC_V1.200_NX.hex from the uBITX_CEC_V1.200.zip archive on GitHub.

The second guess would be that you switched the Nano when you changed the firmware.  If you did, then the calibration data is still in the old Nano, and not transferred to the new one.  You will need to recalibrate the radio if you did swap the Nano.  The best way would be to use the video from Ashhar Farhan and the "yellow box" method to get the calibration settings.
https://www.youtube.com/watch?v=t6LGXhS4_O8

You get to the yellow box by pressing the encoder.  You will then need to set it into calibration mode by rotating the encoder until the set calibration selection comes up.  Press the encoder again.  The yellow box disappears, so you need to press the encoder again to bring it back up.  Now the Calibration and BFO tuning come up as options in the yellow box.  When you have the value set you press the PTT button, wait 10 seconds, and then power cycle the radio.  This ensures the values have been saved to the EEPROM in the Nano.

When doing the calibration be sure to do all three steps:
1 - Set the BFO to the lower edge of the 300 to 3000 Hz window so that you get the lowest tones to zero beat
2 - Adjust the frequency calibration
3 - Go back and adjust the BFO centering the plateau for the best audio level and alternate sideband suppression.

Once you have the rig calibrated I would recommend using the CEC Memory Manager to read the values from the uBITX and save them to a file.  Then you can reload the calibration values at a future date if you need to replace the Nano.  Memory Manager is available here:
https://github.com/phdlee/ubitx/releases/tag/v1.11

Note:  The calibration data is for the Raduino/Mainboard combination.  As long as the two are used together the calibration data is accurate with any Nano used.  You are adjusting the Si5351a clock reference (on the Raduino, NOT the Nano) and the BFO in relationship to the SSB filter on the mainboard. 

73
Evan
AC9TU


Vic WA4THR
 

The Nextion display will generate some noise, especially if the brightness is not on full bright. You might want to check that.


_Dave_ AD0B
 

My solution to a slight noise problem was to use a small toroid and wrap the 4 nextion leads through it.

I run a nextion 3.5 on my ubitx without additional regulator. Added in a heat sink to the existing 7805. Have not had a problem in the 2 years that it has been that way. 

Is your radio in a metal case?

Perhaps a high pass filter may be needed for BCB interference. 
--
73
Dave
ADOB
Raduino bracket and Ham_Made_Keys


vu3gwn
 

Thanks. I had not seen the menu options for Calibration in KD8CEC builds...And I had not set the code to V5...You were right now both counts...now trying to get the best possible voice...

Thanks !


vu3gwn
 

After trying out the steps, I think I have arrived at a good value for 40m which is 210000 and 110570500. But the problem is this setting completely makes the 20m sound bad. If I adjust 20m, then 40m goes for a toss. Never used to happen with plain vanilla Bitx...How to correct this with Kd8CEC....Can we store band specific calibration values ?

Thanks !


Evan Hand
 

vu3gwn,
I believe that your BFO is off.  It should be closer to 11,055,600.  You can have it set for the wrong sideband and when you swap between 20 and 40 meters you are changing sidebands.  The other thing to note is that the LSB setting in the Memory Manager should be 0.  Only the USB value should be used.

73
Evan
AC9TU


vu3gwn
 

Thanks Evan. You are spot on the side band change...still getting used to the new firmware. Just realised that in the morning. I will try with the 11055600 and see how it sounds too...yes, frequency calibration is only on USB and LSB is always zero.

Just want to get a good working backup from UMM.

Thanks again
73
Guru
VU3GWN