Topics

uBITX v6 to WSJT-X running on Raspberry Pi 3B - "Target VFO unaccessible.." #ubitxv6 #wsjt-x #raspberrypi3b


Stephen KO4CVU
 

This problem may be indirectly related to Aaron's situation. I am running WSTJ-X on a Raspberry Pi 3B. The firmware on the uBITX is Reed's R1.5.0. I have been very successful receiving without CAT control but now I'd like to transmit. I am reasonably sure that I finally found the correct identification for the USB serial port on the Pi that I have the cable from the uBITX plugged in to. I say this because the display on the uBITX flashes when I click on the "Test CAT" button from the Configuration>Radio window in the WSJT-X software. Using the FT-817 as the radio with default data bits, default stop bits and default Handshake as shown in Reed's v6 Manual ((R1.5.1), I get the error message "Rig Failure Hamlib error: Target VFO unaccessible while getting current frequency." I have tried various combinations of data bits and stop bits but continue to get the same message. I have also tried setting the radio choice to FT-857 and then I get "Rig failure Hamlib error: Protocol error while testing getting current VFO." I have tried various combinations of data bits and stop bits with this choice, too. I would appreciate any suggestions about what to try next.  Thanks, Stephen, KO4CVU
P.S. Fldigi works great running on the Pi, but that software can be configured to use the PTT circuit on the uBITX via the Nexus DR-X cross patch which I have mounted on top of the Pi.


Reed N
 

Hi Stephen,

What version of WSJT-X are you running?

I don't have a spare RPi free at the moment to see if it's a linux/windows difference. I would think that hamlib would behave the same regardless of the compilation target, but can't easily confirm at the moment...


Reed


Stephen KO4CVU
 

Reed,
WSJT-X is v2.2.2 0d9b96. 
Thanks,
Stephen


Ashhar Farhan
 

i loosely remember that the wsjtx folks fixed their software to work with ubitx. I don't recall more, can someone help?
- f

On Thu, Sep 3, 2020 at 11:47 AM Stephen KO4CVU <goinfishin1952@...> wrote:
Reed,
WSJT-X is v2.2.2 0d9b96. 
Thanks,
Stephen


Stephen KO4CVU
 

I happened to have downloaded WSJT-X to my Windows 10 laptop months ago. I connected it to the uBITX v6 this morning with only the USB cable since I do not have the audio dongle. WSJT-X will give me a GREEN indication on the Test button and it will control the frequency with the following configuration:
Radio: FT-817; Baud: 38400; Data bits: D; Stop bits: D; Handshake: D; DTR: High; RTS: Low; PTT: CAT; Port: USB; Xmit Audio: Front/Mic; Mode: USB; Split: None. Obviously, I had to determine what serial port to use by the method already described in another topic.
This version of WSJT-X is v2.1.2 0068f9 which appears to be an earlier version than the one I have running in Raspbian on the Raspberry Pi 3B. My next step is to check the WSJT-X website to see if there is a Windows version at the same revision level as the version I have on the Pi. I will report the results of further experiments that I am able to complete. Thanks, Stephen


Stephen KO4CVU
 

In a nutshell, the Windows version of WSJT-X v2.2.2 won't work with the FT-817 radio selection. BUT it will give me a GREEN indication on the the Test button with the FT-857 radio selected AND the configuration shown in the PDF that Evan attached to his message #80833. I can't vouch for the receive or transmit audio because I don't have the necessary cross patch or audio dongle to use with my laptop. v2.2.2 will certainly change the frequency for me, though!
Now, I am headed back to the Rasperry Pi ... more to follow. Thanks, Stephen


Stephen KO4CVU
 

No luck with the Raspberry Pi 3B and WSJT-X v2.2.2 It is possible that I am not getting something correct configuring v2.2.2 for the Pi or ...
Looks like I may be ordering a dongle for the laptop, now! I will let this conclude my recitation of sad adventures trying to WSPR with my Pi. Thanks, Stephen


Evan Hand
 

Stephen,
I have used my Raspberry Pi 4 to run the WSJT-X with the uBITX, so it is possible.  I will go back an dig up the details.  One thing I do remember is that you still need a separate dongle for it to work.  that is the same one I used for the Windows version.

It may take a couple of days to recreate what I did, as I have dismantled my Pi station (Using a Windows 10 laptop now).

73
Evan
AC9TU


Evan Hand
 

Did a quick search and found the following.  This may not be the actual web site that I used, however, it is one very similar.  
https://dl1gkk.com/setup-raspberry-pi-for-ham-radio/

The key things that need to be done are the installation of Flrig and Fldigi (I assume you already have the WSJT-X installed.  Those two allow connection to the uBITX.

Again, I will go back and setup my Pi station.
73
Evan
AC9TU


AndyH
 

Stephen,

   This is a problem with V2.2.2 of WSJT-X (possibly related to Hamlib 4.0) and I had the same challenge with my µBITX.  I dropped back to V2.2.0 and FT-817 control works perfectly.  As an alternative, supposedly we can stay with V2.2.2 and change the FT-817 to FT-857.  I've not yet tried that option.

    More here:  https://wsjtx.groups.io/g/main/topic/bug_hamlib_cat_rig_not/75122237?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,75122237

73, Andy, KG5RKP


On Wed, Sep 2, 2020 at 06:21 PM, Stephen KO4CVU wrote:
This problem may be indirectly related to Aaron's situation. I am running WSTJ-X on a Raspberry Pi 3B. The firmware on the uBITX is Reed's R1.5.0. I have been very successful receiving without CAT control but now I'd like to transmit. I am reasonably sure that I finally found the correct identification for the USB serial port on the Pi that I have the cable from the uBITX plugged in to. I say this because the display on the uBITX flashes when I click on the "Test CAT" button from the Configuration>Radio window in the WSJT-X software. Using the FT-817 as the radio with default data bits, default stop bits and default Handshake as shown in Reed's v6 Manual ((R1.5.1), I get the error message "Rig Failure Hamlib error: Target VFO unaccessible while getting current frequency." I have tried various combinations of data bits and stop bits but continue to get the same message. I have also tried setting the radio choice to FT-857 and then I get "Rig failure Hamlib error: Protocol error while testing getting current VFO." I have tried various combinations of data bits and stop bits with this choice, too. I would appreciate any suggestions about what to try next.  Thanks, Stephen, KO4CVU
P.S. Fldigi works great running on the Pi, but that software can be configured to use the PTT circuit on the uBITX via the Nexus DR-X cross patch which I have mounted on top of the Pi.


Ashhar Farhan
 

it is probably time to write a separate module for ubitx for hamlib. does anyone here know the hamlib folks?
- f

On Fri, Sep 4, 2020 at 5:33 AM AndyH <awhecker@...> wrote:
Stephen,

   This is a problem with V2.2.2 of WSJT-X (possibly related to Hamlib 4.0) and I had the same challenge with my µBITX.  I dropped back to V2.2.0 and FT-817 control works perfectly.  As an alternative, supposedly we can stay with V2.2.2 and change the FT-817 to FT-857.  I've not yet tried that option.

    More here:  https://wsjtx.groups.io/g/main/topic/bug_hamlib_cat_rig_not/75122237?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,75122237

73, Andy, KG5RKP

On Wed, Sep 2, 2020 at 06:21 PM, Stephen KO4CVU wrote:
This problem may be indirectly related to Aaron's situation. I am running WSTJ-X on a Raspberry Pi 3B. The firmware on the uBITX is Reed's R1.5.0. I have been very successful receiving without CAT control but now I'd like to transmit. I am reasonably sure that I finally found the correct identification for the USB serial port on the Pi that I have the cable from the uBITX plugged in to. I say this because the display on the uBITX flashes when I click on the "Test CAT" button from the Configuration>Radio window in the WSJT-X software. Using the FT-817 as the radio with default data bits, default stop bits and default Handshake as shown in Reed's v6 Manual ((R1.5.1), I get the error message "Rig Failure Hamlib error: Target VFO unaccessible while getting current frequency." I have tried various combinations of data bits and stop bits but continue to get the same message. I have also tried setting the radio choice to FT-857 and then I get "Rig failure Hamlib error: Protocol error while testing getting current VFO." I have tried various combinations of data bits and stop bits with this choice, too. I would appreciate any suggestions about what to try next.  Thanks, Stephen, KO4CVU
P.S. Fldigi works great running on the Pi, but that software can be configured to use the PTT circuit on the uBITX via the Nexus DR-X cross patch which I have mounted on top of the Pi.


Stephen KO4CVU
 

Andy,
As an epilogue to my story, I have been able to get WSJT-X v2.2.2 to work very nicely using the FT-857 radio selection. This evening, I received the USB External Stereo Sound Adapter (dongle) that Evan suggested. I connected it to my laptop and got both the audio and the CAT control working.  After the first 45 minutes of operation, I had reception reports of my transmissions from all over the continental U. S., Maui, Costa Rica, Iceland, Brazil, Norway, Scotland, the Canary Islands, Italy, and a club station at the German Antarctic Research Station. I am amazed at what this little uBITX v6 will do! Thank you, Evan and Reed for your help in getting me and my radio to this point ... and to Ashhar for coming up with this excellent radio.


Reed N
 

I don't feel like I helped all that much in this thread, but I'm glad you're on the air :)


Reed


Evan Hand
 

Stephen,
Congratulations on your achievements, and glad that I could be of some help.

Enjoy
73
Evan
AC9TU