Topics

UBitx 6 Code compulation errors

James Lawrie
 

Hello,

Haven't been here in a while... But I need help trying to compile the Original 6.1 Code and the updated 6.3.1 Update. I have downloaded both and installed correctly in Arduino 1.8.12 but when I go to compile not upload both versions error out. I receive the following error on original:

 nano_gui.cpp:292:11: error: invalid conversion from 'const GFXfont*' to 'GFXfont*' [-fpermissive]
   gfxFont = &ubitx_font;
           ^
"C:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\arduino\\tools\\avr-gcc\\4.9.2-atmel3.5.3-arduino2/bin/avr-g++" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10812 -DARDUINO_AVR_ELEKTOR_UNO_R4 -DARDUINO_ARCH_AVR "-IC:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\Elektor-Uno-R4-for-Arduino-1.8.x\\hardware\\avr\\1.0.0\\cores\\arduino" "-IC:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\Elektor-Uno-R4-for-Arduino-1.8.x\\hardware\\avr\\1.0.0\\variants\\R4" "-IC:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\Elektor-Uno-R4-for-Arduino-1.8.x\\hardware\\avr\\1.0.0\\libraries\\Wire" "-IC:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\Elektor-Uno-R4-for-Arduino-1.8.x\\hardware\\avr\\1.0.0\\libraries\\EEPROM\\src" "-IC:\\Users\\lawri\\AppData\\Local\\Arduino15\\packages\\Elektor-Uno-R4-for-Arduino-1.8.x\\hardware\\avr\\1.0.0\\libraries\\SPI" "C:\\Users\\lawri\\AppData\\Local\\Temp\\arduino_build_671872\\sketch\\ubitx_v6.1_code.ino.cpp" -o "C:\\Users\\lawri\\AppData\\Local\\Temp\\arduino_build_671872\\sketch\\ubitx_v6.1_code.ino.cpp.o"
Using library Wire at version 1.0 in folder: C:\Users\lawri\AppData\Local\Arduino15\packages\Elektor-Uno-R4-for-Arduino-1.8.x\hardware\avr\1.0.0\libraries\Wire
Using library EEPROM at version 2.0 in folder: C:\Users\lawri\AppData\Local\Arduino15\packages\Elektor-Uno-R4-for-Arduino-1.8.x\hardware\avr\1.0.0\libraries\EEPROM
Using library SPI at version 1.0 in folder: C:\Users\lawri\AppData\Local\Arduino15\packages\Elektor-Uno-R4-for-Arduino-1.8.x\hardware\avr\1.0.0\libraries\SPI
exit status 1
invalid conversion from 'const GFXfont*' to 'GFXfont*' [-fpermissive]

This happens on several different types of UNO, Uno Nano, UNO, Elektor UNO R4....

Any Ideas? I should be able to verify code without uploading. The GFXfont and reference to SPI and EEPROM show up in both versions of code. As stated before I have tried more than just the UNO Nano clone board with same results.

If you can please help or have had same issues please let me know, the UNO Clone I used was from another working Radino board. I still have original and don't want to flash it until this bug is fixed.

Thanks,

Jim

Reed N
 

Hi Jim,

Looks like a simple fix. Change the indicated line to read:

gfxFont = (GFXfont*)&ubitx_font;



Reed

James Lawrie
 

I’ll give that a try tonight, I tried my had at troubleshooting but my programming skills went the way of the dodo, thanks.

jim