Topics

T/R Relay sticking!

chuckr@hostu.org
 

Hi all, whats your thoughts, while using wsjt-x for ft8 I have been noticing a peroid of not receive data on the water fall, until I click the tune button on and off. Then all works as it should. Noticed that when it is sticking (?) the sound of the relay un keying is real faint or quieter than normal. I beleive this is pointing to at sticky relay. This is a un moded V5 board and has been working flawlessy for several months of FT8 untill lately.  Is there any know quick/easy fix (often not worth it in the long term) or just replace it with the same brand and model number or one of the brand names that has been used for the low pass relay replacements ( something start with ax I think. So whats your thoughts, recomendations or other help or support,,, and many thanks for all on this group.
73
chuck

chuckr@hostu.org
 

I really could use a good reference for a long lasting replacement relay for the uBitix transimit/receive relay, what say you ?

 

Hi Chuck,

Has anyone measured the current that this relay is switching?  I wonder if it is exceeding the specification for these small relays which I think is normally 2A max.

In general though, I would expect a top brand relay would last longer.  Maybe you could try an Omron G5V-2 series relay. 

73,


Mark.

Evan Hand
 

The total for the board is less than 3 amps, and the PA is not switched.  There is not more than 500 ma being switched by the main T/R relay K1. K3 is handling the antenna switching between the PA and the receive front end.  That could have high RF induced currents that would be difficult to measure.  The other band switching relays are also handling the RF power.

With the above, we need to know which relay is sticking.

There is one other possibility, that is RF feedback into the rig causing the Nano to sense that a key is pressed. I had this issue with an off center fed dipole feeding back into the rig and causing it to lock up.  Have there been any changes to the shack right before the relay started sticking?  

Above are just some ideas.  Please take with a grain of salt and research before using.
73
Evan
AC9TU

albert@...
 

I have a Rev 5 board running stock 5.1 version software/firmware.
I am having a similar issue with the mic PTT.

Using a 50 ohm dummy load, radio works as expected.

Using an antenna, I have intermittent issues with the radio staying in transmit when using the Mic. No issues using a manual key, or paddle.
The radio is connected to an antenna tuner and SWR is 1:1.
I also notice the display will change to the menu selection "Band Select" when the failure occurs. (I have not touched the knob.)
Monitoring the PTT line (Orange Wire of RADUINO), it toggles with the PTT button, in failure mode as well as normal operation.

Monitoring the collector of Q15 proves interesting results.
With my voltmeter on the collector, I can't get it to fail. It toggles from 13.65 volts to ground. Which is what I would expect.
The voltmeter is a digital high impedance type.
The connection of my voltmeter appears to adds enough capacitance/inductance to prevent the problem.
I have noticed that, if the radio sticks in transmit, touching the collector after the failure has occurred, WILL NOT correct the issue. I must do a power-cycle to correct it.

I operate the radio on 13.8 volts input. I have tried lowering the supply voltage to 12.6 but it made no difference, still fails.

Will continue more testing in the morning.

Albert

Evan Hand
 

Albert,

The problem you describe is what I had with an off center fed dipole. For me it was rf getting into the nano control lines. I was able to solve with grounding and rf chokes on the antenna coax and mic/ptt cable.  I also cleaned up the wiring and installed some small snap on ferrites on the digital lines to the Raduino.

The above solved it for me.

73
Evan
AC9TU