Topics

Si5351 weirdness

Ashhar Farhan
 

Hans and the group,
This is going to be fun. Today, I was fooling around with the Antuino and suddenly, it wouldn't read the return loss. I checked the driving signal. It was on, but off by about 200 khz. Naturally, the measurement receiver wouldnt pick it up.
I added serial.print into thr source code. Everything seemed to be perfect. Finally on a dare, I probed the crystal, it was at 27.2 mhz! I resoldered, etc. After a few minutes, it jumped back to its standard 27 mhz frequency.
I have never seen anything like this on the si5351. Spurious crystal modes are not uncommon. Anyone else has experienced this too?
- f

 

I've seen this and its always the capacitor!

Raj

At 15/06/2020, you wrote:
Hans and the group,
This is going to be fun. Today, I was fooling around with the Antuino and suddenly, it wouldn't read the return loss. I checked the driving signal. It was on, but off by about 200 khz. Naturally, the measurement receiver wouldnt pick it up.
I added serial.print into thr source code. Everything seemed to be perfect. Finally on a dare, I probed the crystal, it was at 27.2 mhz! I resoldered, etc. After a few minutes, it jumped back to its standard 27 mhz frequency.
I have never seen anything like this on the si5351. Spurious crystal modes are not uncommon. Anyone else has experienced this too?
- f

Jhard356@...
 

When my Bitx V6 arrived it had the out put transistors mounted so that the bottom of the heat sink was 5/8 of a inch off of the mother board. I was always told to keep these leads as short as possible. Did anyone else have theirs mounted high like this?

Ashhar Farhan
 

heatsink? i was complaining about the antuino. it doesn't have a heatsink.


On Mon, Jun 15, 2020 at 8:44 PM <Jhard356@...> wrote:
When my Bitx V6 arrived it had the out put transistors mounted so that the bottom of the heat sink was 5/8 of a inch off of the mother board. I was always told to keep these leads as short as possible. Did anyone else have theirs mounted high like this?