Odd Problem with new v6 - Shorted RXD/TXD pins on Raduino


I got a new v6 kit with the enclosure this past weekend.
My daughter helped put it together.  With the COVID-19
stuff going on, everyone's working from home and has
staked out their territories leaving the bed the only
relatively uncluttered spot to work.

Put it all together and it was good as-was, so I decided to start
messing with it.

First up was loading Reed's code.  (Thanks for your help Reed!)
It wouldn't load.
I tried another nano I had on hand, no go.  It had the pins in the right way.
I ordered got some more Sunday and tried again.

Then I tried loading with the nano pulled from the radio.
It worked.  The original did too.   Oh well, it's good to have spares.
Put it back together and it works, but I can't load with the nano in the raduino board.
I tried CAT too, no luck.

"in the raduino board" kept bouncing around in my head, so
I removed it (not my head).  There was some crusty film on the PCB.
I measured a short between RXD & TXD, so I did some cleaning/poking/scraping
and cleared the short and tried a fresh nano.
The short may have damaged the previous two.  I'll check them out another time.

I can now upload now and CAT works with FT-817 Commander,
but not yet with WSJT-X which is giving the following error:


I'll take it to work to check the spectrum on the good SA this week.

Next is an AGC circuit from Kit-Projects and then maybe try the Teensy.