Topics

Nextion 5" display noise #ubitx #nextion #noise

Justin Phillips K5AXL
 

I have a v5 uBITX in Sunil's 5" case with audio amp kit. Audio sounds just fine until I power the Nextion display. It's got a terrible buzz, and you can hear digital noises when the display changes, or when you turn the encoder. 

I've run separate power for the display and the noise remains. I Also tried powering the display with a battery pack, the noise is just as bad. How do you get this noise out? 

Also, my audio (when not influenced by the display) sounds very tinny and a bit high pitch, and it doesn't seem to change when adjusting the BFO much at all.. any ideas?

Justin Phillips K5AXL
 

So, what has two thumbs and is a huge doomarse? <- this guy.

I was on LSB but adjusting the USB setting. 95% of the display noise is gone now.

Mike Kilpatrick
 

My long lost twin brother !

 

 

From: Justin Phillips K5AXL
Sent: Monday, November 11, 2019 16:38
To: BITX20@groups.io
Subject: Re: [BITX20] Nextion 5" display noise #ubitx #nextion #noise

 

So, what has two thumbs and is a huge doomarse? <- this guy.

I was on LSB but adjusting the USB setting. 95% of the display noise is gone now.

 

MVS Sarma
 

I had simar issue even wirh 2.8 nextion.

 I placed a 2uH inductor in series with 5v line goingbto nextion and a decoupling capacitor of 100uF16v at the nextion side to ground.  

That has reasonably reduced the rumbling noise created after introduction of Nextion display.  Hope it helps.

Sarma vu3zmv




On Mon, 11 Nov 2019, 9:54 am Justin Phillips K5AXL, <dolmdemon@...> wrote:
I have a v5 uBITX in Sunil's 5" case with audio amp kit. Audio sounds just fine until I power the Nextion display. It's got a terrible buzz, and you can hear digital noises when the display changes, or when you turn the encoder. 

I've run separate power for the display and the noise remains. I Also tried powering the display with a battery pack, the noise is just as bad. How do you get this noise out? 

Also, my audio (when not influenced by the display) sounds very tinny and a bit high pitch, and it doesn't seem to change when adjusting the BFO much at all.. any ideas?

Philip
 

Try swapping the Black, and Brown wires on the Volume control.
Black to the wiper, and Brown to the hot end. Sunil's instructions are incorrect.

Philip G7JUR

_Dave_ K0MBT
 

I was able to abate noise by wrapping the 4 wires through a small toroid. 
--
73
Dave
k0mbt
Raduino bracket and Ham_Made_Keys

MVS Sarma
 

That is interesting   Dave. Thanks. 
Sarma vu3zmv

On Sat, 16 Nov 2019, 5:22 am _Dave_ K0MBT, <davesters@...> wrote:
I was able to abate noise by wrapping the 4 wires through a small toroid. 
--
73
Dave
k0mbt
Raduino bracket and Ham_Made_Keys