Topics

Help Request Please with Nextion 2.8 Display


Mick
 

Please can you assist with my Nextion display upgrade, as I'm not sure how to proceed?

 

My ubitx v6 arrived about a week ago and was fine on completion with accurate frequency. Very impressed.

Yesterday I upgraded to a 2.8" Nextion display following KD8CEC instructions to the letter.

The upload of Ian's Version 1.2 firmware to the ubitx V6 went perfectly.  Receive works fine, not tried Tx yet.

 

My replacement display is a Nextion 2.8" Enhanced No. NX3224K028 purchased from Amazon UK.

It says NEXTION HMI SOLUTION on the box.

 

I am thinking that I may have loaded the wrong firmware for the display.  See issues listed below.

I am currently using ..        ubitx_28_E.tft    which loads successfully to my 32GB Micro SD card (Formatted FAT32)
The display then loads the firmware fine from the Micro SD Card, then I remove the card as per instructions.

 

I have tried using ..       ubitx_28_E.HMI       which seems to me to be the correct file?

However, this does not work - the display shows ..          Baud: 9600  SD Card Update ...  No Find File

 

The current issues are using    ubitx_28_E.tft    are as follows  ...

Frequency Display works fine with tuning and is accurate and spot on with my Yaesu FT-897, but I'm stuck on the 80m band

If I hold Touch on any of the top row of buttons (apart from Mode), they change to Orange but nothing happens

Mode Button text is Orange all the time and I can bring up the modes, but cannot change them

I can bring up the Control Menu, but can only adjust LCD brightness, which works

I can adjust CW settings, but Save and Reboot does not work.

The Home button gets me back OK, but CW settings unchanged, still showing default settings

SPL, RIT and ATT buttons do not work either or change colour

 

The display shows +v1.200, which I think is correct

The IFS Button works and I can slide the Orange block to adjust.

So very little is working apart from the tuning.

 

Advice welcomed please.  My Arduino knowledge is somewhat limited, although I have successfully built the K3NG Keyer on a breadboard.

 

Many thanks in advance.

73  Mick M0GWD



Mick
 

Mick,

Attached are the files I used

Ubitx_28.tft (the 1,922 kb size v3)

UBITXV5_CEC_V1.200_NX.hex

Hope this helps

73

Mick (also) VA3EPM

 

From: BITX20@groups.io <BITX20@groups.io> On Behalf Of Mick
Sent: Tuesday, October 20, 2020 6:11 AM
To: BITX20@groups.io
Subject: [BITX20] Help Request Please with Nextion 2.8 Display

 

Please can you assist with my Nextion display upgrade, as I'm not sure how to proceed?

 

My ubitx v6 arrived about a week ago and was fine on completion with accurate frequency. Very impressed.

Yesterday I upgraded to a 2.8" Nextion display following KD8CEC instructions to the letter.

The upload of Ian's Version 1.2 firmware to the ubitx V6 went perfectly.  Receive works fine, not tried Tx yet.

 

My replacement display is a Nextion 2.8" Enhanced No. NX3224K028 purchased from Amazon UK.

It says NEXTION HMI SOLUTION on the box.

 

I am thinking that I may have loaded the wrong firmware for the display.  See issues listed below.

I am currently using ..        ubitx_28_E.tft    which loads successfully to my 32GB Micro SD card (Formatted FAT32)
The display then loads the firmware fine from the Micro SD Card, then I remove the card as per instructions.

 

I have tried using ..       ubitx_28_E.HMI       which seems to me to be the correct file?

However, this does not work - the display shows ..          Baud: 9600  SD Card Update ...  No Find File

 

The current issues are using    ubitx_28_E.tft    are as follows  ...

Frequency Display works fine with tuning and is accurate and spot on with my Yaesu FT-897, but I'm stuck on the 80m band

If I hold Touch on any of the top row of buttons (apart from Mode), they change to Orange but nothing happens

Mode Button text is Orange all the time and I can bring up the modes, but cannot change them

I can bring up the Control Menu, but can only adjust LCD brightness, which works

I can adjust CW settings, but Save and Reboot does not work.

The Home button gets me back OK, but CW settings unchanged, still showing default settings

SPL, RIT and ATT buttons do not work either or change colour

 

The display shows +v1.200, which I think is correct

The IFS Button works and I can slide the Orange block to adjust.

So very little is working apart from the tuning.

 

Advice welcomed please.  My Arduino knowledge is somewhat limited, although I have successfully built the K3NG Keyer on a breadboard.

 

Many thanks in advance.

73  Mick M0GWD


--
 

73
Mick VA3EPM 


Evan Hand
 

On Tue, Oct 20, 2020 at 06:25 AM, Mick wrote:
Attached are the files I used
Mick,
Per the KD8CEC naming convention, that .tft file is for the basic version of the Nextion.  The correct version for an enhanced display is ubitx_28_E.tft.  The .hmi file is the source code to be used with the Nextion editor.  One point on that, the newest version of the editor does not compile to a small enough size to fit into the Nextion displays.  You need to use the LTS version that is available on the site.

The Nano .hex file is the same for all versions of the Nextion display.

Try this file and see if that helps. 

73
Evan
AC9TU


Mick
 

Hello Mick

Thanks for the prompt reply.
As it's an Enhanced display it won't accept the file ubitx_28.tft, it needs to be this one ubitx_28_E.tft  for a successful upload.
I did discover though that I had loaded into the ubitx     UBITXV5_CEC_V1.200_NX_S.hex.
Your file that you attached is missing the _S, so I tried that, but unfortunately still exactly the same issues.

I'm sure I'll get there.

Thanks Mick       73  Mick M0GWD

On 20/10/2020 12:25, Mick wrote:

Mick,

Attached are the files I used

Ubitx_28.tft (the 1,922 kb size v3)

UBITXV5_CEC_V1.200_NX.hex

Hope this helps

73

Mick (also) VA3EPM

 

From: BITX20@groups.io <BITX20@groups.io> On Behalf Of Mick
Sent: Tuesday, October 20, 2020 6:11 AM
To: BITX20@groups.io
Subject: [BITX20] Help Request Please with Nextion 2.8 Display

 

Please can you assist with my Nextion display upgrade, as I'm not sure how to proceed?

 

My ubitx v6 arrived about a week ago and was fine on completion with accurate frequency. Very impressed.

Yesterday I upgraded to a 2.8" Nextion display following KD8CEC instructions to the letter.

The upload of Ian's Version 1.2 firmware to the ubitx V6 went perfectly.  Receive works fine, not tried Tx yet.

 

My replacement display is a Nextion 2.8" Enhanced No. NX3224K028 purchased from Amazon UK.

It says NEXTION HMI SOLUTION on the box.

 

I am thinking that I may have loaded the wrong firmware for the display.  See issues listed below.

I am currently using ..        ubitx_28_E.tft    which loads successfully to my 32GB Micro SD card (Formatted FAT32)
The display then loads the firmware fine from the Micro SD Card, then I remove the card as per instructions.

 

I have tried using ..       ubitx_28_E.HMI       which seems to me to be the correct file?

However, this does not work - the display shows ..          Baud: 9600  SD Card Update ...  No Find File

 

The current issues are using    ubitx_28_E.tft    are as follows  ...

Frequency Display works fine with tuning and is accurate and spot on with my Yaesu FT-897, but I'm stuck on the 80m band

If I hold Touch on any of the top row of buttons (apart from Mode), they change to Orange but nothing happens

Mode Button text is Orange all the time and I can bring up the modes, but cannot change them

I can bring up the Control Menu, but can only adjust LCD brightness, which works

I can adjust CW settings, but Save and Reboot does not work.

The Home button gets me back OK, but CW settings unchanged, still showing default settings

SPL, RIT and ATT buttons do not work either or change colour

 

The display shows +v1.200, which I think is correct

The IFS Button works and I can slide the Orange block to adjust.

So very little is working apart from the tuning.

 

Advice welcomed please.  My Arduino knowledge is somewhat limited, although I have successfully built the K3NG Keyer on a breadboard.

 

Many thanks in advance.

73  Mick M0GWD


--
 

73
Mick VA3EPM 



Virus-free. www.avast.com


Mick
 

Thanks Evan

I did have ubitx_28_E.tft already installed, but I reformatted the card, again to FAT32 and installed your matching file just in case.
No change unfortunately.
Not sure what to look at next, having installed what I believe to be the correct firmware for both ubitx v6 and the Nextion?
It's very odd.

73

Mick M0GWD


Evan Hand
 

At this point the only thing that I ca think of is an issue with the Nextion. You are getting data from the Nano as the frequency changes as you change the encoder. The fact that you can adjust the display and other controls means the touch input is working. Only thing left would be an internal problem.  Maybe there is a wiring problem, through I doubt it. 

Can you return and order another one?

73
Evan
AC9TU


Mick
 

Hi Even,
that's interesting, because I know I used the ubitx_28.tft file (From the version 3 zip file) with a Nextion 28 HMI LCD  touch display and it works fine. Maybe my nextion is not the enhanced version.
--
 

73
Mick VA3EPM 


Mick
 

Mick (M0GWD), Evan,
Is it possible your nextion is a basic version?
--
 

73
Mick VA3EPM 


Mick
 

Hello Evan and Mick and first many thanks for your support.

Evan your final comment on wiring made me check it again after checking several times anyway.
I have found and corrected the problem and now all works well.

For the 4 x connections from the Nextion Display to the Nano Board, I was following the pictures in the Barbaros WB2CBA article.
The connections are at 1, 2, 5 and 11 on a 14-pin header strip.
As per Barbaros recommendation, I used a right-angle male-to-male header, broken off a 40-strip to match the header on the Nano board.
Connecting the 4 wires to this right-angled header, for pins 1, 2 and 5 I counted from one end, and for pin 11, I counted back 4 from the other end,
That would have been fine if my angled header strip had 14 pins, but mine has 15 pins.
The header strip on the Nano board, on closer inspection, has nearly 15 female sockets.  It has just been badly snapped off.
I had snapped off my angled header to match it at 15 pins, so counting back four, I was connecting the Blue wire to pin 12, not 11.
I put it on Pin 11, switched the radio on it and works fine.  Something for others to watch out for also.

Many many thanks for your great support.
By the way Evan the date for returning my Nextion to Amazon UK was yesterday!

All the best from the UK

73

Mick M0GWD


Evan Hand
 

Good News!

Have fun with the new display.  I find it much easier to use then the 1602 display that came with the v5 kits.

73
Evan
AC9TU


Ted
 

"Connecting the 4 wires to this right-angled header, for pins 1, 2 and 5 I counted from one end, and for pin 11, I counted back 4 from the other end, That would have been fine if my angled header strip had 14 pins, but mine has 15 pins."


Hi, Mick.

That's a good catch and easily missed.  I'm glad that you didn't inadvertently let the magic smoke out of the Raduino or the screen as some of us are good at doing. 

How is the rest of the build going for you? Have you had it on the air as yet? 



Ted
K3RTA


Mick
 

Hello Evan

Yes good news and all is well.
My approach could have been better.
If I had snapped off my right-angle header strip to 14-pins to start with, the extraneous piece of plastic on the female header on the Nano board would have been obvious.  You live and learn.

I intend making a new front panel for the ubitx case so that the Nextion display is a nice fit.
It's a great kit and I'm really pleased with it.

Thanks Evan, all the best

Mick M0GWD


On 21/10/2020 00:43, Evan Hand wrote:
Good News!

Have fun with the new display.  I find it much easier to use then the 1602 display that came with the v5 kits.

73
Evan
AC9TU


Virus-free. www.avast.com


Mick
 

Hello Ted

Yes no smoke luckily and as described in my reply to Evan, my approach could have been better.
The build went fine and I had fully completed the kit and was using it on receive with the original display.
I had ordered the Nextion display when I ordered the kit from India, so I was keen to install it once I knew that I had a successful build.
No not on the air with it yet Ted.
I need to make a new front panel for the existing case and install the Kit-Projects AGC kit, which has now also arrived.

All the best Ted

73

Mick M0GWD

On 21/10/2020 01:27, Ted via groups.io wrote:
"Connecting the 4 wires to this right-angled header, for pins 1, 2 and 5 I counted from one end, and for pin 11, I counted back 4 from the other end, That would have been fine if my angled header strip had 14 pins, but mine has 15 pins."


Hi, Mick.

That's a good catch and easily missed.  I'm glad that you didn't inadvertently let the magic smoke out of the Raduino or the screen as some of us are good at doing. 

How is the rest of the build going for you? Have you had it on the air as yet? 



Ted
K3RTA


Virus-free. www.avast.com