Topics

BITX V6.1 TRANSMIT RECIEVE RELAY SWITCH NOT WORKING IN LSB USB


LAKSH MUTHU
 

HI,  Good Day all.
 I am using bitx v6.1. Yesterday, when I connected a new electret mic with  a preamplifier (using 2N3904), temporarily wiried in a multipurpose board, the rig worked O.K. But when I made the wirings for mic with preamp in a suitable PCB and connected it with the rig, on pressing PTT of the mic,in the LSB/USB mode the rig does not switch to TX. It  remains in RX position itself. But on CW mode, pressing CW key (Straight key), it transmits and I am able to establish contact.
   In brief, presently, on pressing PTT the rig dosnot go to TX position in LSB/USB.
 I request valuable suggestions/guidances.
Thanks in advance.
73
Muthu
VU2LMN
+919443114779


Evan Hand
 

Muthu,
Since the setup worked before, I would suggest that you check the wiring of the PTT switch.  Transmit is turned on through the mic PTT by grounding the switch grounding ring of the 3.5mm plug to the shield.  I would suspect that the ground is not connected to the PTT switch.

73
Evan
AC9TU


LAKSH MUTHU
 

Dear Evan,
     Thank u vy much. I will check it up and revert back.
73
Muthu
VU2LMN
+919443114779


LAKSH MUTHU
 

Dear Evan and all,
     Good day. I checked the PTT connection in the Mic  by checking for continuity between the ring and sleeve of the TRS plug. When PTT is pressed, there is continuity(of course between ring and sleeve of TRS plug) and when PTT is released no continuity. Also I checked and confirmed that there is proper connection between the earth point of mic socket and the chassis earth.But the problem persists. I don't know how to find out the fault,
    Valuable guidance will be highly appreciated.
  With regards and 73
               MUTHU
              VU2LMN


LAKSH MUTHU
 

Dear Evan and All,
       Good day. After checking the PTT connections etc; as described in message No 80969, as the problem of no Transmit in LSB persists (but transmits in CW), I purchased a new Nano inserted in the Raduino and tried  by uploading REED's software. The problem of TX/RX relay in LSB/USB mode is  solved, but the touch screen of the display fails to respond. Also, all the BFO settings previously done have disappeared. These settings cannot be done now because, the touch function of the display is not working.
      I request valuable guidance from the group.
Thanks in advance.
MUTHU
VU2LMN


Evan Hand
 

MUTHU,

I do not have a v6 uBITX, so cannot help with your current issue other than to comment that I have read that holding in the encoder while powering on the radio will put it into touch screen calibration mode.  You might want to try that.

I have also read that turning the encoder will change between the buttons on the display after you press the encoder.  A second press of the encoder will select that function.

The calibration settings are stored in the EEPROM of the Nano that is not transferred with a program change.

Hopefully, someone else with actual hands-on experience or Reed will address your issue better.
73
Evan
AC9TU


Reed N
 

Hi Muthu,

The calibrations for the radio should be identical between my software version and Ashhar's v6.1. I'm not sure why you would have a working setup on his software but not mine.

There are a couple ways to calibrate the touch screen. One way is to hold down the tuner button before turning the radio on. This method will force you to also do frequency and BFO calibrations.

The second way is to turn on the radio, briefly press the tuner button, rotate the tuner knob until the gear icon is outlined in white, then press the tuner knob button. Repeat the knob turning and button pressing to get to the calibration, then touch screen calibration setting.


Reed


LAKSH MUTHU
 

Dear All,
    Good Day. In continuation of my above message No. 81273, I am glad to inform the group that the problem has been solved now. I have done the required calibration on the touch screen available in the Settings Menu. After carrying out this, the touch screen started working and the Transmission also works in LSB/USB mode.
    Really UBITX is a wonderful gear to learn a lot.What we have learnt is tiny and what we have yet to learn is to a size even greater than the globe. UBITX and this group  offer good opportunities to learn.
Regards and 73
MUTHU
VU2LMN


LAKSH MUTHU
 

DEAR REED,  EVAN, and the group,
       Good day. Thank you very much for your kind helps. Now I have solved the issue and uploaded REED software. The rig is working now.
   Thanks a lot for all guidance from the group and especially Reed and Evan.
Regard and 73
MUTHU
VU2LMN