Topics

Accidental Calibrate #ubitx #calibration

EI_Frank
 

Help.
I've just assembled my uBitx into the enclosure and powered it up with no problems. The audio quality was excellent on receive. I was scrolling thru the Settings about to set the BFO and accidentally clicked on the Calibrate mode, it went straight into a note, ("Tune to exactly 10Mhz") I turned the Encoder and pushed the button to try and get out of the mode. Since this disaster my excellent audio quality has deteriorated into a squeaky garbled nightmare.
How can I fix this and restore my uBitx to its former glory.??

EI_Frank
 

Hi Guys, just a short update on my Tune-up problems.
It seems that the main issue I have here is that the instructions provided by HF Signals do not align with the actual menu on the uBitx.
Part 2 of the Tune-Up instructions are for aligning the Master Clock. It advises to go to an AM broadcast signal of known frequency. If NOT zero beat then click on encoder button again  and a new option "Set Calibration" will be displayed. This is a photo of what's displayed.


When I click to enter this option it does not give me the option of adjusting to Zero Beat, but instructs me to go to Exactly 10Mhz. per the photo here.
When I press the PTT, it TX's on 10Mhz and displays this on LCD.
When I rotate the encoder it increments the 0 digit on the top right corner. But its a blind adjustment, no feedback on adjustment until you back out of the Calibration and back to a known frequency.
It is not possible to realistically and accurately adjust the clock with this method. 
What am I missing? This is extremely frustrating. 

 

Frank,

You have inadvertently entered the Calibration Twilight Zone. I did the same thing 4 days ago and I only yesterday was able to escape. Here's what I had to do, first upgrade to KD8CEC's firmware 1.08 or later, then download version 1.04 of KD8CEC's uBitx Memory Manager and install it. Then follow this thread,  https://groups.io/g/BITX20/topic/kd8cec_firmware_and_basic/16637851?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,16637851 and load the defaults mentioned there which will allow you to get control of your uBitx again, then using the memory manager continue to tweak your settings until you get it right on. I know it sounds daunting, but that's what I had to do to get back into the land of the living. As far as I'm concerned, the stock calibration procedure should be removed from the base firmware as it does more harm than good.

Joel
N6ALT

 

Frank,

For what it's worth, here is my struggle thread. https://groups.io/g/BITX20/topic/the_dreaded_lsb_and_usb_swap/23816435?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,20,23816435
Maybe you can glean some more info out of it.

Joel
N6ALT

EI_Frank
 

Hi Joel,
Many thanks for sharing your frustration and the eventual solution.
You are a gentleman.
I shall try your solution in the hope of getting out of this Calibration Maze.
I agree with your assessment of the Stock Firmware, Tune-up instructions are not much better and don't agree with the actual firmware on board the uBitx.
This is a great little rig which has great potential, but lots of unnecessary grief in the Tune-Up.
Many thanks again.

73,

Frank 
EI8HIB


On Sat, Jul 28, 2018 at 5:27 PM, Joel Caulkins <caulktel@...> wrote:
Frank,

You have inadvertently entered the Calibration Twilight Zone. I did the same thing 4 days ago and I only yesterday was able to escape. Here's what I had to do, first upgrade to KD8CEC's firmware 1.08 or later, then download version 1.04 of KD8CEC's uBitx Memory Manager and install it. Then follow this thread,  https://groups.io/g/BITX20/topic/kd8cec_firmware_and_basic/16637851?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,16637851 and load the defaults mentioned there which will allow you to get control of your uBitx again, then using the memory manager continue to tweak your settings until you get it right on. I know it sounds daunting, but that's what I had to do to get back into the land of the living. As far as I'm concerned, the stock calibration procedure should be removed from the base firmware as it does more harm than good.

Joel
N6ALT


m5fra2@...
 

Thanks Frank, also been there but getting out of it!

 

Colin – M5FRA

 

From: BITX20@groups.io <BITX20@groups.io> On Behalf Of Joel Caulkins
Sent: 28 July 2018 17:27
To: BITX20@groups.io
Subject: Re: [BITX20] Accidental Calibrate #ubitx #calibration

 

Frank,

You have inadvertently entered the Calibration Twilight Zone. I did the same thing 4 days ago and I only yesterday was able to escape. Here's what I had to do, first upgrade to KD8CEC's firmware 1.08 or later, then download version 1.04 of KD8CEC's uBitx Memory Manager and install it. Then follow this thread,  https://groups.io/g/BITX20/topic/kd8cec_firmware_and_basic/16637851?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,16637851 and load the defaults mentioned there which will allow you to get control of your uBitx again, then using the memory manager continue to tweak your settings until you get it right on. I know it sounds daunting, but that's what I had to do to get back into the land of the living. As far as I'm concerned, the stock calibration procedure should be removed from the base firmware as it does more harm than good.

Joel
N6ALT


Virus-free. www.avast.com

m5fra2@...
 

Sorry… thanks Joel!!

 

 

From: BITX20@groups.io <BITX20@groups.io> On Behalf Of Joel Caulkins
Sent: 28 July 2018 17:27
To: BITX20@groups.io
Subject: Re: [BITX20] Accidental Calibrate #ubitx #calibration

 

Frank,

You have inadvertently entered the Calibration Twilight Zone. I did the same thing 4 days ago and I only yesterday was able to escape. Here's what I had to do, first upgrade to KD8CEC's firmware 1.08 or later, then download version 1.04 of KD8CEC's uBitx Memory Manager and install it. Then follow this thread,  https://groups.io/g/BITX20/topic/kd8cec_firmware_and_basic/16637851?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,16637851 and load the defaults mentioned there which will allow you to get control of your uBitx again, then using the memory manager continue to tweak your settings until you get it right on. I know it sounds daunting, but that's what I had to do to get back into the land of the living. As far as I'm concerned, the stock calibration procedure should be removed from the base firmware as it does more harm than good.

Joel
N6ALT


Virus-free. www.avast.com

Ion Petroianu, VA3NOI
 

You are missing a second, calibrated receiver on which you should be able to listen for zero beat.
Try uploading Ian's firmware ( www.hamskey.com ) and you will do zero beat on your uBitx receiver using the UT beacon you can receive in your area (5, 10, or 15 MHz).
To use Ian's firmware you do not need to do any hardware modifications and you will see lots of improvements.
73,
Ion
VA3NOI

--
Ion

VA3NOI

Christopher Miller
 

This was my advice 

 

Amen

 

David A Posthuma, WD8PUO

 

From: BITX20@groups.io <BITX20@groups.io> On Behalf Of EI_Frank
Sent: Saturday, July 28, 2018 11:07 AM
To: BITX20@groups.io
Subject: Re: [BITX20] Accidental Calibrate #ubitx #calibration

 

Hi Guys, just a short update on my Tune-up problems.
It seems that the main issue I have here is that the instructions provided by HF Signals do not align with the actual menu on the uBitx.
Part 2 of the Tune-Up instructions are for aligning the Master Clock. It advises to go to an AM broadcast signal of known frequency. If NOT zero beat then click on encoder button again  and a new option "Set Calibration" will be displayed. This is a photo of what's displayed.


When I click to enter this option it does not give me the option of adjusting to Zero Beat, but instructs me to go to Exactly 10Mhz. per the photo here.
When I press the PTT, it TX's on 10Mhz and displays this on LCD.
When I rotate the encoder it increments the 0 digit on the top right corner. But its a blind adjustment, no feedback on adjustment until you back out of the Calibration and back to a known frequency.
It is not possible to realistically and accurately adjust the clock with this method. 
What am I missing? This is extremely frustrating. 

Kevin Rea
 

it happened to me, i just turned the unit off and back on, and it was fine.

kevin

EI_Frank
 

My QTH is the east coast of Ireland, so will be very lucky to receive the 5, 10Mhz WWV transmissions, for Zero Beat calibration, given the propagation conditions lately.
I'll have to tune to a local AM broadcast channel.
Thanks for the suggestion anyway.

EI_Frank
 

Joel,
Just wanted to thank you again for the advice.
I went ahead and uploaded the KD8CEC 1.08 firmware to the rig, then successfully calibrated the uBitx.
I was able to make a QSO with a station on the east coast of England, approx 370 km's from my QTH which is 10km's north of Dublin, Ireland.
So a great end to the Calibration Twilight Zone. :-) 
All the best, 73.
Frank

 

Great news Frank, glad it all worked out for you.

Joel
N6ALT

hickmodawg@...
 

I am just an ignorant beginner in amateur radio.  I hope someone can answer my plea for help.

I assembled my uBITX (v.5) and put it in an enclosure.  It works!  I am very happy!  My first real building success!

The receive sounds great.  My local HAM friends tell me that my transmitted CW sounds good too.

The problem is that the signal they receive is not on the frequency shown on my LCD.  Also, they transmit on a certain frequency, but I must tune to a different frequency to hear them.  Both my receive and transmit frequencies are different from what shows on my LCD.

Can I solve this by “calibration?”

I read some threads here and it seems that others have solved this problem but to a new beginner like me, the steps are not clear.  I’m not really experienced with Arduino or Raduino, but I’m eager to learn.

I know it’s a big ask, but, is there someone who might write a step-by-step detailed procedure for “calibrating” for a new beginner like me?  Including the very basic steps?  I’ve read some of the threads of those who have accomplished this.  I know I can do it, but I need a little help…

Thanks for all the great advice and help so far.  This forum has gotten me on the air and I have learned so much!

Martin, AJ6CL