ubitx v6.1 #ft8 #cat #wsjt-x #ubitx6-help


I have a new ubitx ver 6.1 
When I try to use WSJT-X I get the error "ham lib error: IO error while getting current frequency" and the Raduino reboot
The serial port settings are correct. 
I have tried older versions of WSJT and the newest beta version,
I have tried different rig settings - FT-817 857 897 etc
I have tried everything I have found online. Also tried 2 different pc's
I am out of ideas. Perhaps the unit is defective ?
Please Help ! Any suggestion?
thanks and 73 James


I  struggled a bit with the cat connection.  Then I went into the device manager and changed the
Baud rate to 38400...com4  and also set up wsjt-x for the same.  The cat control is working now.
I made a couple of FT-8 contacts on 10 meters today with it.  73.

Kelly Ellison

Stephen KO4CVU

I notice a drastic decrease in power output when running digital with less than 1Khz offset on my uBITX v6.1 Is it just my unit or has anyone else noticed the same symptom? I am wondering if this could be related to the frequency response of the audio circuit since it happens on both the 20 meter and 40 meter bands.
Stephen, KO4CVU

Evan Hand


Have you tried the "Fake It" setting under the Split section of the Radio tab?  Here is the explanation from the WSJT-X manual:

"Split Operation: Significant advantages result from using Split mode (separate VFOs for Rx and Tx) if your radio supports it. If it does not, WSJT-X can emulate such behavior. Either method will result in a cleaner transmitted signal, by keeping the Tx audio always in the range 1500 to 2000 Hz so that audio harmonics cannot pass through the Tx sideband filter. Select Rig to use the radio’s Split mode, or Fake It to have WSJT-X adjust the VFO frequency as needed, when T/R switching occurs. Choose None if you do not wish to use split operation."

You might want to check your BFO setting is the drop off is occurring at 1,000Hz.  Should be at 500Hz.

Here is the video from Ashhar Farhan on v6 calibration. 


I would first just check the current BFO setting with the BFO Tuning Aide.  Only do the last BFO set, not the first or frequency calibration steps, if you see the "plateau" is significantly out of the center of the two bars.  In your case, If the drop-off is caused by the BFO calibration, it will be to the right of the center.