kit-projects AGC with uBITX v5 - need help #v5

Rob French (KC4UPR)


I've posted a few times on here about my kit-projects AGC.  I'm thinking that I've never really had it working right, and am hoping I can get some help.  Here's my setup, and here are my symptoms.

I've got a uBITX v5 with the kit-projects AGC, preceded in the RX path by the kit-projects BCI filter.  I've taken a photo of the AGC board, below.  As I've noted in a previous post, I also have a G4HUP buffer tapped off of the Q12 emitter.  In addition, I've got an audio buffer and preamp for a line out tapped off the VOL-H.  So I can imagine there is some signal loss.  However, that still doesn't (in my mind at least) explain what I'm seeing.

Also, I do have a 1K audio taper pot wired up as an RF gain control.  It appears to work fine, although I always leave it at its max setting (if I decrease it, signal strength decreases appropriately; I just haven't found occasion to use it in practice).  The RF gain pot is wired to the AGC via two lengths of RG-174.  The shields of both are soldered to the pot body, which is grounded to the chassis.  The shields are NOT grounded at the AGC end.  So I think I have installed this properly, though I understand this has been a source of problems for some folks.

The red, green, and blue wires are wired to the switch per the kit-projects instructions, as is the black wire (which is NOT ground, but rather corresponds to the purple wire in the instructions).  I've got a connector that goes to the Raduino A7 ADC for the S-meter, and the yellow wire is the audio input.

I will note that I have no real way to calibrate this thing.  However, I have done a couple of different things to attempt to "force" some AGC action, with no luck.  I will note that I am generally using 40 meter FT8 (7.074 MHz USB) as my "test signal".  There are some very piercing signals, that the AGC doesn't seem to do much of anything with.

Basic Setup:  AGC audio input from VOL-H ("per the instructions")

In this case, I generally see very low signal strengths, even with strong FT8 signals.  The KD8CEC firmware reports ADC values in the range of 20-50 (I understand that this has been divided by 4).  Using my DVM to measure the DC voltage at A7 / the control voltage, it looks to fluctuate between 0.1-0.3 VDC.  As I understand it, this DC voltage is way too low to cause any AGC action.

Next Setup:  AGC audio input from my line out

I have a TL082 configured with one half as a basic buffer, and the other half as a 20dB (100x?) amplifier (reference the TL082 preamp on this page  I normally adjust the gain control (a trim pot) to provide a reasonable audio level for my sound card--this is actually the whole reason I got the AGC in the first place, to control the audio for digimodes. 

Here's where it gets a little weird.  If I adjust the gain to 0, then the A7 ADC registers about nothing... pretty much what I expect.  However, as I increase it, the control voltage increases above what it was in the "basic" case, but it really never gets above 0.3-0.5 VDC even on those same strong FT8 signals.  Even if I max the gain control on the preamp output.

The strange thing here is that if I max the gain control and run that to my sound card, the sound card at its 0dB gain setting (which is line-level) is completely clipped/flat-topped.  So I would assume this is somewhere around 0.7 Vrms on the audio, which according to the ND6T write-up on the AGC, should yield about 3 VDC on the control voltage... but I'm still only seeing 0.3-0.5 VDC!  And no AGC action that I can discern.

Last Case:  Direct DC control

This initially led me to think that the audio wasn't getting properly amplified by Q1 (the 3904, or whatever it is) in the AGC circuit.  So I tried applying 3 VDC directly to the "Common" pad on the AGC, with the switch in the "Slow" position.  When I do this, I see the expected value on the Raduino ADC (reports ~155, i.e. (1024/4)*(3V/5V)).  However, again there is no apparent AGC action (and in this case, I would have thought it was forced to do it).

So, any thoughts?  What am I missing, or what did I break?


Rob French (KC4UPR)

One more solicitation for help, hoping someone has some thoughts.  Big picture, I don't *seem* to get any AGC response either due to the audio input to the AGC (which does register an S-meter reading, though not with DC voltage levels that I would expect), or even with +3V applied directly to the Common pad.  Doesn't seem to be any attenuation.  Again, for the first part (control voltage from the audio), I have a buffer and audio preamp that I use for line-out, and even when that thing is clipping the audio, it doesn't seem to have any effect on the AGC (and the control voltage doesn't seem to get above 0.5 VDC).

I did check the +12V input and the regulator +5V output on the AGC board, those are both fine. 



I have a V4 and use and entirely different AGC system, so I can't help directly. There was at least one instance of that AGC board not working, which may have been due to a failed component, and an update to pull the AGC voltage from a different part of the circuit, not the Vol-H pin, that may be of use. See the following message:,,,20,0,0,0::Created,,kit+projects+v4+agc,20,2,0,31881810



What is the black wire by where RF gain is silked? From the picture you provided, I cant really see where the signal is going. Can we also get a picture of your switch wire up.
Tim Keller

On Sun, Aug 23, 2020 at 5:24 AM Vic WA4THR via <> wrote:
I have a V4 and use and entirely different AGC system, so I can't help directly. There was at least one instance of that AGC board not working, which may have been due to a failed component, and an update to pull the AGC voltage from a different part of the circuit, not the Vol-H pin, that may be of use. See the following message:,,,20,0,0,0::Created,,kit+projects+v4+agc,20,2,0,31881810


Tim Keller - KE2GKB

Rob French (KC4UPR)

Sorry for the delay on this.  Life.

The black wire corresponds to the purple/magenta wire in the instruction manual, i.e. it connects across the two middle terminals of the switch.  The switch is kind of buried at the moment, but if needed I can try to dig it out.  I will note that with the the switch in the OFF position, my S-meter display goes away (as expected), and it reappears (albeit not very good) in either SLOW or FAST.  I'm fairly confident that I do have the switch wired up correctly.

I've tried injected a 1V RMS 1500 Hz audio signal into the yellow audio line.  I was hoping to see that result in AGC action being force, but no luck.  That caused little-to-no change in the value of my S-meter/the corresponding ADC (I will note in general that the ADC input voltage I'm seeing never gets above about 0.3-0.5V).  (As an aside, I also heard the 1500 Hz signal through my headphones... I'm not entirely sure how it's getting into the audio chain???)

Final note, if you look in the photo I posted before, right above the two RG-174 lines that go to the RF gain control, there are two solder pads with nothing between them.  Looking at the manual for the AGC, it appears there is supposed to be a capacitor here.  This appears to be an addition relative to the original ND6T design, but I imagine maybe it could have been an intentional change to the kit?  What was this capacitor for, what's it's value, and could its absence be the cause of any of my issues?


Rob French (KC4UPR)

Sorry,  you had asked about the black wires by RF Gain. Those are two lengths of RG174 to a front panel RF gain pot. I have since removed those and replaced with a jumper while I troubleshoot.


No worries rob life gets us all eventually, So off hand I'm not 100% sure what could be going on. So a few tests to try.

Can you try a 1V RMS ~550HZ signal? Sometimes I have noticed the detector is a little odd on higher frequencies. Second, Could you measure the resistance presented on the black Switch wire to ground in all 3 positions?

A low S-Meter (Or bias voltage as it also happens to be) is either the input buffer transistor being bad, Or what its feeding being bad. At least those are the typical issues. Lets start there

-- Tim Keller - KE2GKB

Rob French (KC4UPR)

Black to ground, resistance, below.  To be clear, this is measuring from the square pad at the end of the diode, where I have the thin black wire soldered in the picture.

OFF (down) - 0 ohms
SLOW (middle) - ~800 ohms
FAST (up) - ~800 ohms

So clearly something is not right here.  I'm guessing that SLOW should resolve to 1M and FAST should be something less (470k?), but not 800 ohms! 

I also went and individually measured the two resistors.

The 470k resistor... I am able to measure a good value across that in OFF and SLOW. When I measure it in FAST, it shows as a short.  I don't think that makes sense.

The 1M resistor... All switches positions, it measures as 0 ohms.

Unless there is other broken component providing a path to ground, my guess is that something is broken in my switch. I do know that I had removed a washer or nut from the base of the switch in order to have it mount flat against the inside of my rig.  I wonder if I overtightened the mounting nut and caused some type of mechanical failure or deformation inside the switch.

I'll need to verify, but it should be an easy matter to desolder those connections and put some jumpers in to test the settings. 

What's the part # on that switch?  I'll probably need to order a couple.  Or, alternatively I could make up some little relay circuit board to put the AGC under software control...



Lets start with some pictures of the switch its a weird configuration, but yeah something is definitely not.

Off Should be 0 Ohms that's correct (its a short to ground) Fast should be Just shy of 470K Slow should be 1meg

however this switch like I said is a little odd, Hence the wiring instructions in the documentation. To test this without the switch you can easily just bridge Common (Black) to Red(fast) or Purple(slow) and see if you get the expected AGC action.

it's something like 2 pole shorting switch. or a type1 DPDT. Lots of conversations on the forums about what it "actually" is But I have attached the internals so you can also check it against your wireup

-- Tim Keller - KE2GKB

Rob French (KC4UPR)

So, I actually rewired this with a pair of SPST toggle switches I had lying around (one for ON/OFF, one for FAST/SLOW).  In retrospect, I don't think I had a switch problem in the first place.  I still see no apparent AGC action, and the S-meter AGC value is near-zero all the time.

When I disconnect the Common line from the board, and measure between the Common line and ground (with everything else connected) while cycling through the switch positions, I get what is expected:

OFF - 0 ohms
FAST - ~470k
SLOW - ~1M

However, when I reconnect Common to the board, and measure the same resistances, then everything basically measures as a short through the switch.  So clearly there is a path to ground somewhere, regardless of switch position, and I figured I would check out the diodes.  I measured both forward and reverse across both diodes; in both cases I get about 550 mV forward and 1100 mV reverse.  At first I thought maybe this was an issue with the diodes, but looking at the schematic, it seems like there is probably always a return path via Q3 gate-source and the other diode. (Looks like the 2N7002's have about ~690-720 mV drop from gate-source?)

So I'm thinking a DC resistance measurement across the switch positions in-circuit doesn't really work due to the presence of Q3?  (I.e. I'm really just measuring some gate-source resistance)

Any other thoughts? 

So, still stumped.  My switches are wired up right.

Rob French (KC4UPR)

Whoops, didn't finish that thought.  So, my switches appear to be wired up right.  In AGC Off, everything works fine.  In AGC Fast/Slow, I get very little ADC, and no AGC action. 

You mentioned the buffer transistor, the MMBT3904. Any good way to check that?  And if I did need to replace it, would a BFR106 be suitable?  (I have a couple of those from when I did the power output modifications.