Digital mode transmit via CAT but MIC-connector switches to Transmit directly - #ubitx-help #cat #v5 #digital

Erwin - PE3ES - F4VTQ

On the ugly build uBITx I now have the latest CEC firmware installed, and a 4-line display (2004)
I can receive and decode FT8 and WSPR via laptop running latest WSJT-x, connected via CAT.
Setup : USB connected to nano and headphone-jack from radio to audio in on internal laptop soundcard.
Works great.

Then I connected a pre-tuned antenna tuner and put the cable from laptop soundcard into the Microphone-jack.

The uBITx started clicking some relais, and went into Tx mode without outputting RF as far as I could tell.

Took all cables out and tried again, same (is noise from laptop audio out triggering Vox PTT?, but reading this forum after the issue : there is no Vox-circuit)

Tried with only cable into Mic-jack : switching to Tx a few times and then settles to Rx again.

So far I did not install the electret-mic and did not install the PTT-switch. I do not intend to do SSB/phone.

The CEC firmware should work CAT-PTT so what am I doing wrong?

Advice and suggestions highly appreciated.

PE3ES - F4VTQ - Erwin