odd behaviour with new library si5351 v2.02 => strong tuning clicks!

Allard PE1NWL

By the way, I still don't quite understand how the 1.7ms gaps Don mentioned can cause the clicks/pops.

What exactly happens in these 1.7ms gaps? Is there no output at all? Or is the output frequency varying/unstable in that interval? I haven't measured with a scope yet, perhaps somebody already did?

Did the older library 2.0.1 not have any tuning gap? Or were they much shorter perhaps?

I believe most of the clicking was caused by noise coming in to the volume pot leads. The clicks could were heard equally loud even when the volume pot was turned to minimum position. Shielding those wires almost completely solved the problem in my case.

So it seems that the raduino generates this noise (which is then probably coupled via the pot leads to the input of the LM386), but I cannot see what the 1.7 ms tuning gaps could have to do with this (and the si5351 library version). Well apparently it does have an effect, but I just don't understand the mechansim behind this.

Perhaps somebody has an idea?

73, Allard PE1NWL

Allard PE1NWL

Thanks Don,
for confirming this! I have updated URL in the Wiki so that it now points
to the v2.0.1 library, instead of v2.0.3 by default.

I used to have the tuning click problem in the past, and I fixed it by
adding capacitors at several places on the +12V rail. The clicks were then
almost gone.
But with the new library it seems the clicking noise is much stronger than
with the old library.
Meanwhile I have added more capacitors and used shielded cable for the
volume pot, the clicks are now almost gone again.
It's remarkable that the tuning click problem is affected by version of
the si5351 library. I never thought about this possibility.

73, Allard PE1NWL

Don, ND6T


Confirmed. Both updates (0.2, 0.3) have 1.7ms gaps when reprogramming frequency. Best to revert to 2.0.1. N5KYD alerted me. -Don, ND6T

Allard PE1NWL

Today there was again a new release v2.03 of the si5351 library.

I immediately tried it, but unfortunately I still have very strong tuning clicks with this version.

As is the case with the recently released v2.02, every time the raduino executes the set_frequency() command a loud pop is heard from the speaker.

This doesn't happen with the v2.01 library.

Can somebody try v2.02 or v2.03 just to see if the problem can be reproduced on another raduino, please?

(you can always download and restore the old working version v2.01 from

We may have to add an extra warning in the Wiki pages until this issue is resolved.

73, Allard PE1NWL

Allard PE1NWL

Today I tried the brand new si5351 library v2.0.2 that was released only a few days ago.

I compiled the same sketch (arduino_v1.03) with this new library, no compilation errors.

On the BITX40 everything works normally, except that I have now loud clicks when I turn the tuning pot.

Then I removed the library and reinstalled the previous version v2.0.1, and compiled again.

Guess what: no tuning clicks!

Has anybody already tried the new si5351 library and had similar experiences?

73, Allard PE1NWL