another stuck relay in TX mode #ubitx #bitx20

Don - KM4UDX

hello all!

My beloved V4 uBITX has been working really hard and flawlessly 24/7 in wspr mode for (almost) months at a time.  The results are impressive...frequently in the top 10 worldwide 2 way spot ranking.  But all that success comes at a price. 

Now, my uBITX randomly sticks in TX mode.  If I tap the left side relay, it releases TX mode.  I learned that diagnostic technique from Dave_ K0MBT (hahah, and thank you!).  If I just reboot or turn off/on, it stays in TX mode.  But the back of the pen allways works.  So am I good to go to replace the relay? I really hate to mess with it, but my hand is forced, as they say.

Is there a prefered type/source of replacement relay? 

thank you all!!!!




First before we assume its a bad relay, reflow each pin and also reduce the transmit drive level. You never know the relay may be okay. I assume you tried more than one band? Make sure you don't have a small strand of wire to blame for this mishap.


Don - KM4UDX

Curt -- I can reflow each pin if I pull up my pants and stop being a whousssssss.

Good implyed question on the drive level. SWR meter says 28w on wspr on 80m, which means two full minutes of hard duty.  But I don't know what band it was on when it locks up.   I was so freeked about how it could be in drive when there was no TX command from my computer, a disconnected sound card, a reboot, a physical turn off/on, that I didn't notice what the band or pwr level was. I feel silly now not noticing that. 

I'll look for any anomolies on the board.  The "case" has a lot of air flow, so something could have landed where it wasn't supposed to be. 

The lock up is seemingly random, so I can't make it misbehave on command (yet).  If it keeps up, I'm sure that even I will figure out the pattern. hahah.  This is the third time so far. 

If i decide to replace it, I assume the required relay is the axicom  V23105A5403A201 discused (endlessly) in previous threads?

Given that I may need only one, there must be some uBITX builder who got 5 or 10 and would send me 1 or 2 (pleaseeeee..)?


Sam Tedesco

I have a bunch. I can mail you a couple.



28 watts on 80m?  most of us are around 10 watts - could be an inaccurate power meter - or if you really are doing 20-some watts you could be over-driving badly. 

notice I am suspicious that relay itself may be still okay ....

you might have some RF getting into raduino that is locking it on transmit.  at the same time, its not wise to make this much RF with the ubitx - you could be jamming all kinds of fellow hams - for not much benefit on FT8.  if it does not lock up when doing SSB voice - another clue it may merely be too much drive into the PA. 

much better to solve it with an adjustment than to take the ubitx into unnecessary surgery! 


John Faivre

I had the same issue. I replaced K1 with the axicom and it fixed it.i only run about 15 watts on 80 meters, but I was switching inductance on my ant tuner often while in transmit. I think that may have contributed to the proble, 
John Faivre WA9SGD

Peter LB0K

A stuck relay that releases on being tapped usually indicates that (some of) the contacts themselves are sticking together, presumably from arcing.

The only real cure with these small sealed units is to replace with a maybe beefier alternative, and in the longer term try and check whether the relay is in fact being commanded to open before the transmission has ended completely. Or maybe the transmission is starting some milliseconds before the relay contacts close properly.
For serious VHF/UHF work this what sequencers for the antenne and power switching arrangements are for, to make sure that the antenna changeovers are made before the signal starts, or after it ends. Thus ensuring the relays, and PA units, aren't subjected to unnecessary stresses.

For testing, one can make continuity checks across the contacts while is in the 'stuck' state to be certain of the diagnosis. But very often any slight movement or vibration will cause the relay contacts to release.

Of cause there could be a dry joint somewhere so reflowing all joints to the relay and its driver is an important first step. And see if the sticking still occurs at lower levels of, say, 10W.

73 Peter. 


Thanks Peter!

Beside all the TX circuitry, the relay is also driving two other relay coils, so I wonder if that may cause a bit of stress too?  Initial resistance of the relay coils in parallel might be pretty low.

I don't know the draw of the TX (not counting the finals on a separate circuit) but I don't think it woul be close to 2A?  So looking at sequencing, or just a beefier relay may be the long term answer.



PS:  I suspect the 28W may be due to Don running the finals at more than 12V?

_Dave_ AD0B

I have 4 uBITX radios and the first one had stuck the left side relay early on. I replaced it with a stock component and it has worked fine. None of the other machines has had a problem. This relay only carries signals on the receive side so no chance of spurious emissions.

Good luck with your repair.

I approach repairs from the viewpoint of a repair technician rather than that of an engineer. I always get a chuckle with those who think they need a wall full of test equipment to fix these critters So far I have been able to resurrect all 3 uBITX radios determined to be junk by previous owners.
73 all

Don - KM4UDX

Yes, with 16v to the finals I get a few more watts. At 80m with 16V and 25w there is 1.6 amps running around -- and maybe more with spikes here and there?

I've asked multiple folks on 80m (where I get the most watts) if they see any artifacts in my PSK signal (for example), and I get fine reports. I have seen wickedly over driven PSK signals with echos on the right and left of the PSK railroad tracks -- and I never want to send that out!!

I confess when I got my uBITX I was clueless oh how to monitor, adjust, and control my drive levels.  In the early days I'm sure I sent out a bunch of majorly over driven stuff. i'd like to go back in time and apologize to anyone who saw the mess I was sending, hahaha.  But, all I could say was...I'm sooo sorry I'm just learning how to figure out all this stuff.  And even the volume control took a while to understand. hahaha.