single usb for cat control & sound card #ubitx #ubitx-help #arduino #cat

Don - KM4UDX

hello!  When i got my sound card dongle and cat control working each in their own USB port on my Win10 laptop, I almost fainted from uBITX joy. It is reliable and works well. So time to move on. Hahah. 

 I now need to get the two usb devices working from one USB port on the computer. Every time I try to combine the cat control usb with my sound card dongle usb into a powered hub (or unpowered) so I can use just one USB port in my laptop, the sound works but the cat control doesn’t. I’ve tried messing with com ports, etc, but I eventually give up and go back to using separate USB ports on the old laptop. 

I’ve seen a post where a usb hub was used successfully to combine sound card and cat control, but I can’t duplicate the results. 

What am I doing wrong? What clue have I missed? What stupid user error?

Why do do I need to do this? Well...

After I get the single USB port solution on working on my win10 laptop, i’ll transition to a new   single board computer (atomic pi) with only ONE native USB port.  

Thank you you all for the help. 

Doug W

Something doesn't make sense.  I hate it when people say it works for me so it must work for you, but I am going to be that guy.  There should be no problem using a USB sound card and a CAT control cable on the same USB hub.  Can you post a screen shot of the ports listed in your device manager (or type them out)? 

Nigel G4ZAL

I think I was one of the first to add an 'all-in-one' USB solution inside a uBitx with a small 4 port hub?  I also did the 'cut the red wire' at that time.
I had posted it here...

and it also exists on, here...

I do find that Windozey 10 has a habit of changing the COM port (serial port) on some boot-ups, eg one time it will be on COM5 and next boot it will assign COM6 - just something to be wary of.

I also made a similar box that sits externally on my FT817ND and has a 4 port hub inside with the USB sound card, USB Serial adapter and a USB GPS dongle, I use the GPS for accurate timekeeping via BkTimeSync - - works great when operating /P as it gives you your locator.


Nigel - G4ZAL


Don - KM4UDX

Doug and Nigel, yes so I'm trying to copy at least Nigel, and many others (which is good news).

As suggested, Win10 reassigned the cat com port from COM7 to COM13 when I put the cat usb cable into the usb hub.  No problems, I just change the com port in fldigi rig device control to COM13...but no.  While COM13 shows up in the dropdown list, and I can select it, nothing happens. After I do hit the save button  (which gets a thin dash outline, and just sits there), or click Save Config on the tab, no changes take effect. After I close fldig, and open it up, there are no changes in config. Hamlib is unchecked, and com13 is not selected. 

So it seems like I can't save the config, or there is some reason why I can't really select COM13 with the usb hub?  Is there something else I am doing?

Don - KM4UDX

okay, so after a day (almost) of back and fourth, it was clear to me that only COM7 was loved by the uBITX cat control.  I finally threw in the towel (I didn't even know I had a towel!) and deep in the advanced device manager setting you can manually assign a comport to a device.  I set it back to COM7, got an error that it was in use already, said darn the torpedoes, did it anyway, reboot, reset fldigi device to COM7, and presto.

Both usb sound dongle and usb cat control now work under 10Win.  Just to push the line, I added one more little usb bluetooth device for my logitech mouse and keyboard.  And now all four functions work on one usb hub: sound card, ubix cat control, mouse, keyboard. Whew!  What a night mare. Who would want to figure this stuff out??

So thanks Nigel and Doug.

Nigel, I too think the arduno should not be powered by the usb cat control.  So you "cut the red wire".  Did it make any difference, actually? Should I do that as well?

Now, on to the Atomic Pi (a rasberry pi clone, sort of) and Lubuntu.  My goal is to have a dedicated computer just for wsjtx (WSPRnet!!) and fldigi, then I will build a new enclosure containing BOTH the uBIX and the Atomic Pi and the usb hub. Then I will have a total integrated portable package. And I will free my old win10 laptop from uBIX bondage.

I know nothing about lunix, or Lubuntu. Zip. Nada. I'm not even sure I'm spelling them right.  But I did get Lunbutu (the OS) installed and working on the AtomicPi. and I got Fldigi installed, but not working due to the Atomic Pi having only USB port so I couldn't get control and sound working.  So now you see why I'm going to take the usb hub, with uBIX, sound, mouse, keyboard from the old Win10 laptop, to the new cool AtomicPi.

I'm sure with a few hundreds of hours of tinkering, messing, trying, failing, errors, redos, and a little help, it might work. If not, I'm only out $38, and a few hundred hours. ahahah. 

Thanks you!!!!

Nigel G4ZAL


I 'cut the red wire' because I had already removed the Raduino 5v regulator and modified my v3 boards audio to have a 5v supply (and the Raduino, USB hub etc) separately supplied from a small radio control 3A uBEC (you can see it, plus a small buss for 5v & GND feeds) on the left most side of the board/enclosure.
I also use the Win10 laptop for other things and when the laptop is on, the Raduino was powered up via USB - hence disconnecting the 5v feed from the USB from the computer side.
i also noticed that with both 5v feeds connected, sometimes it would cause the uBitx to reload/restart when interconnecting the USB cable.
I have no sign of any interference from the uBEC or the hub etc, so I'd say yes, cut the red wire!

Only downside is that when updating firmware, you have to have the rig powered up (as no power is supplied to the hub/Raduino via the computer USB port).

The upside is that I don't have to open the case to do firmware updates!


Don - KM4UDX

So now I'm stuck on getting uBITX cat control working on the AtomicPi in Lubunto.  The audio works great, I get decodes!! So good there. I have tried every option on the Device dropdown list. No love. I'm sure the problem is due to my total ignorance of how to configure ports, devices, or anything in lunix world...ahhhhhh.....
But I can't configure the rig tab to control the uBITX for the important job of actually TXing. 

Don - KM4UDX

Ah...good info. Thanks!  I also added a BEC for some the 5v needs (plus a usb charge port), and a big dc-Dc buck converter for the 12v board. Now I can power it up with anything (almost) and the finals are at “line” power, and the rest is 12/5 as needed. Even made a tap for the antenna runner led in the meter. 

Such fun. 

Now I just have to get my atomic pi and fldigi/wsjtx working....gur. 

Thanks agIn!!