Topics

Flrig and uBitX not connecting

Vic WA4THR
 

Rainy day, so I decided to play with digital control of my uBitX V4 running KD8CEC v1.1o with a V3 Nextion interface. This combination works fine using Memory Manager, but I cannot get Flrig to connect using the same port that I use when running MM (but not at the same time). Here is what I see, what am I doing wrong?:

Vic WA4THR
 

Update: I did download and update the driver to CH340, but that made no difference. Memory Manager still works, but Flrig does not.

However, i loaded WSJT-X and set it for the same COM port and as an FT817 and it controls and reads the rig fine, so the problem is only with Flrig.

=Vic=

Sascha Bohnet | DL5SMB
 

Hi Vic,

I think you are using the wrong baud rate. Try changing to 19200 Baud - that should do the trick.
The correct speed is hardwired within  KD8CECs firmware. You can change it of course, but then you need will have to recompile the source code again.

Good luck

Sascha

Sascha Bohnet | DL5SMB
 

Sorry, I'll take it back.
I just read that you wrote WSJTSX worked and checked the source code
  Init_Cat(38400, SERIAL_8N1);
  initSettings();
  initPorts();   
38400 is correct after all.

What version of flrig do you use? I mean when was it released? I think I remember the rig control library once had a problem.....

Sascha

Vic WA4THR
 

I had downloaded Flrig from the W1HKJ site, version 1.3.44, when I was trying to use it. I've deleted it from the computer now as it did not work.

Is anyone else using Flrig?

=Vic=

Jay - WS4JM
 

Vic,

I know this is an old thread, did you ever get this to work?

Jay
WS4JM

Vic WA4THR
 

No, the need never came back up. I could use WSJT-X if I wanted to control and the Flrig was basically for fun and maybe use Fldigi at some point. I see the fl*** programs get updated a lot, so maybe something more recent has fixed the problem.

=Vic=

Jay - WS4JM
 

I loaded the latest yesterday, no joy. I thought it would be an easy way to do rig control with a Raspberry Pi. On to something else.

73 de WS4JM
Jay

Dean Souleles
 

I have my CAT control on my V5 with the CEC firmware working with FLRIG on a windows 10 PC no problem.  (And also WSJT-X, HRD and others)./


Dean
KK4DAS

Vic WA4THR
 

What version of Flrig and what are your port settings, Dean? I was also trying with a Win10 machine at the time and only had issues trying to run Flrig with my v.4 uBitX running CEC software.

=Vic=

Dean Souleles
 

Hi Vic,

Flrig is 1.3.45

Settings below...similar to yours but not exactly the same.  

73, 
Dean
KK4DAS

Vic WA4THR
 

Very good, Dean. I matched your settings (except the COM port which is different on my machine) and after initializing a second time I do have control of the uBitX. Thanks! Not sure what I'll do with that...but it is interesting that CAT PTT and the S-Meter work in Flrig now. Cool.

=Vic=

Dean Souleles
 

Vic,

Glad you got it working.  My experience has been that it doesn't always connect the first time.  I think that's why I played around with the retries and retry interval.   

73,

Dean