Topics

Nextion Basic 3.2 Display will not update #ubitx

V Zecchinelli
 

I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

Joe
 

Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

pat griffin
 

You could try downloading directly to the display. It’s slow but it would tell you if the display or card is bad.
73
Pat aa4pg


On Aug 13, 2018, at 1:02 PM, Joe <joeman2116@...> wrote:

Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

V Zecchinelli
 

Thanks Pat.  Sounds like a great idea but not sure I know how to do that.  Would I cobble together a USB to connect to the 5V, RX, TX, GND?  At this point the display is not connected to the uBitX.  I have 5V & GND connected to USB adapter and computer.


On 8/13/2018 2:33 PM, pat griffin wrote:
You could try downloading directly to the display. It’s slow but it would tell you if the display or card is bad.
73
Pat aa4pg


On Aug 13, 2018, at 1:02 PM, Joe <joeman2116@...> wrote:

Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

pat griffin
 

I am not home and it has been a bit since I did it. You will need an ftdi usb to serial cable ($15 or so) Connect it to the computer USB port and the other end (4 pins) to the 5v, grd, rx, and tx pins on the display. Then select the port in the editor and the download or upload I forget what it is called. I may have left out a step but that’s basically it
Pat


On Aug 13, 2018, at 1:53 PM, V Zecchinelli <n1vin@...> wrote:

Thanks Pat.  Sounds like a great idea but not sure I know how to do that.  Would I cobble together a USB to connect to the 5V, RX, TX, GND?  At this point the display is not connected to the uBitX.  I have 5V & GND connected to USB adapter and computer.


On 8/13/2018 2:33 PM, pat griffin wrote:
You could try downloading directly to the display. It’s slow but it would tell you if the display or card is bad.
73
Pat aa4pg


On Aug 13, 2018, at 1:02 PM, Joe <joeman2116@...> wrote:

Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

V Zecchinelli
 

Thanks a lot Pat.  I found the cable on Amazon and it is on it's way.  I very much appreciate your input.

73 Vince N1VIN



On 8/13/2018 3:28 PM, pat griffin wrote:
I am not home and it has been a bit since I did it. You will need an ftdi usb to serial cable ($15 or so) Connect it to the computer USB port and the other end (4 pins) to the 5v, grd, rx, and tx pins on the display. Then select the port in the editor and the download or upload I forget what it is called. I may have left out a step but that’s basically it
Pat


On Aug 13, 2018, at 1:53 PM, V Zecchinelli <n1vin@...> wrote:

Thanks Pat.  Sounds like a great idea but not sure I know how to do that.  Would I cobble together a USB to connect to the 5V, RX, TX, GND?  At this point the display is not connected to the uBitX.  I have 5V & GND connected to USB adapter and computer.


On 8/13/2018 2:33 PM, pat griffin wrote:
You could try downloading directly to the display. It’s slow but it would tell you if the display or card is bad.
73
Pat aa4pg


On Aug 13, 2018, at 1:02 PM, Joe <joeman2116@...> wrote:

Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN


V Zecchinelli
 

Thanks Joe.  I tried 2 SD cards I had but I have used them many times in RPI projects so I have ordered a couple new ones.  For power I tried USB port on PC and 5V 3A supply I use with QRP-LABS U3S so I know it is good.  I have also ordered a USB-TTL cable. 

73 Vince N1VIN



On 8/13/2018 2:01 PM, Joe wrote:
Hi,
I have seen this issues several times

1. Make sure your power source is good.
2. Try another microsd card.

Usually one of the above clears the problem

Joe
VE1BWV



On Mon, Aug 13, 2018, 2:47 PM V Zecchinelli <n1vin@...> wrote:
I have spent most of today searching through messages and wiki to no avail.  I am using the basic 3.2 Nextion display and am trying to upload the tft file I downloaded from ubitx.net.  SD card is 8Gb and is formatted FAT32 and tft file copied to it.  When I insert the card into the Nextion display it shows Baud:   9600 and SD Card Update....... and stalls at that point.  I have waited as long as an hour.  Am  missing something or perhaps I procured a bad Nextion or SD card?
Thank you for any input.
73 Vince N1VIN

SV9CVJ Nikos
 

Try with another SD card I changed 4 cards .

V Zecchinelli
 

Thanks Nikos.  I ordered some new SD cards to try.


On 8/13/2018 3:38 PM, SV9CVJ Nikos wrote:
Try with another SD card I changed 4 cards .

Joe
 

I found that only microsd cards which said Hc1 or UHC1 worked for me.
Class did not matter.


Joe
Ve1bwv


On Mon, Aug 13, 2018, 5:10 PM V Zecchinelli <n1vin@...> wrote:

Thanks Nikos.  I ordered some new SD cards to try.


On 8/13/2018 3:38 PM, SV9CVJ Nikos wrote:
Try with another SD card I changed 4 cards .

V Zecchinelli
 

Thanks Joe. 


On 8/13/2018 8:32 PM, Joe wrote:
I found that only microsd cards which said Hc1 or UHC1 worked for me.
Class did not matter.


Joe
Ve1bwv

On Mon, Aug 13, 2018, 5:10 PM V Zecchinelli <n1vin@...> wrote:

Thanks Nikos.  I ordered some new SD cards to try.


On 8/13/2018 3:38 PM, SV9CVJ Nikos wrote:
Try with another SD card I changed 4 cards .


ke4d@...
 

I had a similar situation. Many attemps and finally it just decided to load. 

V Zecchinelli
 

Interesting.  Thanks for the info ke4d.


On 8/14/2018 6:40 AM, ke4d@... wrote:
I had a similar situation. Many attemps and finally it just decided to load. 

Kai Nilakari
 

Anyone of you having TFT file for 3.2 inch basic display?
The one which is in a zip package is too small, loads ok but looks strange in the upper right corner...and my fingers are way too
thick to press those small buttons. The previous one looks good.

Kai OH3WE

Vince Vielhaber
 

I'm replying to an old post, much of it was about SD cards with the Nextion displays (for those that use email, not the web). 

I got a 4.3" Nextion Enhanced display for a non-bitx project and tried HC and HC-I SD cards to get it to load the firmware.  All of the attempts were made formatting the cards as VFAT32 from Linux, all were dismal failures.

What I finally had to do was format one in my wife's laptop (long format) to get it to recognize it as VFAT32.  Also what I did to avoid having to format it like that again was to use dd and make an image of the blank, formatted card.

The first one I tried to use was just an HC.  No go. The display still didn't like it. The second one was an HC-I card.  That one worked.  Also that one was formatted using the above mentioned image. 

I hope this helps someone else that may encounter similar problems.

Vince - K8ZW (using the group's web interface)