Topics

#bitx40help - Unit stuck in transmit #bitx40help

AGØH
 

I installed Allard’s V1.27.  I wired all of the mods with the exception of the touch keyer.  My intention was to use straight key CW.  Prior to the mods, the board worked fine.  In my haste to get the mods in, I inadvertently left out the 4.7K resistor in the TX-RX wiring, wiring direct from the base of the 2n3904 to the Raduino output D7. 

When I fired it up, all calibration functions seemed to work.  The ptt, when pushed, put the BitX into transmit with good output power.  But-----when released, did not return the rig to receive mode.  The PTT wiring from the switch on the microphone checked out o.k.)  When I pull the PTT connector from the board, the rig returns to the receive mode. 

I checked out the wiring and  thought I found my error and inserted the 4.7K resistor between the base and the D7 line.  When I powered up the rig, it powered up in the receive mode.  I pushed the PTT switch and it went into Transmit mode.  It again would not return to receive  mode when I released the PTT button.

 

I tried resetting the rig by grounding the Red wire but it had no effect on correcting the problem. 

I’m hoping I didn’t damage the Arduino by leaving the resistor out.

I do have a spare Radiuno but am hesitant to put that in if I don’t have to. 

Any suggestions would be greatly appreciated! 

Thanks es 73,

Keith - AGØH

Allard PE1NWL
 

Hi Keith,

I believe your Raduino is still OK.
But you probably reversed the collector and emitter of the 2N3904. Please verify that you installed the tranistor correctly.

73 Allard PE1NWL

Allard PE1NWL