Date   
Re: Raduino consumption #ubitx #radiuno

Jerry Gaffke
 

Curious, I still learn new stuff everyday.
I was expecting the REF pin to be high impedance.

I powered up a spare Nano  from 5v with some other project's code it it.
It draws around 17ma while the code boots,
Then after everything is initialized, it goes to 18ma.
We can expect that 18ma to vary by a few ma depending on what code is installed, but not much.

I then shorted the REF pin to ground.
Still 17ma while the code boots.
Then after a couple seconds, current from the 5v supply shoots up to 102ma and stays there.
When I remove the REF pin short to ground, the supply current then falls back to 18ma.

My code uses the ATMega328P's internal 5v rail for reference, just like all the uBitx code does.
I assume what happens is the code turns on an internal transistor switch that shorts the REF pin to 5v.
I have not tried it, but changing this line of code that gets executed during setup()
    analogReference(DEFAULT);
to this:
    analogReference(EXTERNAL);
should leave that pin in a high impedance state, and I'd expect the supply current on my Nano
to remain at 18ma even with the REF pin shorted to ground.
I may try that later today.

So, a shorted REF cap could go a long ways toward explaining why your Nano is drawing so much current.

But does not explain your 36 ohms from ground to 5V.
I measure over 1.05k on my good raduino with good Nano, and 3.1k on my spare Nano.
Neither changes when I swap my ohmmeter leads.
The Nano reading of 3.1k does not change when I short the REF pin to ground.
And your board is drawing way more than just an extra 84ma.
So you probably have a second problem on that Nano board, not just a shorted REF cap.

The Nano is tough to remove, if it comes to that.
I'd try a little rotary saw or grinder using my Dremel tool for all but the pins hiding
behind the LCD connector, then heat up those few pins on the Nano board to pull it free.
And then extract all the pins one-by-one from the Raduino.
And take care to wash all the metal bits from the Raduino.
If anybody has a better method, perhaps they could speak up.

You clearly know what you are doing, and are on the right track.
Good luck!

Jerry, KE7ER
 


Thanks for advice and links (i already looked at this ch340 datasheet but it's very short and incomplete -no data about 3v3 output voltage interval)
I've got something : only 36ohms between gnd and 5V, more than 1Kohm on a spare nano, no output data shorted to gnd or 5V
BUT only 6ohms between REF and gnd (about 3K on my spare nano) And REF pin is shown unlinked on Raduino board ->
- bad nano PCB with no space between gnd and ref
- short circuit on capacitor on the REF pin
but all that hard to check and correct without unsolder :-(
first easy thing that i can do easily is cut pcb between Atmega pin 21 and REF output of the board (but i will need later to replace the capa on the other side to enforce noise reduction on analog read)
second thing is to cut and remove this unused pin between nano and raduino (in case the short circuit is on the raduino solder part)
i will keep you informed
73 - Remi

Re: I need a V3 or V4 uBitx board.

Jerry Gaffke
 

Not being a mechanical engineer, I'm awfully suspicious of relays.
Especially cheap ones.
K1 and K2 can rattle quite a bit when working CW.

I'd much prefer to have K1 and K2 swapped out for solid state TR switching.
Hopefully get good CW QSK out of the deal.
The Bitx20A and Bitx17A (out of stock, perhaps permanently?) on qrpkits.com
look like they would do a good job of this.

And if I were building to my preferences,
might consider using plug in filters for the transmit LPF's.

Jerry


On Sat, Jun 23, 2018 at 11:01 pm, Glenn wrote:
I had similar problem some time ago. No Tx.  I could hear K1 pulling in but in actual fact it wasn't making contact. I replaced it with a different brand of relay and no problems since. But it does make me suspicious of the other relays in the uBITX. If they don't work then  a LPF may not be actually switching either.
glenn

Keypad for Raduino...?

Arv Evans
 

Hello

I got tired of the minimalist input button scheme for my uBITX Raduino.  Found this
on-line, and am now working on code to make use of it for a homebrewed Raduino.

http://www.technoblogy.com/show?NGM

More info later when I get everything working.

Arv
_._

RFI from uBitx TX after AGC and other mods installed

RowlandA
 

I just finished installing:
1) ND6T AGC mod using Kees' kit. 
2) AGC off/med/long switch as described in ND6T's instructions
3) T/R LED (Sunil's approach)
4) An RF gain control with an on/off switch so I have front panel on/off using Sunil's enclosure.
5) A wire from J1 to the purple wire on the Digital connector for an S-meter reading

The good news is - no smoke and everything seems to be working.  But now when I transmit (so far just tried SSB), I get very loud RFI (my own garbled voice) in my headphones or speaker, so something I added is getting RF into the system.

I installed the AGC board right at the RF in/out point using the approach outlined by Kees.  I ran RG-174 to the RF gain control, grounded at the RF gain control but not grounded (per instructions) at the AGC board.

I used twisted pair for the runs from the AGC board to the audio gain pot and the +5/ground which I picked up from the green Raduino wire, tapped at the point where the green wire connects to the resistor at the Key jack.  The ground lead twisted to the +5V lead is connected to the ground "bus wire" that connects the front-panel PTT, Phones and Key jacks together.

The wires to select AGC hang time from the front panel switch are not twisted together.

Everything is connected to the AGC board using header pins and plug-in wires so I can disconnect easily from the AGC board, but not easily from the other end of the wire(s).  

Is there an obvious place to start troubleshooting this and/or since I'm already using coax and twisted pairs as recommended in ND6T's instructions, thoughts on a fix?

73,

Rowland K4XD

Re: I need a V3 or V4 uBitx board.

 

A couple of months ago I built a Steve Weber 'Slop Bucket' 20 meter Transceiver that is SSB/CW. It uses a 74HC4053, a triple DPDT analog switch driving some transistors for T/R switching. It is sweet, no clicking at all, just nice and quiet. That radio is a pleasure to use except for the hissy LM386. I guess I can't have it all my way.

Joel
N6ALT

Re: I need a V3 or V4 uBitx board.

Jack Purdum
 

Hi Joel:

Do you have a URL where we can find out more about it?

Jack, W8TEE

On Sunday, June 24, 2018, 1:12:24 PM EDT, Joel Caulkins <caulktel@...> wrote:


A couple of months ago I built a Steve Weber 'Slop Bucket' 20 meter Transceiver that is SSB/CW. It uses a 74HC4053, a triple DPDT analog switch driving some transistors for T/R switching. It is sweet, no clicking at all, just nice and quiet. That radio is a pleasure to use except for the hissy LM386. I guess I can't have it all my way.

Joel
N6ALT

Re: I need a V3 or V4 uBitx board.

Jerry Gaffke
 

Steve always puts a lot of effort in getting the details right.
His stuff always seems to operate cleanly with a comfortable user interface.
I've heard good things about the Slop Bucket.

An unfortunate name, unless you are old enough to catch the reference.

Jerry


On Sun, Jun 24, 2018 at 10:12 am, Joel Caulkins wrote:
A couple of months ago I built a Steve Weber 'Slop Bucket' 20 meter Transceiver that is SSB/CW. It uses a 74HC4053, a triple DPDT analog switch driving some transistors for T/R switching. It is sweet, no clicking at all, just nice and quiet. That radio is a pleasure to use except for the hissy LM386. I guess I can't have it all my way.

Re: I need a V3 or V4 uBitx board.

Jerry Gaffke
 

Here's Steve's group on groups.io, Slop Bucket lives here:
https://groups.io/g/kd1jvdesigns/messages?expanded=1

And his older yahoo group is still alive and kicking, adding a bit of confusion:
https://groups.yahoo.com/neo/groups/AT_Sprint/info

Jerry


On Sun, Jun 24, 2018 at 10:17 am, Jack Purdum wrote:
Do you have a URL where we can find out more about it?
 

Re: Keypad for Raduino...?

Mark Pilant
 

Hi Arv.

I used a similar keyboard for a Scalar Network Analyzer I built. (Before I
found out about the PHSNA :-) It turned out to work very well. I did run
into a few issues worth mentioning.

Make sure you have some form of switch debouncing (software or hardware) as
part of the design. I had both in my design. Also, make sure you take into
account the resistor tolerances when determining the analog value for any
given key. (Part of my SNA design was a set of calibration tasks, one of
which was the keypad.)

I'm building a uBitx with a TFT, and may include a soft keypad to augment the
encoder. (If I can find the time... too many projects :-)

73

- Mark N1VQW

BTW, feel free to look at the SNA code: https://github.com/pilant/N1VQW-SNA

Re: Keypad for Raduino...?

Jack Purdum
 

On Sunday, June 24, 2018, 1:34:36 PM EDT, Mark Pilant <mark@...> wrote:


Hi Arv.

I used a similar keyboard for a Scalar Network Analyzer I built.  (Before I
found out about the PHSNA :-)  It turned out to work very well.  I did run
into a few issues worth mentioning.

Make sure you have some form of switch debouncing (software or hardware) as
part of the design.  I had both in my design.  Also, make sure you take into
account the resistor tolerances when determining the analog value for any
given key.  (Part of my SNA design was a set of calibration tasks, one of
which was the keypad.)

I'm building a uBitx with a TFT, and may include a soft keypad to augment the
encoder.  (If I can find the time... too many projects :-)

73

- Mark  N1VQW

BTW, feel free to look at the SNA code: https://github.com/pilant/N1VQW-SNA




Re: I need a V3 or V4 uBitx board.

Jack Purdum
 

The the groups.io the only place to get info and perhaps place an order??

Jack, W8TEE


On Sunday, June 24, 2018, 1:23:24 PM EDT, Jerry Gaffke via Groups.Io <jgaffke@...> wrote:


Here's Steve's group on groups.io, Slop Bucket lives here:
https://groups.io/g/kd1jvdesigns/messages?expanded=1

And his older yahoo group is still alive and kicking, adding a bit of confusion:
https://groups.yahoo.com/neo/groups/AT_Sprint/info

Jerry


On Sun, Jun 24, 2018 at 10:17 am, Jack Purdum wrote:
Do you have a URL where we can find out more about it?
 

Re: Keypad for Raduino...?

Mark Pilant
 

Hi Jack.

I don't think I'd use an analog approach to it....
The "electronic code lock" keypad approach works great if you have lots of
I/O pins available. But where I was using an UNO, I was quickly running out
of I/O pins. So by using the analog approach, I only needed one I/O pin (as
well as +5VDC and ground).

As I see it, the trade off is mostly in the additional code needed for the
analog approach. Although as I've been doing software engineering for way
too long (O/S, real time, embedded, etc.) it wasn't a big deal for me.

73

- Mark N1VQW

Re: RFI from uBitx TX after AGC and other mods installed

Don, ND6T
 

Rowland,
Check to see if the ground at the center of your new receive RF point is good when the board is unplugged. If it is, then unplug the AGC board and jumper the two outer pins of that RF tap. It sounds like it might not be grounded well. Of course it could be many more things but that is a start. Try to disconnect or bypass one thing at a time to isolate the cause. Since you are hearing what sounds like SSB then I doubt that the problem is improper gating of the audio. Unless you are using an amplified microphone and you are just hearing peaks that are over-powering it. In which case, unplug the PA power and see if it went away. Are you transmitting into a dummy load or into a radiating antenna? The more information, the better. Please keep us posted. 73, Don

Re: I need a V3 or V4 uBitx board.

Jerry Gaffke
 

I think groups.io is your best bet.
Steve has a poll going now, asking if there is interest in a new run of boards.
If you want one you should join the group and respond to that.
I may jump in there as well.

If and when he does decide to create more kits, he will post a message to the group
with instructions on how to order.  Not sure how that happens now, but his CW rigs
sold out fast and you had to respond within a few hours.

Steve did maintain a website in the past:  http://kd1jv.qrpradio.com/
but that has not been updated in years.
He's more interested in building radios than being a webmaster.

Jerry


On Sun, Jun 24, 2018 at 10:45 am, Jack Purdum wrote:
The the groups.io the only place to get info and perhaps place an order??
 
Jack, W8TEE
 
 
. . .

 

On Sunday, June 24, 2018, 1:23:24 PM EDT, Jerry Gaffke via Groups.Io <jgaffke@...> wrote:
 
 
Here's Steve's group on groups.io, Slop Bucket lives here:
https://groups.io/g/kd1jvdesigns/messages?expanded=1

And his older yahoo group is still alive and kicking, adding a bit of confusion:
https://groups.yahoo.com/neo/groups/AT_Sprint/info

Jerry

Re: I need a V3 or V4 uBitx board.

 

Hi Jack,

Steve only kitted 50 SB's, (they are all gone), however he asked the group last week if we all thought he should order another batch only 40 meter version, I voted yes. We'll see  what happens as a bunch wanted the 20 meter versions also. Maybe he will give us the option for the band of choice.

Joel
N6ALT

Re: I need a V3 or V4 uBitx board.

Jack Purdum
 

Hi Joel:

Keep me posted if he does offer it. (I need to join another group like I need a hole in my head.)

Jack, W8TEE

On Sunday, June 24, 2018, 1:56:56 PM EDT, Joel Caulkins <caulktel@...> wrote:


Hi Jack,

Steve only kitted 50 SB's, (they are all gone), however he asked the group last week if we all thought he should order another batch only 40 meter version, I voted yes. We'll see  what happens as a bunch wanted the 20 meter versions also. Maybe he will give us the option for the band of choice.

Joel
N6ALT

Re: I need a V3 or V4 uBitx board.

Jerry Gaffke
 

Well, Steve ain't a gonna offer it unless there's sufficient interest.

Perhaps the Incas were onto something:
    https://news.nationalgeographic.com/news/2008/05/080512-inca-skulls.html

Jerry


On Sun, Jun 24, 2018 at 11:03 am, Jack Purdum wrote:
Keep me posted if he does offer it. (I need to join another group like I need a hole in my head.)
 

Re: I need a V3 or V4 uBitx board.

 

Joel :

Try putting a .01 uF cap in series with a 1.8K Ohm resistor between pins 1 & 5 of the LM386 on your "Slop Bucket".
That should get rid of most of the high frequency hiss on the LM386 without impacting SSB reception.

This is a N6KR (Wayne Burdick) trick; a little used feature of the LM386 called BASS Boost.
The values I specified are those that are used in Norcal 40a.

I made the same mod to my BITX40 and it works great on both SSB and CW.

Cheers

Michael VE3WMB 

Re: I need a V3 or V4 uBitx board.

 

Michael,

Thanks, I’ll give it a try as it is particularly bad on the SB. When I use a LM386 I usually build VK3YE’s version which has some good gain but tends to be more quiet. Steve pretty much used the application note version.

Joel
N6ALT

Re: Topic change

Sascha Bohnet | DL5SMB
 

Allison you wrote earlier that, if Q90 was changed to a BFR106, R81 (1kO) needs to be changed to somewhing between 2K-2,7kO. Is this correct?

Also, if C81 was changed to 470pF, do C261 and C262 also have to be removed? I think you wrote earlier, that these two capacitors could stay.
Also you did not wrote to also change R83 to 2,2O as Farhan does.

I just did these mods (changed Q90, R81, C81 and R83 - but left in C261 and C262) and though there is more power on the upper bands, I have only about 0,5 Watts on 80 and 40 Mhz. ( 5 W between 14 and 20 Mhz and 2 Watt on 10m).

What did I do wrong, did i miss something obvious?

I measured the voltage at R82 - according to messsage #43844 there should be 2,98V - I have about 1,5V (same frequency, 7150 Mhz). Was changing R81 wrong?

Sascha