Date   

Re: UBitX V6 Flrig rig xml file

Andy_501 <andrew.webb.501.ve4per@...>
 

Thank You Vic

I just added FT817 as general FLdigi rig file but still unable to comm to UBITx unit. I will log into groups.io and look through the archives to see what I can find.

On 2020-01-05 03:56, Vic WA4THR via Groups.Io wrote:
In general, the uBitX emulates a Yaesu FT817 for CAT commands. There is another thread where the appropriate com settings is discussed.

=Vic=


Re: #bitx40 #arduino #raduino Is the Raduino module still available? #raduino #bitx40 #arduino

Evan Hand
 

I believe that you will need to send an email to HFSignals@....  They do not offer parts separately on their web page.  There are clones available from other suppliers.  I would suggest you google Raduino to see what is currently available.

73
Evan
AC9TU 


Re: #bitx40 #arduino #raduino Is the Raduino module still available? #raduino #bitx40 #arduino

Mark GØNMY
 

I could not find any for sale on their website but I will have another look.

Thanks guys

 

 


--
----------------------------------------------------------------------------------------------------

G0NMY's Blog

May the Morse be with you!


Re: #bitx40 #arduino #raduino Is the Raduino module still available? #raduino #bitx40 #arduino

 

The uBitx raduino board is the same AFAIK. Just ask for one from HFSIGNALS.
You can upload bitx40 sketch in to it.

Raj


At 05/01/2020, you wrote:
Hello Mark,
                 I Also have a bitx 40 board  but missing the raduino and found the same as you so its sat here waiting..Regards Dave G0AYD FISTS15892 CWOPS 2159.

On Sun, 5 Jan 2020 at 03:05, Mark GØNMY <mark.g0nmy@...> wrote:

I know the bitx40 has ceased production, but are there any Raduino modules still available?

Obviously nothing found on HFsignals web site.

Thanks for any info.

73 Mark


Re: commande

fr4ta.daniel@...
 

Merci pout ta réponse Vic, mais je suis tellement impatient de le recevoir que quelques semaines va me sembler une éternité.
73 Daniel


Re: #bitx40 #arduino #raduino Is the Raduino module still available? #raduino #bitx40 #arduino

Dave Dixon
 

Hello Mark,
                 I Also have a bitx 40 board  but missing the raduino and found the same as you so its sat here waiting..Regards Dave G0AYD FISTS15892 CWOPS 2159.


On Sun, 5 Jan 2020 at 03:05, Mark GØNMY <mark.g0nmy@...> wrote:

I know the bitx40 has ceased production, but are there any Raduino modules still available?

Obviously nothing found on HFsignals web site.

Thanks for any info.

73 Mark
--
----------------------------------------------------------------------------------------------------

G0NMY's Blog

May the Morse be with you!


Re: commande

Vic WA4THR
 

I believe I read that after rushing to get the first shipments out they were taking a couple of weeks off before filling more orders. Patience!

Je crois avoir lu qu'après s'être précipité pour sortir les premiers envois, ils prenaient quelques semaines de congé avant de remplir plus de commandes. La patience!


=Vic=


Re: UBitX V6 Flrig rig xml file

Vic WA4THR
 

In general, the uBitX emulates a Yaesu FT817 for CAT commands. There is another thread where the appropriate com settings is discussed.

=Vic=


Re: V6 WIRE UP #v6 PC communication query #v6

Andy_501 <andrew.webb.501.ve4per@...>
 


On 2020-01-04 19:20, Andy_501 via Groups.Io wrote:
Found the "Tune" button but will not adjust to 10000 exactly as required only hits 10500 then 9000 + below or 11000 above. unable to attain suggested freq is there another adjustment somewhere?

For anyone else just new to this rig note if you connect it to a powered USB port you cant reset using power down as the powered USB port holds it on.


On 2020-01-04 6:37 p.m., Andy_501 via Groups.Io wrote:
Just got my rig powered up and tested functions on TFT display but have a couple of questions;

1. If I select WPM on the display it allows me to adjust speed of CW  and indicates setting below VFO A/B windows however the bottom text line always stays the same at "cw: 12wpm, 800hz"

2. I can change to modes LSB/USB/CW when on either VFO but when I plug in a TS jack for a hand key but no key attached, essentially an open circuit it generates a slow tone burst and TX mode active and outputs 10 W RF power to the dummy load on 10 MHz. If I short the key leads the bursts increase in frequency and it remains in TX mode transmitting pulsed RF. I had thought if I plugged key in nothing nothing would occur until the key was pressed they I would expect to hear a sidetone and see TX modes indicator active and RF on the wattmeter.

3.I am seeing the posts here about set up menu mode activation by holding a tune button down I suspect when turning power switch on but mine does not have such a button at least not visible on the external case; di I need to open it up to access said button?

4. I have the USB connection connected and am using Linux UbuntuStudio 18.04LTS  as an PC OS is there a specific linux terminal app or comm program I need to compile to be able to comm with the rig? If not a linux one can I run whatever might be available under winetricks?


Any tips appreciated.

Thanx & 73

Andy










Re: V6 WIRE UP #v6 PC communication query #v6

Andy_501 <andrew.webb.501.ve4per@...>
 


On 2020-01-04 18:37, Andy_501 via Groups.Io wrote:
Just got my rig powered up and tested functions on TFT display but have a couple of questions;

1. If I select WPM on the display it allows me to adjust speed of CW  and indicates setting below VFO A/B windows however the bottom text line always stays the same at "cw: 12wpm, 800hz"
Dscovered TUNE knob is also an Enter/Save/Toggle by pushing it. (also chgs to FAST TUNE)
2. I can change to modes LSB/USB/CW when on either VFO but when I plug in a TS jack for a hand key but no key attached, essentially an open circuit it generates a slow tone burst and TX mode active and outputs 10 W RF power to the dummy load on 10 MHz. If I short the key leads the bursts increase in frequency and it remains in TX mode transmitting pulsed RF. I had thought if I plugged key in nothing nothing would occur until the key was pressed they I would expect to hear a sidetone and see TX modes indicator active and RF on the wattmeter.
Looks like this one means further research into types of jacks used.

3.I am seeing the posts here about set up menu mode activation by holding a tune button down I suspect when turning power switch on but mine does not have such a button at least not visible on the external case; di I need to open it up to access said button?   See # 1.

4. I have the USB connection connected and am using Linux UbuntuStudio 18.04LTS  as an PC OS is there a specific linux terminal app or comm program I need to compile to be able to comm with the rig? If not a linux one can I run whatever might be available under winetricks? Still looking for a link to download an XML file for this rig to work with FLrig / FLDigi

Is this a help/community forum or a developer's forum?

Thanx & 73

Andy







Re: New file uploaded to BITX20@groups.io

Andy_501 <andrew.webb.501.ve4per@...>
 

It apparently was rejected by groups.io for posting so att below instead and moderator can place it in logical location.

On 2020-01-05 01:41, BITX20@groups.io Notification wrote:

Hello,

This email message is a notification to let you know that the following files have been uploaded to the Files area of the BITX20@groups.io group.

Uploaded By: Andy_501 <andrew.webb.501.ve4per@...>

Cheers,
The Groups.io Team


New file uploaded to BITX20@groups.io

BITX20@groups.io Notification <BITX20+notification@...>
 

Hello,

This email message is a notification to let you know that the following files have been uploaded to the Files area of the BITX20@groups.io group.

Uploaded By: Andy_501 <andrew.webb.501.ve4per@...>

Cheers,
The Groups.io Team


commande

fr4ta.daniel@...
 

Bonjour à tous,
J"ai passé une commande de ubitx v6 depuis le 17/12/2019 et jusqu’à ce jour je n'ai eu aucune nouvelle de HF signal sauf qu"ils ont bien reçu ma commande et le paiement, Que dois-je en penser. D'autres sont ils dans le même cas que moi?

Good morning, everyone,
I have placed an order for ubitx v6 since 17/12/2019 and to date I have had no news of HF signal except that they have received my order and payment, what should I think. Are others in the same case as me?

Bonne année 2020 à tous    Happy new year 2020


Re: one_stop_setting debugging #v6

Reed N
 

HA! Groups.io really doesn't want email addresses, so my post above got censored a bit, it would seem.

On step 9, "A@...:LSB" should read
"A @ 7040.20 : LSB" (spaces added to avoid censorship)

On step 11, "A@...:LSB" should read
"A @ 7123.00 : LSB" (spaces added to avoid censorship)


Reed


Re: ubitx #v6 Screen Speed Mod #v6

Reed N
 

Joel and @klimber - I created a new thread to discuss the one_stop_settings branch issues: https://groups.io/g/BITX20/topic/one_stop_setting_debugging/69432630

If you have any further feedback on that build, we can discuss there, but I'd like to keep this thread focused on the pdq_gfx_update branch.


Reed


one_stop_setting debugging #v6

Reed N
 

This is a discussion I'm splitting off from https://groups.io/g/BITX20/message/74440 and https://groups.io/g/BITX20/message/74449, where Joel and Armando indicated that the software branch https://github.com/reedbn/ubitxv6/tree/one_stop_settings wasn't working for them.

Hey guys. I did some testing, but it didn't turn up any obvious issues, so I'm really not quite sure why the one_shot_settings branch is causing problems. Here's the debugging steps I took:

  1. Load stock software (fe1ff169380f744d8a07c194dcae51e3264e2a39)
  2. Set cal: 0
  3. Set BFO: 11.053.0
  4. Tune A: 7040.2, LSB
  5. Tune B: 14040.25, USB
  6. Switch to A to force EEPROM save
  7. Measure clk2, clk1, clk0 pins (used nanoVNA by attaching to CH1 and measuring S21 response, since I left my oscilloscope at work)
  8. Load one_stop_settings software (b655704264d7160a1d1ee4c2d2b11386173ed324)
  9. Observe that new software shows A@...:LSB, as expected
  10. Re-measure clk2, clk1, clk0 pins
  11. Tune to A@...:LSB
  12. Re-measure clk2


Measurements from stock software:
clk2: 52.05MHz
clk1: 33.95MHz
clk0: 11.05MHz

Measurements from one_stop_settings software:
clk2: 52.05MHz
clk1: 33.95MHz
clk0: 11.05MHz
clk2 after retuning from 7040.20 to 7123.00: 52.13MHz
difference in clk2 measurements: 80kHz
difference in tuned frequencies: 82.8kHz - not an exact match, but well within my nanoVNA measurement error

Example plot of nanoVNA measurement (stock is reference/blue, one_stop_settings is active/yellow):


I wouldn't consider myself a master of RF, but if all three clocks are outputting the same frequencies in both the stock and one_stop_settings softwares, and changing the tuned value results in an equal change in the measured value, I would expect the RF side of the radio to be tuned and operate the same.

I did discover an issue with the BFO cal rendering, but it was only graphical as far as I can tell (fixed in 9a68846).

@Joel - can you describe what happened in a little more detail? Here's some specific prompts that would be helpful:
Did the radio receive anything at all? That is, could you hear normal static?
Did the screen/UI still work, in the sense that numbers were present, you could click on buttons, etc?
If the UI was working, did it display the expected settings when you updated, or were the VFO numbers all wacky?
To get back up and running, was it as easy as switching back to the PDQ branch and recalibrating, or were there extra steps you needed to take?

I finally put in an order for the remaining parts I need to get my radio built, so with any luck I'll be able to debug this myself in a few weeks :)


Reed


UBitX V6 Flrig rig xml file

Andy_501 <andrew.webb.501.ve4per@...>
 

Is there an xml rig fle for FLDigi /FLrig  that I can download to get Flrig comms with V6? If so what is the link to get it?


Thanks Andy


Re: Version 6 Arduino

Bob Bennett
 

Well now it refuses to compile on the Raspberry Pi4??

DK9SAS I changed the name as you suggested

Jack, I miss-typed. It is EEPROPM but when I go to compile I get  and error message
Setup.cpp:2134:10: error: ‘class EEPROMclass” has no member named ‘put’
    EEPROM.put(CW_KEY_TYPE, tmp_key); 

Bob nz2z
--
Bob
NZ2Z


#bitx40 #arduino #raduino Is the Raduino module still available? #raduino #bitx40 #arduino

Mark GØNMY
 

I know the bitx40 has ceased production, but are there any Raduino modules still available?

Obviously nothing found on HFsignals web site.

Thanks for any info.

73 Mark
--
----------------------------------------------------------------------------------------------------

G0NMY's Blog

May the Morse be with you!


Re: ubitx #v6 Screen Speed Mod #v6

Reed N
 

@klimber,

PDQ branch is very close to the stock firmware. I made changes to get the screen draw speed up, but tried to avoid changing anything else. Hopefully Ashhar will accept the PR, and then I can make PRs for other improvements off of that (which is what the one_stop_settings branch will be), but in general PRs are easier to accept the less stuff that has changed.


Reed

10781 - 10800 of 84516