Date   
Re: Spare board

Jim Sheldon
 

I believe I do.  A V4, I think.  Make me an offer.  I'll look for it in the morning and let you know for sure.  Please reply privately.

Jim, W0EB

On Dec 4, 2019, at 10:43 AM, Ted via Groups.Io <k3rta@...> wrote:

Anyone have a spare ųBitx main board lying around?  V3 would be fine, but any would do.


-Ted
 K3RTA

Re: Nextion Question

Mark Hatch
 

Dennis,

Are you trying to use the KD8CEC software or just writing your own sketches for the Nextion.

In relationship to KD8CEC, Ian did some fancy footwork in his approach where he created buffers of commands/datas that he transferred back and forth between the Nextion and the Raduino. He did not use the standard Auduino library. On the Nextion side, this meant that he used timers and events (like a button press) to actually program that guy. BTW: Becareful of the Nextion code. Spaces matter! Especially in if/elseif statements.

73
Mark

Re: Spare board

Tony Frey
 

Hi ted, I have 2 that I let the magic smoke out of.  Yours for the taking if you like to resurrect or parts.

Tony

Acta non Verba


From: BITX20@groups.io <BITX20@groups.io> on behalf of Ted via Groups.Io <k3rta@...>
Sent: Wednesday, December 4, 2019 11:43:39 AM
To: BITX20@groups.io <BITX20@groups.io>
Subject: [BITX20] Spare board
 
Anyone have a spare ųBitx main board lying around?  V3 would be fine, but any would do.


-Ted
 K3RTA

Re: A minor bug in the ubitx circuit

KG5MG
 

Ashhar,


Does this pertain to all boards of all versions?  I have a v5 I just finished.  All I need to do is make a power cord and a mic cable.  I haven't even applied power to the board, yet.
Do I need to make these alterations?

I have been inactive in amateur radio for over 10 years and just getting back into the hobby.  I don't have a spare parts box, unfortunately. I will need to order the replacement cap and resistor. Can you give specs on the SMD cap and resistor? I've never worked with them.

Do you anticipate any other alterations?  If so I will wait before ordering parts.

Hamp Yearwood
KG5MG 

Re: A minor bug in the ubitx circuit

paul_hvidston
 

Thanks for the helpful tip, Ashhar. I can see how this slipped through the evolution of the AF amp. I'm focusing on CW for this rig and have been busy up to this point working on the firmware. Had not even gotten to the point of transmitting CW with my brand new V5.

72 de N6MGN

standalone signal analyzer firmware hex file

talmadge huckabee
 

can somebody tell me where can I found the latest   standalone signal analyzer firmware (hex file)

Nextion Question

Dennis
 

Greetings,
I have a working ver5 uBitx using the "stock" display. I want to now use a 3.2" Nextion and CEC software. Could someone point me to the proper sketch. I am using what I believe to be the proper sketch and have set up ubitx.h like this:
"
//===========================================================================
// Compile Option
//===========================================================================
//Ubitx Board Version
#define UBITX_BOARD_VERSION 5           //v1 ~ v4 : 4, v5: 5
 
//Depending on the type of LCD mounted on the uBITX, uncomment one of the options below.
//You must select only one.
//#define UBITX_DISPLAY_LCD1602P        //LCD mounted on unmodified uBITX (Parallel)
//#define UBITX_DISPLAY_LCD1602I        //I2C type 16 x 02 LCD
//#define UBITX_DISPLAY_LCD1602I_DUAL   //I2C type 16 x02 LCD Dual
//#define UBITX_DISPLAY_LCD2004P        //24 x 04 LCD (Parallel)
//#define UBITX_DISPLAY_LCD2004I        //I2C type 24 x 04 LCD
#define UBITX_DISPLAY_NEXTION         //NEXTION LCD
 
//#define UBITX_DISPLAY_NEXTION_SAFE      //Only EEProm Write 770~775
#define I2C_LCD_MASTER_ADDRESS_DEFAULT  0x27     //0x27  //DEFAULT, if Set I2C Address by uBITX Manager, read from EEProm
#define I2C_LCD_SECOND_ADDRESS_DEFAULT  0x3F     //0x27  //only using Dual LCD Mode
"
After wiring in the Nextion I have power (it lights up), but no apparent link to the radino code. Pushing in the sd card does nothing (it's loaded with ubtix_32_E.tft) either.

I would appreciate someone pointing me in the right direction. At the moment I am at a loss as to how to proceed.

Kind Regards,
73, Dennis W7DRW

Re: A minor bug in the ubitx circuit

Ashhar Farhan
 

Precise! I should also wear my glasses while typing!


On Wed 4 Dec, 2019, 10:20 PM Jerry Gaffke via Groups.Io, <jgaffke=yahoo.com@groups.io> wrote:

This is kind of cryptic:
>  The volume with the 0.1uf cap in place of the R253 was too old. I placed a replaced a 10 K resistor in place of 1K at R250 and the volume is not reasonable.

Auto-correct is the devil's tool.
And typing with thumbs is an abomination.

Perhaps  old==low,  and  not==now  ??? 

Jerry
 
 
On Wed, Dec 4, 2019 at 01:57 AM, Ashhar Farhan wrote:
The volume with the 0.1uf cap in place of the R253 was too old. I placed a replaced a 10 K resistor in place of 1K at R250 and the volume is not reasonable.
You can solder the regular through hole resistors in place of the SMDs if your junk box is low on SMD components.
 
- f
Hide quoted text

 

On Wed, Dec 4, 2019 at 3:03 PM Ashhar Farhan <farhanbox@...> wrote:
 
Replace the R253 (a resistor) with a 0.1uf capacitor to get the sidetone going properly. 
 
The long story:
I was fooling around with an upgrade to Raduino, (more over the weekend) . I noticed that the sidetone was not proper. After a day's frustration, I put a scope probe on the sidetone line and saw that as the sidetone made a square wave of 0 to +5v and back, the average voltage rose to 2.5 v. This was directly coupled (well, me!) to the LM386 audio amp's volume control. Replacing the final resistor(R253) in the low pass filter with a 0.1uf capacitor fixes the problem. 
The problem was that the sidetone would 'vanish' after a start blip. That's because the LM386 was being pushed to the rail by the 2.5v DC on the input!
I am enclosing a picture of the mod. 
 
73, f
 

Re: A minor bug in the ubitx circuit

Jerry Gaffke
 


This is kind of cryptic:
>  The volume with the 0.1uf cap in place of the R253 was too old. I placed a replaced a 10 K resistor in place of 1K at R250 and the volume is not reasonable.

Auto-correct is the devil's tool.
And typing with thumbs is an abomination.

Perhaps  old==low,  and  not==now  ??? 

Jerry
 
 

On Wed, Dec 4, 2019 at 01:57 AM, Ashhar Farhan wrote:
The volume with the 0.1uf cap in place of the R253 was too old. I placed a replaced a 10 K resistor in place of 1K at R250 and the volume is not reasonable.
You can solder the regular through hole resistors in place of the SMDs if your junk box is low on SMD components.
 
- f
Hide quoted text

 

On Wed, Dec 4, 2019 at 3:03 PM Ashhar Farhan <farhanbox@...> wrote:
 
Replace the R253 (a resistor) with a 0.1uf capacitor to get the sidetone going properly. 
 
The long story:
I was fooling around with an upgrade to Raduino, (more over the weekend) . I noticed that the sidetone was not proper. After a day's frustration, I put a scope probe on the sidetone line and saw that as the sidetone made a square wave of 0 to +5v and back, the average voltage rose to 2.5 v. This was directly coupled (well, me!) to the LM386 audio amp's volume control. Replacing the final resistor(R253) in the low pass filter with a 0.1uf capacitor fixes the problem. 
The problem was that the sidetone would 'vanish' after a start blip. That's because the LM386 was being pushed to the rail by the 2.5v DC on the input!
I am enclosing a picture of the mod. 
 
73, f
 

Spare board

Ted
 

Anyone have a spare ųBitx main board lying around?  V3 would be fine, but any would do.


-Ted
 K3RTA

Re: 5/7" Nextion Firmware location

Joe Puma
 

Thank you but no worries Joshi,


When I was working on the menus I envisioned so many visual changes that could be made to the layout and pages. I figured that at some point there would cool themes available like the days of windows desktop themes. Like something that looks like a commercial radio, icon, or yaesu  or maybe a theme based on NASA or SpaceX. Or even cooler like the look of Star Treks computer screens from Next Generation or the like. Being that these menus are not easy to program or redesign I guess we don’t see much. Plus I don’t think much hams are fancy graphic designers let alone able to wrap their brain around the way the Nextion screens are programmed.  If I’m ever in the mood again I might have a go at a new redesign. 

Cheers,
73
Joe
KD2NFC 



On Dec 3, 2019, at 9:37 PM, Joshi Hp <hp.joshi.hp@...> wrote:


I am sorry I missed the contribution of Joe Puma. I thank him also.

On Tue, 3 Dec, 2019, 9:01 PM Mark Hatch, <mark2382@...> wrote:
Great!

But giving credit where credit is due, would not have had this if Joe Puma had not got it going. His work showed me the path to complete. 

73
Mark
AJ6CU

Re: Wiring up usb to back panel - V5

Morris Ford <morrishford@...>
 

Thanks for that. I have that board and I was planning to use it for the usb sauce. The info you sent has details about the wiring that I had been looking for.

In the long term my planning has a usb hub integrated in the cabinet as was suggested in response to my post and a raspberry pi in cabinet and adding sdr capability to the ubitx.

morris
k7lsv

On Tue, Dec 3, 2019 at 8:19 AM Maurice Bersan via Groups.Io <Vk6hly=yahoo.com@groups.io> wrote:

Re: A minor bug in the ubitx circuit

Ashhar Farhan
 

The volume with the 0.1uf cap in place of the R253 was too old. I placed a replaced a 10 K resistor in place of 1K at R250 and the volume is not reasonable.
You can solder the regular through hole resistors in place of the SMDs if your junk box is low on SMD components.

- f

On Wed, Dec 4, 2019 at 3:03 PM Ashhar Farhan <farhanbox@...> wrote:

Replace the R253 (a resistor) with a 0.1uf capacitor to get the sidetone going properly. 

The long story:
I was fooling around with an upgrade to Raduino, (more over the weekend) . I noticed that the sidetone was not proper. After a day's frustration, I put a scope probe on the sidetone line and saw that as the sidetone made a square wave of 0 to +5v and back, the average voltage rose to 2.5 v. This was directly coupled (well, me!) to the LM386 audio amp's volume control. Replacing the final resistor(R253) in the low pass filter with a 0.1uf capacitor fixes the problem. 
The problem was that the sidetone would 'vanish' after a start blip. That's because the LM386 was being pushed to the rail by the 2.5v DC on the input!
I am enclosing a picture of the mod. 

73, f


A minor bug in the ubitx circuit

Ashhar Farhan
 


Replace the R253 (a resistor) with a 0.1uf capacitor to get the sidetone going properly. 

The long story:
I was fooling around with an upgrade to Raduino, (more over the weekend) . I noticed that the sidetone was not proper. After a day's frustration, I put a scope probe on the sidetone line and saw that as the sidetone made a square wave of 0 to +5v and back, the average voltage rose to 2.5 v. This was directly coupled (well, me!) to the LM386 audio amp's volume control. Replacing the final resistor(R253) in the low pass filter with a 0.1uf capacitor fixes the problem. 
The problem was that the sidetone would 'vanish' after a start blip. That's because the LM386 was being pushed to the rail by the 2.5v DC on the input!
I am enclosing a picture of the mod. 

73, f


Re: ND6T/K5BCQ Automatic RF Gain Control aka "Kees" Board

KE2GKB
 

Hi Dale,
Not sure if anyone has a kee's board floating around but n8dah and I have made a drop in agc following the same schematic with a few improvements. Available for purchase over at our http://shop.kit-projects.com web-shop with over 400 of them sold! 

I use it on my v3 and I love it.

Otherwise, nd6t's website has a how to make one using double clad copper board. If you want to get the materials :)



On Tue, Dec 3, 2019 at 10:19 PM Dale Hardin <joe.dale.hardin@...> wrote:
Anyone have one of the "Kees" AGC boards laying around in excess to your needs?  I have a uBitx V5 on the way and I want to install this board.  Since Kees sold around 450+ of them; (1)They must work. and (2) There must be a few unbuilt kits around.  Thanks in advance, Dale KS4NS
--
Dale Hardin, KS4NS
Elberta, AL


--
Tim Keller - KE2GKB
https://shop.kit-projects.com

ND6T/K5BCQ Automatic RF Gain Control aka "Kees" Board

Dale Hardin
 

Anyone have one of the "Kees" AGC boards laying around in excess to your needs?  I have a uBitx V5 on the way and I want to install this board.  Since Kees sold around 450+ of them; (1)They must work. and (2) There must be a few unbuilt kits around.  Thanks in advance, Dale KS4NS
--
Dale Hardin, KS4NS
Elberta, AL

Re: 5/7" Nextion Firmware location

Joshi Hp
 

I am sorry I missed the contribution of Joe Puma. I thank him also.


On Tue, 3 Dec, 2019, 9:01 PM Mark Hatch, <mark2382@...> wrote:
Great!

But giving credit where credit is due, would not have had this if Joe Puma had not got it going. His work showed me the path to complete. 

73
Mark
AJ6CU

Re: Wiring up usb to back panel - V5

 

Hi Morris,

Just google for "usb connector pinout".  If you click on the images tab, you will see lots of helpful pictures to show how the wiring is done.

73,


Mark

Re: Wiring up usb to back panel - V5

Justin Phillips K5AXL
 


On Tue, Dec 3, 2019 at 3:27 PM Nigel G4ZAL <nigel@...> wrote:
I put a 4 port USB hub inside my case and now have one USB connection for raduino/sound/serial  -- works great for FT8 etc
More here...
http://ubitx.net/2018/11/09/using-a-usb-hub-for-a-single-usb-cable-to-your-pc/

HTH

Nigel - G4ZAL

Re: How to get rid of Local FM broadcast stations #ubitx

Gavin
 

Sorry I'm pretty new at these things. The ground wire connecting to the volume control, or to the DC connector? They look fine, what would be a way to test to make sure? Or anything to look out for?

Thanks!
- Gavin


On Mon, Dec 2, 2019 at 10:06 PM, Ashhar Farhan wrote:
Look carefully at your ground wire. it maybe floating.
 
- f

On Tue, Dec 3, 2019 at 9:33 AM Adrian Chadd <adrian.chadd@...> wrote:
hi,

post a photo of the wiring. you may need to shorten some wires and do
some RF bypassing?



-adrian

On Mon, 2 Dec 2019 at 19:33, <gdesplin@...> wrote:
>
> I tried taking it of the metal chassis and now the broadcast stations were quiet compared to a loud hum. The hum got more intense if I put my fingers close it the volume control wires. Also if things got moved around a bit it the broadcast stations would get loud and then stop when things moved back around again.
>
> On Mon, Dec 2, 2019 at 06:10 PM, Ashhar Farhan wrote:
>
> If the stations are heard regardless of your tuning, it is probable that they are being picked up by the audio system. Can you double check that the volume control and the speaker wires don't touch the chassis anywhere?
>
> - f
>
> On Tue 3 Dec, 2019, 1:36 AM , <gdesplin@...> wrote:
>>
>> Ok, so are you talking about getting this http://qrpme.com/?p=product&id=BCI like suggested at http://ubitx.net/fix-bci-filter/ or another one of their suggestions? Or maybe something like in this youtube video https://www.youtube.com/watch?v=fgQenFJOjr4 ?  Or did you have something else in mind? I'm all for whichever is simplest/easiest as I am a beginner.
>>
>> On Mon, Dec 2, 2019 at 10:20 AM, Adrian Chadd wrote:
>>
>> well, yeah. If you have AM stations close by then they can definitely
>> overwhelm your frontend.
>>
>> Get one of the bitx AM broadcast filters; they're high-pass filters
>> that drop-off around 3MHz. So yeah, you won't be receiving 160m, but
>> that's ok right?
>>
>>
>> -adrian
>>
>> On Mon, 2 Dec 2019 at 09:17, <gdesplin@...> wrote:
>>
>>
>> Ah, it looks like both these stations also have AM counterparts, at 1490 kHz and 1210 kHz. Does that change things?
>
>